[PATCH 0/2] Update guile-hall to 0.4.1.

  • Done
  • quality assurance status badge
Details
4 participants
  • Taiju HIGASHI
  • Ludovic Courtès
  • Maxime Devos
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Taiju HIGASHI
Severity
normal
T
T
Taiju HIGASHI wrote on 24 May 2022 15:26
(address . guix-patches@gnu.org)(name . Taiju HIGASHI)(address . higashi@taiju.info)
20220524132642.14122-1-higashi@taiju.info
Hi,

Since I wanted to update guile-hall to 0.4.1, I tried to update the dependent
library guile-config to 0.5.0. However, the incompatible change of
guile-config 0.5.0 made it impossible to build gwl. Therefore, I would like to
address this by temporarily adding a variant called guile-config-0.5.

Cheers

Taiju HIGASHI (2):
gnu: Add guile-config-0.5.
gnu: guile-hall: Update to 0.4.1.

gnu/packages/guile-xyz.scm | 27 ++++++++++++++++++++++-----
1 file changed, 22 insertions(+), 5 deletions(-)

--
2.36.0
T
T
Taiju HIGASHI wrote on 24 May 2022 15:29
[PATCH 2/2] gnu: guile-hall: Update to 0.4.1.
(address . 55612@debbugs.gnu.org)(name . Taiju HIGASHI)(address . higashi@taiju.info)
20220524132927.14418-3-higashi@taiju.info
* gnu/packages/guile-xyz.scm (guile-hall): Update to 0.4.1.
---
gnu/packages/guile-xyz.scm | 11 ++++++-----
1 file changed, 6 insertions(+), 5 deletions(-)

Toggle diff (45 lines)
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 15b3e787be..115afeeb9e 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -1706,16 +1706,17 @@ (define-public guile2.2-config
(define-public guile-hall
(package
(name "guile-hall")
- (version "0.3.1")
+ (version "0.4.1")
(source
(origin
(method git-fetch)
(uri (git-reference
(url "https://gitlab.com/a-sassmannshausen/guile-hall")
(commit version)))
- (file-name "guile-hall-0.3.1-checkout")
+ (file-name (git-file-name name version))
(sha256
- (base32 "1s24nigdra6rvclvy15l2aw00c3aq9vv8qwxylzs60darbl36206"))))
+ (base32
+ "0yrrik1v1xbik5h5q7w2cxrx6gvkmcdm32dl36i7xqdq8pr8sh2d"))))
(build-system gnu-build-system)
(arguments
`(#:modules
@@ -1744,7 +1745,7 @@ (define-public guile-hall
(string-append
(assoc-ref inputs input)
path))
- ,''("guile-config"))))))
+ ,''("guile-config-0.5"))))))
(out (assoc-ref outputs "out"))
(bin (string-append out "/bin/"))
(site (uncompiled-dir out "")))
@@ -1768,7 +1769,7 @@ (define-public guile-hall
(list autoconf automake pkg-config texinfo))
(inputs (list guile-3.0))
(propagated-inputs
- (list guile-config))
+ (list guile-config-0.5))
(synopsis "Guile project tooling")
(description
"Hall is a command-line application and a set of Guile libraries that
--
2.36.0
T
T
Taiju HIGASHI wrote on 24 May 2022 15:29
[PATCH 1/2] gnu: Add guile-config-0.5.
(address . 55612@debbugs.gnu.org)(name . Taiju HIGASHI)(address . higashi@taiju.info)
20220524132927.14418-2-higashi@taiju.info
* gnu/packages/guile-xyz.scm (guile-config-0.5): New variable.
---
gnu/packages/guile-xyz.scm | 16 ++++++++++++++++
1 file changed, 16 insertions(+)

Toggle diff (36 lines)
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 2c18fc138c..15b3e787be 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -41,6 +41,7 @@
;;; Copyright © 2021, 2022 Artyom V. Poptsov <poptsov.artyom@gmail.com>
;;; Copyright © 2022 Maxime Devos <maximedevos@telenet.be>
;;; Copyright © 2022 Zhu Zihao <all_but_last@163.com>
+;;; Copyright © 2022 Taiju HIGASHI <higashi@taiju.info>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1680,6 +1681,21 @@ (define-public guile-config
"https://gitlab.com/a-sassmannshausen/guile-config")
(license license:gpl3+)))
+(define-public guile-config-0.5
+ (package
+ (inherit guile-config)
+ (name "guile-config-0.5")
+ (version "0.5.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.com/a-sassmannshausen/guile-config")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256 (base32
+ "1xrl8bdcvvvbsrms0s3pp3d698541fv5b5kyy1z2kwli7akvdiph"))))))
+
(define-public guile2.2-config
(package
(inherit guile-config)
--
2.36.0
M
M
Maxime Devos wrote on 24 May 2022 16:10
Re: [bug#55612] [PATCH 0/2] Update guile-hall to 0.4.1.
062bf5f523196cae4da48085c8418ad076a72699.camel@telenet.be
Taiju HIGASHI schreef op di 24-05-2022 om 22:26 [+0900]:
Toggle quote (5 lines)
> Since I wanted to update guile-hall to 0.4.1, I tried to update the dependent
> library guile-config to 0.5.0. However, the incompatible change of
> guile-config 0.5.0 made it impossible to build gwl. Therefore, I would like to
> address this by temporarily adding a variant called guile-config-0.5.

Would it be feasible to make gwl compatible with 0.5.0? Otherwise, it
becomes impossible to install 'guile-hall' and the dependencies of
'gwl' in the same profile due to propagation conflicts, which can be
rather inconvenient

Greetings,
Maxime.
-----BEGIN PGP SIGNATURE-----

iI0EABYKADUWIQTB8z7iDFKP233XAR9J4+4iGRcl7gUCYoznZhccbWF4aW1lZGV2
b3NAdGVsZW5ldC5iZQAKCRBJ4+4iGRcl7k/XAQDB5lIHahgzTALpxUsiXnYFzURf
Dh3u71PQOyi7lWmTIAD/dzpr6EVT8Fv7Mfdkbwh04o8YcHY5YSTQCfId2fgkJwk=
=STd8
-----END PGP SIGNATURE-----


T
T
Taiju HIGASHI wrote on 24 May 2022 16:20
(name . Maxime Devos)(address . maximedevos@telenet.be)(address . 55612@debbugs.gnu.org)
875ylvqaf9.fsf@taiju.info
Hi Maxime,

Thanks for your reply.
I see. So separating the packages doesn't solve anything because of the
conflicts that occur?
I'll see if I can fix gwl to solve this.

Cheers
M
M
Maxime Devos wrote on 24 May 2022 16:26
(name . Taiju HIGASHI)(address . higashi@taiju.info)(address . 55612@debbugs.gnu.org)
d5019147620c82206fa25cf74715bbec30873ecc.camel@telenet.be
Taiju HIGASHI schreef op di 24-05-2022 om 23:20 [+0900]:
Toggle quote (3 lines)
> I see. So separating the packages doesn't solve anything because of the
> conflicts that occur?

Depends on how things are used. If you install two applications (*)
'foo' and 'bar' in the same profile that use different versions of
guile-config: no problem. If you are developing both 'foo' and 'bar'
in the same session, e.g. with "guix shell -D foo -D bar", then there's
a problem because the profile can contain only a single version of
their dependency guile-config (**). Some other problematic variations
are possible too.

(*) Normally applications don't propagate anything, they just put
things in 'inputs' and use sufficient amount of wrapping to avoid
propagation.

(**) IIUC, "guix shell -D" currently silently picks one version or the
other
-----BEGIN PGP SIGNATURE-----

iI0EABYKADUWIQTB8z7iDFKP233XAR9J4+4iGRcl7gUCYozrFhccbWF4aW1lZGV2
b3NAdGVsZW5ldC5iZQAKCRBJ4+4iGRcl7gNpAQDCTYM42AM9jDh2cPpCCwQM3sKz
cy0/c4xaw/jmrJiLLwEAzCXbo5CPXrajVdeikF9XbdtSZrUhC/1yZ6AErM81/wI=
=VakA
-----END PGP SIGNATURE-----


T
T
Taiju HIGASHI wrote on 26 May 2022 03:10
(name . Maxime Devos)(address . maximedevos@telenet.be)(address . 55612@debbugs.gnu.org)
87o7zlayk0.fsf@taiju.info
Hi Maxime,

Thanks!

I did not know that installing both packages in the same profile would
not cause problems.
It doesn't seem to be a problem in my usual use cases, but it is not
desirable.

I wrote a patch for gwl to fix building errors. However, I'm not
confident that patch, because I'm not familiar with gwl much, so I ask
in the gwl-devel mailing list whether my patch not have any problems.
L
L
Ludovic Courtès wrote on 3 Jun 2022 23:23
Re: bug#55612: [PATCH 0/2] Update guile-hall to 0.4.1.
(name . Taiju HIGASHI)(address . higashi@taiju.info)
87y1ydh258.fsf_-_@gnu.org
Hi,

Taiju HIGASHI <higashi@taiju.info> skribis:

Toggle quote (5 lines)
> Thanks for your reply.
> I see. So separating the packages doesn't solve anything because of the
> conflicts that occur?
> I'll see if I can fix gwl to solve this.

Indeed, I get this:

Toggle snippet (29 lines)
$ guix build gwl --with-latest=guile-config
guix build: warning: cannot authenticate source of 'guile-config', version 0.5.1
updating checkout of 'https://gitlab.com/a-sassmannshausen/guile-config'...
retrieved commit 6a00702d044663fef6d6d619f4aeb75417e1b10b
substitute: updating substitutes from 'https://ci.guix.gnu.org'... 100.0%
substitute: updating substitutes from 'https://bordeaux.guix.gnu.org'... 100.0%
substitute: updating substitutes from 'https://guix.bordeaux.inria.fr'... 100.0%
The following derivations will be built:
/gnu/store/9xnjw36mzhshqh3x7vmwi6q45v10i7rc-gwl-0.4.0.drv
/gnu/store/0mwhz53h7whs3nahiv6d8drclqajz282-guile-config-0.5.1.drv
/gnu/store/z9vkfyxlsnh1v2v4mmbdymxwza1dwmd3-guile-config-0.5.1-checkout.drv

[…]

starting phase `build'
GEN guix/extensions/workflow.scm
mv -f "guix/extensions/workflow.scm-t" "guix/extensions/workflow.scm"
GEN gwl/config.go
ice-9/boot-9.scm:1685:16: In procedure raise-exception:
Syntax error:
gwl/config.scm:66:8: argument: extraneous field initializers (optional?) in form (argument (name (quote file)) (optional? #f) (test file-exists?) (handler identity) (example "/path/to/my-workflow.w"))
make: *** [Makefile:1574: gwl/config.go] Error 1
error: in phase 'build': uncaught exception:
%exception #<&invoke-error program: "make" arguments: ("GUILE_AUTO_COMPILE=0") exit-status: 2 term-signal: #f stop-signal: #f>
phase `build' failed after 0.3 seconds
command "make" "GUILE_AUTO_COMPILE=0" failed with status 2
builder for `/gnu/store/9xnjw36mzhshqh3x7vmwi6q45v10i7rc-gwl-0.4.0.drv' failed with exit code 1

How about one of these two options:

1. Provide both versions of guile-config, use the old one in GWL, at
the risk of preventing installation of guile-hall + gwl in the same
profile (which is probably not much of a problem in practice).

2. Patch GWL so it works with the latest guile-config.

That should unblock the situation. WDYT?

Thanks,
Ludo’.
T
T
Taiju HIGASHI wrote on 4 Jun 2022 00:24
(name . Ludovic Courtès)(address . ludo@gnu.org)
DF71FADA-B937-4083-8C2D-A70516FA7B3D@taiju.info
Hi Ludovic,

Thank you for the comment!

Toggle quote (10 lines)
>How about one of these two options:
>
> 1. Provide both versions of guile-config, use the old one in GWL, at
> the risk of preventing installation of guile-hall + gwl in the same
> profile (which is probably not much of a problem in practice).
>
> 2. Patch GWL so it works with the latest guile-config.
>
>That should unblock the situation. WDYT?

The second option is preferable and is currently being worked on.

I have the patch reviewed for adequacy.


Cheers,
--
Taiju
R
R
Ricardo Wurmus wrote on 6 Jul 2022 10:40
[PATCH 0/2] Update guile-hall to 0.4.1.
(address . 55612@debbugs.gnu.org)
87mtdm1vl2.fsf@elephly.net
The GWL now supports guile-config 0.5.x. My apologies for the delay.

Taiju Higashi, could you please update your patch so that it updates to
guile-config 0.5.1? Once ready I can apply it. Thanks!

(The GWL should get a new release soon, but that shouldn’t block this
issue.)

--
Ricardo
T
T
Taiju HIGASHI wrote on 6 Jul 2022 15:46
[PATCH v2 1/2] gnu: guile-config: Update to 0.5.1.
(address . rekado@elephly.net)
20220706134645.30409-1-higashi@taiju.info
* gnu/packages/guile-xyz.scm (guile-config): Update to 0.5.1.
---
gnu/packages/guile-xyz.scm | 5 +++--
1 file changed, 3 insertions(+), 2 deletions(-)

Toggle diff (32 lines)
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 2456509b97..3952fb6261 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -42,6 +42,7 @@
;;; Copyright © 2022 Maxime Devos <maximedevos@telenet.be>
;;; Copyright © 2022 Zhu Zihao <all_but_last@163.com>
;;; Copyright © 2022 Antero Mejr <antero@mailbox.org>
+;;; Copyright © 2022 Taiju HIGASHI <higashi@taiju.info>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1614,7 +1615,7 @@ (define-public guile-dbd-mysql
(define-public guile-config
(package
(name "guile-config")
- (version "0.4.2")
+ (version "0.5.1")
(source
(origin
(method git-fetch)
@@ -1623,7 +1624,7 @@ (define-public guile-config
(commit version)))
(file-name (git-file-name name version))
(sha256 (base32
- "09028ylbddjdp3d67zdjz3pnsjqz6zs2bfck5rr3dfaa0qjap40n"))))
+ "0s708k6qnk9155bjrcy1f1v7lqhlpaj4mjip46sr3iw85hca92wz"))))
(build-system gnu-build-system)
(native-inputs
(list autoconf automake pkg-config texinfo))
--
2.36.1
T
T
Taiju HIGASHI wrote on 6 Jul 2022 15:46
[PATCH v2 2/2] gnu: guile-hall: Update to 0.4.1.
(address . rekado@elephly.net)
20220706134645.30409-2-higashi@taiju.info
* gnu/packages/guile-xyz.scm (guile-hall): Update to 0.4.1.
---
gnu/packages/guile-xyz.scm | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)

Toggle diff (26 lines)
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 3952fb6261..bf118537b9 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -1653,16 +1653,16 @@ (define-public guile2.2-config
(define-public guile-hall
(package
(name "guile-hall")
- (version "0.3.1")
+ (version "0.4.1")
(source
(origin
(method git-fetch)
(uri (git-reference
(url "https://gitlab.com/a-sassmannshausen/guile-hall")
(commit version)))
- (file-name "guile-hall-0.3.1-checkout")
+ (file-name (git-file-name name version))
(sha256
- (base32 "1s24nigdra6rvclvy15l2aw00c3aq9vv8qwxylzs60darbl36206"))))
+ (base32 "0yrrik1v1xbik5h5q7w2cxrx6gvkmcdm32dl36i7xqdq8pr8sh2d"))))
(build-system gnu-build-system)
(arguments
`(#:modules
--
2.36.1
T
T
Taiju HIGASHI wrote on 6 Jul 2022 15:56
Re: [bug#55612] [PATCH 0/2] Update guile-hall to 0.4.1.
(name . Ricardo Wurmus)(address . rekado@elephly.net)(address . 55612@debbugs.gnu.org)
87bku2ibtw.fsf@taiju.info
Hi Ricarod,

Toggle quote (8 lines)
> The GWL now supports guile-config 0.5.x. My apologies for the delay.
>
> Taiju Higashi, could you please update your patch so that it updates to
> guile-config 0.5.1? Once ready I can apply it. Thanks!
>
> (The GWL should get a new release soon, but that shouldn’t block this
> issue.)

I sent the patch. However, the GWL build fails.
I also made a patch for GWL package definitions.
If there are problems with the GWL patch, please ignore this patch.
From cc9ca4bfdf295affeeaba6422cbbd13e66332387 Mon Sep 17 00:00:00 2001
From: Taiju HIGASHI <higashi@taiju.info>
Date: Wed, 6 Jul 2022 22:48:59 +0900
Subject: [PATCH] gnu: gwl: Fix build.

* gnu/packages/package-management.scm (gwl): Apply patches for newer versions
of guile-config
* gnu/packages/patches/gwl-fix-build-guile-config-0.5.1.patch: Add the patch.
---
gnu/packages/package-management.scm | 5 +-
.../gwl-fix-build-guile-config-0.5.1.patch | 75 +++++++++++++++++++
2 files changed, 79 insertions(+), 1 deletion(-)
create mode 100644 gnu/packages/patches/gwl-fix-build-guile-config-0.5.1.patch

Toggle diff (106 lines)
diff --git a/gnu/packages/package-management.scm b/gnu/packages/package-management.scm
index e485e34bca..3c82d847a6 100644
--- a/gnu/packages/package-management.scm
+++ b/gnu/packages/package-management.scm
@@ -21,6 +21,7 @@
;;; Copyright © 2021, 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2021 John Kehayias <john.kehayias@protonmail.com>
;;; Copyright © 2022 Zhu Zihao <all_but_last@163.com>
+;;; Copyright © 2022 Taiju HIGASHI <higashi@taiju.info>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1308,7 +1309,9 @@ (define-public gwl
(uri (string-append "mirror://gnu/gwl/gwl-" version ".tar.gz"))
(sha256
(base32
- "0sgaaq430l3dqmqqiikfb0ilxnd2cq28626y18kxx5c781qwpys9"))))
+ "0sgaaq430l3dqmqqiikfb0ilxnd2cq28626y18kxx5c781qwpys9"))
+ (patches
+ (search-patches "gwl-fix-build-guile-config-0.5.1.patch"))))
(build-system gnu-build-system)
(arguments
`(#:parallel-build? #false ; for reproducibility
diff --git a/gnu/packages/patches/gwl-fix-build-guile-config-0.5.1.patch b/gnu/packages/patches/gwl-fix-build-guile-config-0.5.1.patch
new file mode 100644
index 0000000000..496fd652e1
--- /dev/null
+++ b/gnu/packages/patches/gwl-fix-build-guile-config-0.5.1.patch
@@ -0,0 +1,75 @@
+From c0f281d2ef927686ed42f9c44828c501011a60dc Mon Sep 17 00:00:00 2001
+From: Ricardo Wurmus <rekado@elephly.net>
+Date: Tue, 5 Jul 2022 16:58:53 +0200
+Subject: Require guile-config >= 0.5.0.
+
+---
+ configure.ac | 5 +++++
+ gwl/config.scm.in | 14 +++++++++-----
+ 2 files changed, 14 insertions(+), 5 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index a6897f4..eadc82f 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -42,6 +42,11 @@ GUILE_MODULE_REQUIRED(gcrypt hash)
+ GUILE_MODULE_REQUIRED(pfds sets)
+ GUILE_MODULE_REQUIRED(drmaa v1 high)
+ GUILE_MODULE_REQUIRED(config)
++GUILE_MODULE_CHECK(guile_config_too_old,(config api),(argument (name 'foo) (optional? 'old)),supports `optional?' field in argument definition)
++if test "x$guile_config_too_old" = "xyes"; then
++ AC_MSG_ERROR([Guile Config needs to be version 0.5.0 or higher.])
++fi
++
+ AC_PATH_PROG([DOT], [dot])
+ if test "x$DOT" = "x"; then
+ AC_MSG_ERROR(['dot' could not be found; please check your Graphviz installation.])
+diff --git a/gwl/config.scm.in b/gwl/config.scm.in
+index 20a562e..d64eca3 100644
+--- a/gwl/config.scm.in
++++ b/gwl/config.scm.in
+@@ -65,7 +65,6 @@ workflow.")
+ (list
+ (argument
+ (name 'file)
+- (optional? #false)
+ (test file-exists?)
+ (handler identity)
+ (example "/path/to/my-workflow.w"))))
+@@ -95,12 +94,19 @@ workflow.")
+ (character #\i)
+ (synopsis "Specify workflow input NAME, optionally mapped to FILE")
+ (example "NAME[=FILE]")
+- (test string?))
++ (default #false)
++ (test (match-lambda
++ (#false #true)
++ (value (string? value)))))
+ (switch
+ (name 'output)
+ (character #\o)
+ (synopsis "Set LOCATION as output for a workflow")
+- (example "LOCATION"))
++ (example "LOCATION")
++ (default #false)
++ (test (match-lambda
++ (#false #true)
++ (value (string? value)))))
+ (switch
+ (name 'engine)
+ (character #\e)
+@@ -147,11 +153,9 @@ format) of the specified workflow.")
+ (list
+ (argument
+ (name 'file)
+- (optional? #false)
+ (test file-exists?)
+ (handler identity)
+ (example "/path/to/my-workflow.w")))))
+-
+ (configuration
+ (name 'web)
+ (synopsis "Start the web interface")
+--
+cgit v1.1
+
--
2.36.1
Regards,
--
Taiju
T
T
Taiju HIGASHI wrote on 16 Jul 2022 13:27
(name . Ricardo Wurmus)(address . rekado@elephly.net)(address . 55612@debbugs.gnu.org)
87tu7hz4a8.fsf@taiju.info
Hi Ricardo,

Toggle quote (12 lines)
>> The GWL now supports guile-config 0.5.x. My apologies for the delay.
>>
>> Taiju Higashi, could you please update your patch so that it updates to
>> guile-config 0.5.1? Once ready I can apply it. Thanks!
>>
>> (The GWL should get a new release soon, but that shouldn’t block this
>> issue.)
>
> I sent the patch. However, the GWL build fails.
> I also made a patch for GWL package definitions.
> If there are problems with the GWL patch, please ignore this patch.

Is there a problem with the patch I sent you?
Please let me know if there is any work left for me to do.

Thanks,
--
Taiju
R
R
Ricardo Wurmus wrote on 21 Jul 2022 17:54
(name . Taiju HIGASHI)(address . higashi@taiju.info)(address . 55612-done@debbugs.gnu.org)
87h73asbom.fsf@elephly.net
Taiju HIGASHI <higashi@taiju.info> writes:

Toggle quote (17 lines)
> Hi Ricardo,
>
>>> The GWL now supports guile-config 0.5.x. My apologies for the delay.
>>>
>>> Taiju Higashi, could you please update your patch so that it updates to
>>> guile-config 0.5.1? Once ready I can apply it. Thanks!
>>>
>>> (The GWL should get a new release soon, but that shouldn’t block this
>>> issue.)
>>
>> I sent the patch. However, the GWL build fails.
>> I also made a patch for GWL package definitions.
>> If there are problems with the GWL patch, please ignore this patch.
>
> Is there a problem with the patch I sent you?
> Please let me know if there is any work left for me to do.

I applied your patches to update guile-config and guile-hall.
I had already fixed the problem in the GWL and made a new release
today; I then updated the gwl package.

Thanks for your patience!

--
Ricardo
Closed
T
T
Taiju HIGASHI wrote on 22 Jul 2022 02:05
(name . Ricardo Wurmus)(address . rekado@elephly.net)(address . 55612@debbugs.gnu.org)
87y1wmm2q3.fsf@taiju.info
Toggle quote (4 lines)
> I applied your patches to update guile-config and guile-hall.
> I had already fixed the problem in the GWL and made a new release
> today; I then updated the gwl package.

Thank you!

--
Taiju
?
Your comment

This issue is archived.

To comment on this conversation send an email to 55612@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 55612
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch