Artyom V. Poptsov wrote 3 years ago
(address . guix-patches@gnu.org)
Hello,
this patch adds "langcodes" Python module[1] under the name
"python-langcodes".
References:
1. "A Python library for working with and comparing language codes."
From 4a55bea39a617c64f354170777db4ba420045459 Mon Sep 17 00:00:00 2001
From: "Artyom V. Poptsov" <poptsov.artyom@gmail.com>
Date: Sun, 22 May 2022 21:50:37 +0300
Subject: [PATCH] gnu: Add python-langcodes
* gnu/packages/python-xyz.scm (python-langcodes): New variable.
---
gnu/packages/python-xyz.scm | 31 +++++++++++++++++++++++++++++++
1 file changed, 31 insertions(+)
Toggle diff (41 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 3c4fa16d16..95099feb04 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -31449,3 +31449,34 @@ written in C.")
(synopsis "Cython bindings for MurmurHash2")
(description "This package provides Cython bindings for MurmurHash2.")
(license license:expat)))
+
+(define-public python-langcodes
+ (package
+ (name "python-langcodes")
+ (version "3.3.0")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "langcodes" version))
+ (sha256
+ (base32
+ "1xkyh3qdcigb18qiimbwl2669y22hhdmd89mqcd270c7lbahfkbr"))))
+ (build-system python-build-system)
+ (native-inputs (list python-pytest))
+ (inputs (list python))
+ (home-page "https://github.com/explosion/catalogue")
+ (synopsis "Python library for working with language codes")
+ (description
+ "A Python library for working with and comparing language
+codes.
+
+\"langcodes\" implements @url{http://tools.ietf.org/html/bcp47, BCP 47}, the
+IETF Best Current Practices on Tags for Identifying Languages. BCP 47 is also
+known as RFC 5646. It subsumes ISO 639 and is backward compatible with it, and
+it also implements recommendations from the @url{http://cldr.unicode.org/,
+Unicode CLDR}.
+
+langcodes can also refer to a database of language properties and names, built
+from Unicode CLDR and the IANA subtag registry, if you install
+@code{language_data}.")
+ (license license:expat)))
+
--
2.25.1
--
Artyom "avp" Poptsov <poptsov.artyom@gmail.com>
Home page: https://memory-heap.org/~avp/
CADR Hackerspace co-founder: https://cadrspace.ru/
GPG: D0C2 EAC1 3310 822D 98DE B57C E9C5 A2D9 0898 A02F
-----BEGIN PGP SIGNATURE-----
iQEzBAEBCgAdFiEE0MLqwTMQgi2Y3rV86cWi2QiYoC8FAmKKhsoACgkQ6cWi2QiY
oC+hxAgAq/vzQi0F2vcPjLy88nIuvAGTEGsnebPjADdTTAwyB2WM/Uw9W7uvPjaF
axi4gGE0kwbNPObG0ePMj/ILmaPzmfW5CnorUuZ4+AMkpvo0XnKKcJ39VY6UOd6A
G84dVztNZ+/CMq41Rd1lv9Os11LiKSb4w0/JTlYRk7NFqcyAviYTb4XZ8PtR+aLg
88dCzpsbky/cUgl5KqtPplfseLHyEl+N27YnRNvGuJVxj5SCOQXa5Fv9/LYPj8pg
GENMD9hgp9EiT/kXKNQZPP29CGNzPQYjaxJAC7IulKdzs4/3Egt/O0BIE2iNnh/y
nZC24Bkov4CGM1/C2SuqJLdkv44eBg==
=C8pZ
-----END PGP SIGNATURE-----