[PATCH] gnu: Add python-langcodes

  • Done
  • quality assurance status badge
Details
3 participants
  • Ludovic Courtès
  • Mathieu Othacehe
  • Artyom V. Poptsov
Owner
unassigned
Submitted by
Artyom V. Poptsov
Severity
normal

Debbugs page

Artyom V. Poptsov wrote 3 years ago
(address . guix-patches@gnu.org)
87leutflf9.fsf@gmail.com
Hello,

this patch adds "langcodes" Python module[1] under the name
"python-langcodes".

References:
1. "A Python library for working with and comparing language codes."
From 4a55bea39a617c64f354170777db4ba420045459 Mon Sep 17 00:00:00 2001
From: "Artyom V. Poptsov" <poptsov.artyom@gmail.com>
Date: Sun, 22 May 2022 21:50:37 +0300
Subject: [PATCH] gnu: Add python-langcodes

* gnu/packages/python-xyz.scm (python-langcodes): New variable.
---
gnu/packages/python-xyz.scm | 31 +++++++++++++++++++++++++++++++
1 file changed, 31 insertions(+)

Toggle diff (41 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 3c4fa16d16..95099feb04 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -31449,3 +31449,34 @@ written in C.")
(synopsis "Cython bindings for MurmurHash2")
(description "This package provides Cython bindings for MurmurHash2.")
(license license:expat)))
+
+(define-public python-langcodes
+ (package
+ (name "python-langcodes")
+ (version "3.3.0")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "langcodes" version))
+ (sha256
+ (base32
+ "1xkyh3qdcigb18qiimbwl2669y22hhdmd89mqcd270c7lbahfkbr"))))
+ (build-system python-build-system)
+ (native-inputs (list python-pytest))
+ (inputs (list python))
+ (home-page "https://github.com/explosion/catalogue")
+ (synopsis "Python library for working with language codes")
+ (description
+ "A Python library for working with and comparing language
+codes.
+
+\"langcodes\" implements @url{http://tools.ietf.org/html/bcp47, BCP 47}, the
+IETF Best Current Practices on Tags for Identifying Languages. BCP 47 is also
+known as RFC 5646. It subsumes ISO 639 and is backward compatible with it, and
+it also implements recommendations from the @url{http://cldr.unicode.org/,
+Unicode CLDR}.
+
+langcodes can also refer to a database of language properties and names, built
+from Unicode CLDR and the IANA subtag registry, if you install
+@code{language_data}.")
+ (license license:expat)))
+
--
2.25.1
--
Artyom "avp" Poptsov <poptsov.artyom@gmail.com>
CADR Hackerspace co-founder: https://cadrspace.ru/
GPG: D0C2 EAC1 3310 822D 98DE B57C E9C5 A2D9 0898 A02F
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEE0MLqwTMQgi2Y3rV86cWi2QiYoC8FAmKKhsoACgkQ6cWi2QiY
oC+hxAgAq/vzQi0F2vcPjLy88nIuvAGTEGsnebPjADdTTAwyB2WM/Uw9W7uvPjaF
axi4gGE0kwbNPObG0ePMj/ILmaPzmfW5CnorUuZ4+AMkpvo0XnKKcJ39VY6UOd6A
G84dVztNZ+/CMq41Rd1lv9Os11LiKSb4w0/JTlYRk7NFqcyAviYTb4XZ8PtR+aLg
88dCzpsbky/cUgl5KqtPplfseLHyEl+N27YnRNvGuJVxj5SCOQXa5Fv9/LYPj8pg
GENMD9hgp9EiT/kXKNQZPP29CGNzPQYjaxJAC7IulKdzs4/3Egt/O0BIE2iNnh/y
nZC24Bkov4CGM1/C2SuqJLdkv44eBg==
=C8pZ
-----END PGP SIGNATURE-----

Mathieu Othacehe wrote 3 years ago
(name . Artyom V. Poptsov)(address . poptsov.artyom@gmail.com)(address . 55580@debbugs.gnu.org)
877d5vndev.fsf@gnu.org
Hello Artyom,

Toggle quote (2 lines)
> + (inputs (list python))

This line is implicit, you can remove it.

Toggle quote (2 lines)
Is that the correct home-page?

Toggle quote (3 lines)
> + "A Python library for working with and comparing language
> +codes.

You can merge those lines.

Toggle quote (3 lines)
> +
> +\"langcodes\" implements @url{http://tools.ietf.org/html/bcp47, BCP 47}, the

@code{python-langcodes} implements...

Toggle quote (2 lines)
> +langcodes can also refer to a database of language properties and names, built

@code{python-langcodes} can also...

Toggle quote (3 lines)
> +from Unicode CLDR and the IANA subtag registry, if you install
> +@code{language_data}.")

That could be @code{python-language-data} is the package is created, I
guess :)

Could you please send an updated version?

Thanks,

Mathieu
Artyom V. Poptsov wrote 3 years ago
(name . Mathieu Othacehe)(address . othacehe@gnu.org)(address . 55580@debbugs.gnu.org)
877d5sz3tc.fsf@gmail.com
Hello Mathieu,

thank you for the patch review.

Here's the updated patch.

- Artyom
From fade3d87c1b64e4279787d2bb28b0e61d2b7ee61 Mon Sep 17 00:00:00 2001
From: "Artyom V. Poptsov" <poptsov.artyom@gmail.com>
Date: Sun, 22 May 2022 21:50:37 +0300
Subject: [PATCH] gnu: Add python-langcodes

* gnu/packages/python-xyz.scm (python-langcodes): New variable.
---
gnu/packages/python-xyz.scm | 29 +++++++++++++++++++++++++++++
1 file changed, 29 insertions(+)

Toggle diff (39 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index f3d7fab973..82c2c87e4c 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -29403,3 +29403,32 @@ Information about these scales can be
@url{https://en.wikipedia.org/wiki/List_of_musical_scales_and_modes, found on
Wikipedia}.")
(license license:expat)))
+
+(define-public python-langcodes
+ (package
+ (name "python-langcodes")
+ (version "3.3.0")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "langcodes" version))
+ (sha256
+ (base32
+ "1xkyh3qdcigb18qiimbwl2669y22hhdmd89mqcd270c7lbahfkbr"))))
+ (build-system python-build-system)
+ (native-inputs (list python-pytest))
+ (inputs (list python))
+ (home-page "https://github.com/rspeer/langcodes")
+ (synopsis "Python library for working with language codes")
+ (description
+ "A Python library for working with and comparing language codes.
+
+@code{python-langcodes} implements @url{http://tools.ietf.org/html/bcp47, BCP
+47}, the IETF Best Current Practices on Tags for Identifying Languages. BCP
+47 is also known as RFC 5646. It subsumes ISO 639 and is backward compatible
+with it, and it also implements recommendations from the
+@url{http://cldr.unicode.org/, Unicode CLDR}.
+
+@code{python-langcodes} can also refer to a database of language properties
+and names, built from Unicode CLDR and the IANA subtag registry, if you
+install @code{python-language-data}.")
+ (license license:expat)))
--
2.25.1
--
Artyom "avp" Poptsov <poptsov.artyom@gmail.com>
CADR Hackerspace co-founder: https://cadrspace.ru/
GPG: D0C2 EAC1 3310 822D 98DE B57C E9C5 A2D9 0898 A02F
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEE0MLqwTMQgi2Y3rV86cWi2QiYoC8FAmKfou8ACgkQ6cWi2QiY
oC+u5Qf/XhAvfRjBXaTmw+bAl9D0s9IPrrtMY0CVPTIiHn9JARe18f2S1ISO822m
+DZ5FOpx4M/Nc+fr8L0ZDxJNYM8ozmY5XfQF2TY6hbDIZWiBqMIyP11wM+wkvmZG
HDwHFSKvC2OlBisa7No1JrHSReT8CZm+h1/1HsfBXPr+JJfD2hBJfC1hU9JJaf+A
IaS8tLLphrKyozNucb3IPJeKimiqdWeuoZf0VcvHOPyGxgDtFmtPQt6EFgrBaNkj
aIhrtOy01RpqbUg3/Bbkvzjj4l9U/2WnVDmpWgurt7ek8vfJt+S4XrHSdIyp0Jdq
ilcwgzRq0B6P56+R4O5eMrFx+Ne+NQ==
=tcBJ
-----END PGP SIGNATURE-----

Artyom V. Poptsov wrote 3 years ago
(name . Mathieu Othacehe)(address . othacehe@gnu.org)(address . 55580@debbugs.gnu.org)
8735ggz37k.fsf@gmail.com
Oh, I forgot to remote 'python' from inputs.

Please find double-fixed patch attached.

- Artyom
From 1e6e6361d3c4cb007f8cd160797b8c4a1f7aacdc Mon Sep 17 00:00:00 2001
From: "Artyom V. Poptsov" <poptsov.artyom@gmail.com>
Date: Sun, 22 May 2022 21:50:37 +0300
Subject: [PATCH] gnu: Add python-langcodes

* gnu/packages/python-xyz.scm (python-langcodes): New variable.
---
gnu/packages/python-xyz.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)

Toggle diff (38 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index f3d7fab973..628bce5d8f 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -29403,3 +29403,31 @@ Information about these scales can be
@url{https://en.wikipedia.org/wiki/List_of_musical_scales_and_modes, found on
Wikipedia}.")
(license license:expat)))
+
+(define-public python-langcodes
+ (package
+ (name "python-langcodes")
+ (version "3.3.0")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "langcodes" version))
+ (sha256
+ (base32
+ "1xkyh3qdcigb18qiimbwl2669y22hhdmd89mqcd270c7lbahfkbr"))))
+ (build-system python-build-system)
+ (native-inputs (list python-pytest))
+ (home-page "https://github.com/rspeer/langcodes")
+ (synopsis "Python library for working with language codes")
+ (description
+ "A Python library for working with and comparing language codes.
+
+@code{python-langcodes} implements @url{http://tools.ietf.org/html/bcp47, BCP
+47}, the IETF Best Current Practices on Tags for Identifying Languages. BCP
+47 is also known as RFC 5646. It subsumes ISO 639 and is backward compatible
+with it, and it also implements recommendations from the
+@url{http://cldr.unicode.org/, Unicode CLDR}.
+
+@code{python-langcodes} can also refer to a database of language properties
+and names, built from Unicode CLDR and the IANA subtag registry, if you
+install @code{python-language-data}.")
+ (license license:expat)))
--
2.25.1
--
Artyom "avp" Poptsov <poptsov.artyom@gmail.com>
CADR Hackerspace co-founder: https://cadrspace.ru/
GPG: D0C2 EAC1 3310 822D 98DE B57C E9C5 A2D9 0898 A02F
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEE0MLqwTMQgi2Y3rV86cWi2QiYoC8FAmKfpf8ACgkQ6cWi2QiY
oC+pvgf+LQrZkQhCylssBelL24zcK350Gp2/HeXKYmOzbao4eZX4PWTas3iPhYMu
mOwIC1nR+2xshtHCyYWUMWcf1iLWHDO2J+ti8ojGRIOL8iGXUKrSDHRUvc0PUjtk
i66KRHSLMvolwEX0DxeHDjJqTy0zDE0mjhjJhqq1F7YkZsCOvLEzg+ICfOzH4QV/
P7ZTEslkWeI4dNmB7GWV/fj60oD5MGefOle4XMdMvPFMV1b4CIucY+B9cVylbRvf
VCkCQI6t+4Hze7D6qWD+siXE3rDyIHbopiuy8xMN1KQRAyKfwFOA0PWGYJDFL2TE
wPqu2wzSuunapDlXXn6MgYIeON3zDA==
=r4ai
-----END PGP SIGNATURE-----

Artyom V. Poptsov wrote 3 years ago
(name . Mathieu Othacehe)(address . othacehe@gnu.org)(address . 55580@debbugs.gnu.org)
87ilp5vsbw.fsf@gmail.com
Hello Mathieu,

have you had any chance to review my updated patch?

Thanks!

- Artyom

--
Artyom "avp" Poptsov <poptsov.artyom@gmail.com>
CADR Hackerspace co-founder: https://cadrspace.ru/
GPG: D0C2 EAC1 3310 822D 98DE B57C E9C5 A2D9 0898 A02F
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEE0MLqwTMQgi2Y3rV86cWi2QiYoC8FAmKm/9MACgkQ6cWi2QiY
oC8cogf/YXTV16fDHfq6WtbDjclJf+atw3aETERgC7/n8EsY/e94I5cRdeNfnYjQ
apQwElmL/O+NfUGU/EfY/MwivZ2rHwVEQDOfccqDl0LARMZqJpoidCSy41ZXjqF4
WBdiGpm2YgKbb1RPzuVohgQVPv/3YHeQzKvwaRyGe0XzmpnYZlF8JF2qAR0r0ZZt
ZTZ0EbJmIy6u0u1R0fbPATFScb5zdtKKjJcFvoU+kpF7wYdqvAIq7IT1+3X0tLDF
A7EyX2WqfveIDkSEgB3B8aevi857TE11tVTzSX5uLVhUbbV754OIx9SisOKksx0j
5DbuR+fNQxnGFE8HWvRBvj1UQ8ea5w==
=R/X0
-----END PGP SIGNATURE-----

Ludovic Courtès wrote 3 years ago
(name . Artyom V. Poptsov)(address . poptsov.artyom@gmail.com)
87sfo8svr1.fsf_-_@gnu.org
Hi,

"Artyom V. Poptsov" <poptsov.artyom@gmail.com> skribis:

Toggle quote (7 lines)
> From 1e6e6361d3c4cb007f8cd160797b8c4a1f7aacdc Mon Sep 17 00:00:00 2001
> From: "Artyom V. Poptsov" <poptsov.artyom@gmail.com>
> Date: Sun, 22 May 2022 21:50:37 +0300
> Subject: [PATCH] gnu: Add python-langcodes
>
> * gnu/packages/python-xyz.scm (python-langcodes): New variable.

I made the beginning of the description a sentence and committed it.

Thanks,
Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 55580@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 55580
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help