[PATCH] gnu: Add python-wasabi

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Artyom V. Poptsov
Owner
unassigned
Submitted by
Artyom V. Poptsov
Severity
normal

Debbugs page

Artyom V. Poptsov wrote 3 years ago
(address . guix-patches@gnu.org)
87pmk6f4xn.fsf@gmail.com
Hello,

this patch adds "wasabi" Python module[1] under the name
"python-wasabi".

'python-wasabi' is the one of the dependencies of spaCy -- an NLP
library for Python.[2]

- Artyom

References:
1. "A lightweight console printing and formatting toolkit"
From 355e95d400aa0fc74a89f51a55c44bad3c0c0216 Mon Sep 17 00:00:00 2001
From: "Artyom V. Poptsov" <poptsov.artyom@gmail.com>
Date: Sun, 22 May 2022 09:34:05 +0300
Subject: [PATCH] gnu: Add python-wasabi

* gnu/packages/python-xyz.scm (python-wasabi): New variable.
---
gnu/packages/python-xyz.scm | 18 ++++++++++++++++++
1 file changed, 18 insertions(+)

Toggle diff (28 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 3c4fa16d16..3ca48438eb 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -31449,3 +31449,21 @@ written in C.")
(synopsis "Cython bindings for MurmurHash2")
(description "This package provides Cython bindings for MurmurHash2.")
(license license:expat)))
+
+(define-public python-wasabi
+ (package
+ (name "python-wasabi")
+ (version "0.9.1")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "wasabi" version))
+ (sha256
+ (base32
+ "1kwqfalq7qxs9f7xb2m055g01qpbznyzxl7sjnzjdvvhkczg39md"))))
+ (build-system python-build-system)
+ (native-inputs (list python-pytest))
+ (home-page "https://github.com/ines/wasabi")
+ (synopsis "Console printing and formatting toolkit")
+ (description
+ "A lightweight console printing and formatting toolkit for Python.")
+ (license license:expat)))
--
2.25.1
--
Artyom "avp" Poptsov <poptsov.artyom@gmail.com>
CADR Hackerspace co-founder: https://cadrspace.ru/
GPG: D0C2 EAC1 3310 822D 98DE B57C E9C5 A2D9 0898 A02F
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEE0MLqwTMQgi2Y3rV86cWi2QiYoC8FAmKJ2kQACgkQ6cWi2QiY
oC9J/Af+OQyLomo/kcSzZOUijaJe9YaxvVTe6GpKB/2F+uKj5uRKBklS2C/nS0kn
wAOI3l5WX10EePTAetmuoLaCH/OwdnWNezbfHI2rHT1plqPLIW9YQYbdKwkjit7k
T0EOnar/Wzb2Kc8YFFThoEpi2QjBEX0jMf+2yzQKEx02Dd8AuH23s9mSXXv9WY3x
8YsujmfMYnzHJRb4wbrVJ/s+uiamulaDtYdWyE76IZDp8Jm+8k3wcNAZ/NAamZnc
lvR2P43Zt/wRTpRU4o4sOhbdQjP/Kx8iavhAcppJgPvaBhpAufma4mbSo3plAljE
KtBWJ/lf8AZkKsk6Tb/7wOjslEuJJA==
=/pr7
-----END PGP SIGNATURE-----

Ludovic Courtès wrote 3 years ago
(name . Artyom V. Poptsov)(address . poptsov.artyom@gmail.com)(address . 55570-done@debbugs.gnu.org)
87h75ad5px.fsf@gnu.org
"Artyom V. Poptsov" <poptsov.artyom@gmail.com> skribis:

Toggle quote (7 lines)
> From 355e95d400aa0fc74a89f51a55c44bad3c0c0216 Mon Sep 17 00:00:00 2001
> From: "Artyom V. Poptsov" <poptsov.artyom@gmail.com>
> Date: Sun, 22 May 2022 09:34:05 +0300
> Subject: [PATCH] gnu: Add python-wasabi
>
> * gnu/packages/python-xyz.scm (python-wasabi): New variable.

Applied with the fixlet below, thanks!

Ludo’.
Toggle diff (12 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 1b056e5a15..c010d87a01 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -31784,5 +31784,6 @@ (define-public python-wasabi
(home-page "https://github.com/ines/wasabi")
(synopsis "Console printing and formatting toolkit")
(description
- "A lightweight console printing and formatting toolkit for Python.")
+ "This package provides a lightweight console printing and formatting
+toolkit for Python.")
(license license:expat)))
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 55570@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 55570
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help