Artyom V. Poptsov wrote 3 years ago
(address . guix-patches@gnu.org)
Hello,
this patch adds "blis" Python module[1] under the name "python-blis".
- Artyom
References:
1. "Fast matrix-multiplication as a self-contained Python library"
From 3d22d0e5f7929ac1b782217ec207a5e462316c66 Mon Sep 17 00:00:00 2001
From: "Artyom V. Poptsov" <poptsov.artyom@gmail.com>
Date: Sun, 22 May 2022 01:14:26 +0300
Subject: [PATCH] gnu: Add python-blis
* gnu/packages/python-xyz.scm (python-blis): New variable.
---
gnu/packages/python-xyz.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)
Toggle diff (34 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 3c4fa16d16..95b85b9931 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -31449,3 +31449,27 @@ written in C.")
(synopsis "Cython bindings for MurmurHash2")
(description "This package provides Cython bindings for MurmurHash2.")
(license license:expat)))
+
+(define-public python-blis
+ (package
+ (name "python-blis")
+ (version "0.9.0")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "blis" version))
+ (sha256
+ (base32
+ "0adl7knj11rglg6l9nfqccl8kgs2v1c7qllv9c5kf5k796hir7k9"))))
+ (build-system python-build-system)
+ (native-inputs (list python-pytest python-cython))
+ (inputs (list python python-numpy python-hypothesis))
+ (arguments
+ ;; XXX: Tests are failing with the following error:
+ ;; AttributeError: module 'numpy.__config__' has no attribute 'blas_ilp64_opt_info'
+ (list #:tests? #f))
+ (home-page "https://github.com/explosion/cython-blis")
+ (synopsis "Fast matrix-multiplication Python library")
+ (description
+ "This package provides the @url{https://github.com/flame/blis,
+Blis linear algebra} routines as a self-contained Python C-extension.")
+ (license license:bsd-3)))
--
2.25.1
--
Artyom "avp" Poptsov <poptsov.artyom@gmail.com>
Home page: https://memory-heap.org/~avp/
CADR Hackerspace co-founder: https://cadrspace.ru/
GPG: D0C2 EAC1 3310 822D 98DE B57C E9C5 A2D9 0898 A02F
-----BEGIN PGP SIGNATURE-----
iQEzBAEBCgAdFiEE0MLqwTMQgi2Y3rV86cWi2QiYoC8FAmKJZP0ACgkQ6cWi2QiY
oC8VnQf+OTRCZWGDEXb7ujqZNsjogn05h+RRG16jDfZZq+B0MFxpga8ycN+4oEHH
VFZX9A9UbOJR276krwtTVGgVBnsVp6NyNCwR9b69G39ihMITiS6fA8i7RXNT+aie
4rS0kgZIP1x8nWq01qACk27QTGMPLIIhGFiAub0ZyeI/gpHLTeGpxCUHva+rV0cP
zp/SoukUjl6KGpq9GXSlFEoKoJnOjU/Q0DtaT5g2us4OHOo3GDVoF+ep0NmVRruO
guzQPau/230OMuY0l/TKxLtrtWvdVJiDjXijBKlZlk1QxlFs1VBK4UsfpVYckjLl
R3mLuUxNgNwT9fVgxgzq3PfQKfTL2Q==
=8DRQ
-----END PGP SIGNATURE-----