[PATCH] gnu: Add emacs-corfu-doc.

  • Done
  • quality assurance status badge
Details
3 participants
  • jgart
  • Maxime Devos
  • Tobias Geerinckx-Rice
Owner
unassigned
Submitted by
jgart
Severity
normal
J
(address . guix-patches@gnu.org)(name . jgart)(address . jgart@dismail.de)
20220520231347.12506-1-jgart@dismail.de
* gnu/packages/emacs-xyz.scm (emacs-corfu-doc): New variable.
---
gnu/packages/emacs-xyz.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)

Toggle diff (39 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index b2e2cffffe..e21c4f4308 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -3134,6 +3134,32 @@ (define-public emacs-corfu
@code{completion-in-region} counterpart of the Vertico minibuffer UI.")
(license license:gpl3+)))
+(define-public emacs-corfu-doc
+ ;; There are no tagged version releases.
+ (let ((commit "96b5de8cced0f2c2069748305bb72cf2db77200e")
+ (revision "0"))
+ (package
+ (name "emacs-corfu-doc")
+ (version (git-version "0.5.1" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/galeo/corfu-doc")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "18xgm8jjppdq43i4wa36pbwlh4jxdgkmfbj13w5q4c7b9cy7r3mf"))))
+ (build-system emacs-build-system)
+ (propagated-inputs (list emacs-corfu))
+ (home-page "https://github.com/galeo/corfu-doc")
+ (synopsis "Documentation popup for Corfu")
+ (description
+"The @code{corfu-doc} package provides a way to display a documentation
+popup for completion candidates when using @code{emacs-corfu}. It can
+be regarded as @code{emacs-company-quickhelp} for @code{emacs-corfu}.")
+ (license license:gpl3+))))
+
(define-public emacs-cape
(package
(name "emacs-cape")
--
2.35.3
M
M
Maxime Devos wrote on 21 May 2022 14:43
a6ad26f2f20f12aaff0201924e05be7457a2f295.camel@telenet.be
jgart via Guix-patches via schreef op vr 20-05-2022 om 18:13 [-0500]:
Toggle quote (8 lines)
> +(define-public emacs-corfu-doc
> +  ;; There are no tagged version releases.
> +  (let ((commit "96b5de8cced0f2c2069748305bb72cf2db77200e")
> +        (revision "0"))
> +    (package
> +      (name "emacs-corfu-doc")
> +      (version (git-version "0.5.1" revision commit))

That commit says: ‘Version 0.5.1’, so it seems a proper version /
formal release to me, with no need for git-version.

Greetings,
Maxime.
-----BEGIN PGP SIGNATURE-----

iI0EABYKADUWIQTB8z7iDFKP233XAR9J4+4iGRcl7gUCYojehxccbWF4aW1lZGV2
b3NAdGVsZW5ldC5iZQAKCRBJ4+4iGRcl7kCWAQClhkMWNmH8LBrta/EqMw9KEqFw
sX1GBxUeWUH4QAXJgwEA3ziu2w9J2xEiczWswZKtykDm6lA4rC2NSaXg677WiAU=
=1BZ+
-----END PGP SIGNATURE-----


J
[PATCH v2] gnu: Add emacs-corfu-doc.
(address . 55551@debbugs.gnu.org)(name . jgart)(address . jgart@dismail.de)
20220522001930.17894-1-jgart@dismail.de
* gnu/packages/emacs-xyz.scm (emacs-corfu-doc): New variable.

Hi Maxime,

Here's a version 2 of the original patch with your suggestions.

Thank you for the code review.

all best,

jgart
---
gnu/packages/emacs-xyz.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (38 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index b2e2cffffe..c271d0521c 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -3134,6 +3134,31 @@ (define-public emacs-corfu
@code{completion-in-region} counterpart of the Vertico minibuffer UI.")
(license license:gpl3+)))
+(define-public emacs-corfu-doc
+ (let ((commit "96b5de8cced0f2c2069748305bb72cf2db77200e")
+ (revision "0"))
+ (package
+ (name "emacs-corfu-doc")
+ (version "0.5.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/galeo/corfu-doc")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "18xgm8jjppdq43i4wa36pbwlh4jxdgkmfbj13w5q4c7b9cy7r3mf"))))
+ (build-system emacs-build-system)
+ (propagated-inputs (list emacs-corfu))
+ (home-page "https://github.com/galeo/corfu-doc")
+ (synopsis "Documentation popup for Corfu")
+ (description
+"The @code{corfu-doc} package provides a way to display a documentation
+popup for completion candidates when using @code{emacs-corfu}. It can
+be regarded as @code{emacs-company-quickhelp} for @code{emacs-corfu}.")
+ (license license:gpl3+))))
+
(define-public emacs-cape
(package
(name "emacs-cape")
--
2.35.3
T
T
Tobias Geerinckx-Rice wrote on 5 Jun 2022 18:10
(name . jgart)(address . jgart@dismail.de)
87czfngke9@nckx
jgart via Guix-patches via ???
Toggle quote (3 lines)
> Here's a version 2 of the original patch with [Maxime's]
> suggestions.

I bumped it further to 0.6.3, and removed the revision &
let-binding entirely.

Pushed to master; thanks!

Kind regards,

T G-R
-----BEGIN PGP SIGNATURE-----

iIMEARYKACsWIQT12iAyS4c9C3o4dnINsP+IT1VteQUCYpzVvg0cbWVAdG9iaWFz
LmdyAAoJEA2w/4hPVW15AFIA/1KBavMxqEN1DbyAUOF1XCfCBBicpEtRR/pSRhJf
bVpiAP9sSGkFv0livfry2oUMcSc2WSbIUd7l1BOSwrrMz/ZmDw==
=hBf2
-----END PGP SIGNATURE-----

?
Your comment

This issue is archived.

To comment on this conversation send an email to 55551@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 55551
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch