Wamm K. D wrote 3 years ago
(address . guix-patches@gnu.org)(name . Wamm K. D)(address . jaft.r@outlook.com)
---
This isn't the end-goal package to add but a dependency.
'Trying to add Siglo so sending this one, first; Siglo will follow.
gnu/packages/python-xyz.scm | 29 +++++++++++++++++++++++++++++
1 file changed, 29 insertions(+)
Toggle diff (39 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 5094ef068c..ee7850b518 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -31177,3 +31177,32 @@ (define-public python-deepmerge
"The @code{deep-merge} Python library provides a toolset to deeply merge
nested data structures in Python like lists and dictionaries.")
(license license:expat)))
+
+(define python-gatt
+ (package
+ (name "python-gatt")
+ (version "0.2.7")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "gatt" version))
+ (sha256 (base32
+ "0fjf066jixk30fr8xwfalwfnhqpr56yv0cccyypnx2qp9bi9svb2"))))
+ (inputs (list python-dbus python-pygobject))
+ (build-system python-build-system)
+ (home-page "https://github.com/getsenic/gatt-python")
+ (synopsis "Bluetooth GATT SDK for Python")
+ (description "The Bluetooth GATT SDK for Python helps you implementing and
+communicating with any Bluetooth Low Energy device that has a GATT profile. It
+supports:
+@itemize @bullet
+@item Discovering nearby Bluetooth Low Energy devices
+@item Connecting and disconnecting devices
+@item Implementing your custom GATT profile
+@item Accessing all GATT services
+@item Accessing all GATT characteristics
+@item Reading characteristic values
+@item Writing characteristic values
+@item Subscribing for characteristic value change notifications
+@end itemize
+Currently Linux is the only platform supported by this library.")
+ (license license:expat)))
--
2.36.0