[PATCH] gnu: qpwgraph: Add qpwgraph.

  • Done
  • quality assurance status badge
Details
3 participants
  • Efraim Flashner
  • J. Sims
  • Mathieu Othacehe
Owner
unassigned
Submitted by
J. Sims
Severity
normal

Debbugs page

J. Sims wrote 3 years ago
(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
jZ2MdgKVH08B8uOpaJAoaVBKD8zdxKSC6gEH79L-V6gWETzZfigMnEK5mzwu0yVnVp2z_-MuzON57qD-4aQv04IKOcgMe6vy6AWDM95jcdo=@protonmail.com
Hello,

This patch adds the qpwgraph application, which is a visual interface to
PipeWire connections. Besides managing connections and just being
neat, it can also serve to easily check that a PipeWire configuration
is setup and working (the purpose for which I packaged it). Hopefully,
others will find it useful as well.

Note that I put it in gnu/packages/audio.scm because that made the most
sense to me after a quick check of the packages files. If there's a
better one, I can redo the patch with it in that file.

Thanks,
Juli

--------------------------BEGIN-PATCH------------------------------

* gnu/packages/audio.scm (qpwgraph): Add qpwgraph.
---
gnu/packages/audio.scm | 30 ++++++++++++++++++++++++++++++
1 file changed, 30 insertions(+)

Toggle diff (47 lines)
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 6b16269670..6d1aadaf1d 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -37,6 +37,7 @@
;;; Copyright \302\251 2021 jgart <jgart@dismail.de>
;;; Copyright \302\251 2021 Aleksandr Vityazev <avityazev@posteo.org>
;;; Copyright \302\251 2022 Arjan Adriaanse <arjan@adriaan.se>
+;;; Copyright \302\251 2022 Juliana Sims <jtsims@protonmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -5762,3 +5763,32 @@ (define-public odio-sacd
and DSD streams.")
(home-page "https://tari.in/www/software/odio-sacd/")
(license license:gpl3+)))
+
+(define-public qpwgraph
+ (package
+ (name "qpwgraph")
+ (version "0.2.6")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.freedesktop.org/rncbc/qpwgraph")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1gn4zy1b4hggk9andh7cbwkrd7l4djmnipbyyyv9srcsnvqv3wkg"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:tests? #f))
+ (inputs (list alsa-lib
+ pipewire-0.3
+ ;; qtsvg is still on version 5; use qtbase-5 to match
+ qtbase-5
+ qtsvg))
+ (native-inputs (list pkg-config))
+ (synopsis "PipeWire graph manager")
+ (description
+ "qpwgraph is a graph manager dedicated to PipeWire, using the Qt C++ framework.
+It provides a visual interface to audio and video connections managed by PipeWire.")
+ (home-page "https://gitlab.freedesktop.org/rncbc/qpwgraph")
+ (license license:gpl2)))

base-commit: b1cfd39d0164bcbd6aa97672eb87bad234de6ca4
--
2.36.0
Mathieu Othacehe wrote 3 years ago
(name . J. Sims)(address . jtsims@protonmail.com)(address . 55510@debbugs.gnu.org)
8735ginbpn.fsf@gnu.org
Hello,

Thanks for this patch.

Toggle quote (2 lines)
> + (version "0.2.6")

Looks like the 0.3.1 is out there.

Toggle quote (13 lines)
> + (source (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://gitlab.freedesktop.org/rncbc/qpwgraph")
> + (commit (string-append "v" version))))
> + (file-name (git-file-name name version))
> + (sha256
> + (base32
> + "1gn4zy1b4hggk9andh7cbwkrd7l4djmnipbyyyv9srcsnvqv3wkg"))))
> + (build-system cmake-build-system)
> + (arguments
> + `(#:tests? #f))

Why are the tests disabled?

Toggle quote (3 lines)
> + "qpwgraph is a graph manager dedicated to PipeWire, using the Qt C++ framework.
> +It provides a visual interface to audio and video connections managed by PipeWire.")

Those two lines are too long, please wrap them.

Thanks,

Mathieu
J. Sims wrote 3 years ago
Re: [PATCH] gnu: qpwgraph: Add qpwgraph.
(name . 55510@debbugs.gnu.org)(address . 55510@debbugs.gnu.org)
d5UQ2TgzrYX3qvQ_EqRuNJzWs0gJfvLtXlR-ojljdN2SCp9qsb2GwznyT8CIJnf5V_bQXWTHvNpFvLBO4IZ9vM2Ca-gq3OSwiDyTDoOcqKU=@protonmail.com
This is an updated version of the patch taking into account previous comments, updated to the latest release.

- Juli

--------------------------BEGIN-PATCH------------------------------

* gnu/packages/audio.scm (qpwgraph): Add qpwgraph.
---
gnu/packages/audio.scm | 31 +++++++++++++++++++++++++++++++
1 file changed, 31 insertions(+)

Toggle diff (46 lines)
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index e0e1554..c5cf7b4 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -37,6 +37,7 @@
;;; Copyright © 2021 jgart <jgart@dismail.de>
;;; Copyright © 2021 Aleksandr Vityazev <avityazev@posteo.org>
;;; Copyright © 2022 Arjan Adriaanse <arjan@adriaan.se>
+;;; Copyright © 2022 Juliana Sims <jtsims@protonmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -5747,3 +5748,33 @@ (define-public odio-sacd
and DSD streams.")
(home-page "https://tari.in/www/software/odio-sacd/")
(license license:gpl3+)))
+
+(define-public qpwgraph
+ (package
+ (name "qpwgraph")
+ (version "0.3.2")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.freedesktop.org/rncbc/qpwgraph")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1zja4klvzbfwi14ihiahl8zm869h0c1yrpfkzvixxjcps372hh07"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:tests? #f)) ;; no tests
+ (inputs (list alsa-lib
+ pipewire-0.3
+ ;; qtsvg is still on version 5; use qtbase-5 to match
+ qtbase-5
+ qtsvg))
+ (native-inputs (list pkg-config))
+ (synopsis "PipeWire graph manager")
+ (description
+ "qpwgraph is a graph manager dedicated to PipeWire, using the Qt C++
+framework. It provides a visual interface to audio and video connections
+managed by PipeWire.")
+ (home-page "https://gitlab.freedesktop.org/rncbc/qpwgraph")
+ (license license:gpl2)))
--
2.36.1
Efraim Flashner wrote 3 years ago
Re: [bug#55510] [PATCH] gnu: qpwgraph: Add qpwgraph.
(name . J. Sims)(address . jtsims@protonmail.com)(address . 55510-done@debbugs.gnu.org)
YsVFKVVlrHDWQjlE@3900XT
Thanks. Patch pushed!


--
Efraim Flashner <efraim@flashner.co.il> אפרים פלשנר
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAmLFRSkACgkQQarn3Mo9
g1HpZQ/8D9cfgPh+UtpvGPeq/ckztFjW678MJ1QIbsy/kxsc5ctCTmc2vK2XiY5i
CjT4BuNxsdHv6ORh2cBJo8Krv/18BjUEoB4gWNc81fltp3c935rN1pibwj78EVoH
e5OKHxXEir01kIRlMTdMJYoXAqzTzujhwyVVyfADBY18QmHcYoASC2W8etuDcD7i
aWI3Jqok8wb1jNU9wu4EwIN2VWbH3BHsitErRT2qP7YwyCQ6JiLKLwVY45whLxT/
VuYoFC67uUWCM2wQsRe73R3hkUcQPb/kwvdDnmEKu6d1ULuyiKlYrfvLwf83ACus
DzhMVokBL886yvJ2qeX/AOK/I0c2m88e4XVqe0wUPGML7vPdSf6ioy4eTP/KZaUP
W10FV4d1kXmUQLRi6cJT5B+BHR+loDa33WYbduTJz5PG/BlfUkKtHkrYfyO0KwP1
qXwDFsOI/mpsUg8+g/HO3z2Tx65+RJjwUBmEnMR7IZvpxtVrPepYugx576MleO3F
/LNVZJfAC+AaAJ3qgGeiZf6F9vnlba8JX2KCuUH0nQs39v6FEYiX0cV4FaaG/In7
BHul5CcXOWAlIIKwv//3v5U1zgTAs8eal5CPCHNWzy3pg5CRtldgyifsqt85/bP4
gAu4Bh18Q/TZbDslhy8Ab38iz7NECtU6f4bZKMJqBSE3EUZwWZE=
=VHOw
-----END PGP SIGNATURE-----


Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 55510@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 55510
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help