[PATCH 0/1] gnu: Add calceph

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Sharlatan Hellseher
Severity
normal
S
S
Sharlatan Hellseher wrote on 18 May 2022 22:40
(address . guix-patches@gnu.org)
CAO+9K5oneapKAe-_99AQq3K8=TL6b8iD=-Q63L0FHy6vLeCM6Q@mail.gmail.com
Hi Guix team!
While saving up to update python-asdf due to dependency on newer
python-pytest package, I've found one more astronomical library which
it is simple to pack with few farther packages depending on it.
gnu/packages/astronomy.scm | 39 ++++++++++++++++++++++++++++++++++++++
1 file changed, 39 insertions(+)
base-commit: 4f7cd5daa2291ac976ad47a66306b982033c09f0
--
… ??? ????? - ???????????? ?????????????? ?????? ??????? ????????
????? ????? ????? ? ??? ??????, ??????????? ????? ???????, ??
?????????? ?? ? ????????? ??????? ????? ? ?????????????????.
S
S
Sharlatan Hellseher wrote on 18 May 2022 22:50
[PATCH 1/1]: gnu: Add calceph
(address . 55509@debbugs.gnu.org)
CAO+9K5pH8tc8mMhY2kRvMAmkeJB+Oa=Pt84L9i_R1PChQ2yv1A@mail.gmail.com
--
… ??? ????? - ???????????? ?????????????? ?????? ??????? ????????
????? ????? ????? ? ??? ??????, ??????????? ????? ???????, ??
?????????? ?? ? ????????? ??????? ????? ? ?????????????????.
From 896533a7f558d975d96367eb1ae3fe34e90a5c8f Mon Sep 17 00:00:00 2001
From: Sharlatan Hellseher <sharlatanus@gmail.com>
Date: Wed, 18 May 2022 21:31:18 +0100
Subject: [PATCH 1/1] gnu: Add calceph

* gnu/packages/astronomy.scm (calceph): New variable.
---
gnu/packages/astronomy.scm | 39 ++++++++++++++++++++++++++++++++++++++
1 file changed, 39 insertions(+)

Toggle diff (59 lines)
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index c209b1538f..5d2c8fb46a 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -39,6 +39,7 @@ (define-module (gnu packages astronomy)
#:use-module (gnu packages compression)
#:use-module (gnu packages curl)
#:use-module (gnu packages fontutils)
+ #:use-module (gnu packages gcc)
#:use-module (gnu packages gettext)
#:use-module (gnu packages gl)
#:use-module (gnu packages glib)
@@ -71,6 +72,44 @@ (define-module (gnu packages astronomy)
#:use-module (ice-9 match)
#:use-module (srfi srfi-1))
+(define-public calceph
+ (package
+ (name "calceph")
+ (version "3.5.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://www.imcce.fr/content/medias/recherche/equipes/asd/calceph/calceph-"
+ version ".tar.gz"))
+ (sha256
+ (base32 "078wn773pwf4pg9m0h0l00g4aq744pq1rb6kz6plgdpzp3hhpk1k"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ (list gfortran))
+ (home-page "https://www.imcce.fr/inpop/calceph")
+ (synopsis "Astronomical library to access the binary planetary ephemeris files")
+ (description
+ "The CALCEPH Library is designed to access the binary planetary ephemeris files,
+such INPOPxx and JPL DExxx ephemeris files, (called @code{original JPL binary} or
+@code{INPOP 2.0 or 3.0 binary} ephemeris files in the next sections) and the SPICE
+kernel files (called @code{SPICE} ephemeris files in the next sections). At the
+moment, supported SPICE files are:
+
+@itemize
+@item text Planetary Constants Kernel (KPL/PCK) files;
+
+@item binary PCK (DAF/PCK) files;
+
+@item binary SPK (DAF/SPK) files containing segments of type 1, 2, 3, 5, 8, 9,
+12, 13, 17, 18, 19, 20, 21, 102, 103 and 120;
+
+@item meta kernel (KPL/MK) files;
+
+@item frame kernel (KPL/FK) files. Only a basic support is provided;)
+@end itemize\n")
+ (license license:cecill)))
+
(define-public cfitsio
(package
(name "cfitsio")
--
2.36.0
L
L
Ludovic Courtès wrote on 30 May 2022 16:32
Re: bug#55509: [PATCH 0/1] gnu: Add calceph
(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)(address . 55509-done@debbugs.gnu.org)
87bkvf3xbj.fsf_-_@gnu.org
Hi,

Sharlatan Hellseher <sharlatanus@gmail.com> skribis:

Toggle quote (7 lines)
> From 896533a7f558d975d96367eb1ae3fe34e90a5c8f Mon Sep 17 00:00:00 2001
> From: Sharlatan Hellseher <sharlatanus@gmail.com>
> Date: Wed, 18 May 2022 21:31:18 +0100
> Subject: [PATCH 1/1] gnu: Add calceph
>
> * gnu/packages/astronomy.scm (calceph): New variable.

Applied with the cosmetic changes below, thanks!

Ludo’.
Toggle diff (20 lines)
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 99b8e16b9c..86705bbf19 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -98,15 +98,11 @@ (define-public calceph
@itemize
@item text Planetary Constants Kernel (KPL/PCK) files;
-
@item binary PCK (DAF/PCK) files;
-
@item binary SPK (DAF/SPK) files containing segments of type 1, 2, 3, 5, 8, 9,
12, 13, 17, 18, 19, 20, 21, 102, 103 and 120;
-
@item meta kernel (KPL/MK) files;
-
-@item frame kernel (KPL/FK) files. Only a basic support is provided;)
+@item frame kernel (KPL/FK) files (only basic support).
@end itemize\n")
(license license:cecill)))
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 55509@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 55509
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch