[PATCH 0/3] Add python-gpy

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Wiktor Zelazny
Owner
unassigned
Submitted by
Wiktor Zelazny
Severity
normal
W
W
Wiktor Zelazny wrote on 18 May 2022 16:01
(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)(name . Wiktor Zelazny)(address . wzelazny@vurv.cz)
20220518140016.26210-1-wzelazny@vurv.cz
guix import originally put python-cython in propagated-inputs of
python-gpy, but I followed the linter advice and moved it to
native-inputs. I could not figure out the role of this input.
Wiktor ?elazny (3):
gnu: Add python-climin.
gnu: Add python-paramz.
gnu: Add python-gpy.
gnu/packages/python-science.scm | 85 +++++++++++++++++++++++++++++++++
1 file changed, 85 insertions(+)
base-commit: a028eafcc2c6beffcb370296a4c5a90fe34fbcca
--
2.36.0

--
Tato zprava byla prohledana na vyskyt viru
a nebezpecneho obsahu antivirovym systemem
MailScanner a zda se byt cista.
W
W
Wiktor Zelazny wrote on 18 May 2022 18:20
[PATCH 1/3] gnu: Add python-climin.
(name . 55502@debbugs.gnu.org)(address . 55502@debbugs.gnu.org)(name . Wiktor Zelazny)(address . wzelazny@vurv.cz)
20220518162004.1536-1-wzelazny@vurv.cz
* gnu/packages/python-science.scm (python-climin): New variable.
---
gnu/packages/python-science.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)
Toggle diff (45 lines)
diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index bf7c7ce45f..ad17401a61 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -18,6 +18,7 @@
;;; Copyright © 2022 Malte Frank Gerdes <malte.f.gerdes@gmail.com>
;;; Copyright © 2022 Guillaume Le Vaillant <glv@posteo.net>
;;; Copyright © 2022 Paul A. Patience <paul@apatience.com>
+;;; Copyright © 2022 Wiktor ?elazny <wzelazny@vurv.cz>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1222,3 +1223,25 @@ (define-public python-traittypes
out of the scope of the main traitlets project but are a common requirement to
build applications with traitlets in combination with the scipy stack.")
(license license:bsd-3)))
+
+(define-public python-climin
+ (package
+ (name "python-climin")
+ (version "0.1a1")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "climin" version))
+ (sha256
+ (base32
+ "1wpjisd5zzi5yvjff02hnxn84822k8sdxvvd33lil2x79wdb36rv"))))
+ (build-system python-build-system)
+ (native-inputs (list python-nose))
+ (propagated-inputs (list python-numpydoc python-numpy python-scipy))
+ (home-page "https://github.com/BRML/climin")
+ (synopsis "Optimization for machine learning")
+ (description
+ "@command{climin} is a Python package for optimization,
+heavily biased to machine learning scenarios distributed under the BSD 3-clause
+license. It works on top of @command{numpy} and (partially)
+@command{gnumpy}.")
+ (license license:bsd-3)))
--
2.36.0

--
Tato zprava byla prohledana na vyskyt viru
a nebezpecneho obsahu antivirovym systemem
MailScanner a zda se byt cista.
W
W
Wiktor Zelazny wrote on 18 May 2022 18:20
[PATCH 2/3] gnu: Add python-paramz.
(name . 55502@debbugs.gnu.org)(address . 55502@debbugs.gnu.org)(name . Wiktor Zelazny)(address . wzelazny@vurv.cz)
20220518162004.1536-2-wzelazny@vurv.cz
* gnu/packages/python-science.scm (python-paramz): New variable.
---
gnu/packages/python-science.scm | 34 +++++++++++++++++++++++++++++++++
1 file changed, 34 insertions(+)

Toggle diff (49 lines)
diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index ad17401a61..a871bcf89e 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -1245,3 +1245,37 @@ (define-public python-climin
license. It works on top of @command{numpy} and (partially)
@command{gnumpy}.")
(license license:bsd-3)))
+
+(define-public python-paramz
+ (package
+ (name "python-paramz")
+ (version "0.9.5")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "paramz" version))
+ (sha256
+ (base32
+ "16hbh97kj6b1c2gw22rqnr3w3nqkszh9gj8vgx738gq81wf225q9"))))
+ (build-system python-build-system)
+ (propagated-inputs (list python-decorator python-numpy python-scipy
+ python-six))
+ (home-page "https://github.com/sods/paramz")
+ (synopsis "The Parameterization Framework")
+ (description
+ "@command{paramz} is a lightweight parameterization framework
+for parameterized model creation and handling. Its features include:
+
+@itemize
+ @item Easy model creation with parameters.
+ @item Fast optimized access of parameters for optimization routines.
+ @item Memory efficient storage of parameters (only one copy in memory).
+ @item Renaming of parameters.
+ @item Intuitive printing of models and parameters.
+ @item Gradient saving directly inside parameters.
+ @item Gradient checking of parameters.
+ @item Optimization of parameters.
+ @item Jupyter notebook integration.
+ @item Efficient storage of models, for reloading.
+ @item Efficient caching.
+@end itemize")
+ (license license:bsd-3)))
--
2.36.0

--
Tato zprava byla prohledana na vyskyt viru
a nebezpecneho obsahu antivirovym systemem
MailScanner a zda se byt cista.
W
W
Wiktor Zelazny wrote on 18 May 2022 18:20
[PATCH 3/3] gnu: Add python-gpy.
(name . 55502@debbugs.gnu.org)(address . 55502@debbugs.gnu.org)(name . Wiktor Zelazny)(address . wzelazny@vurv.cz)
20220518162004.1536-3-wzelazny@vurv.cz
* gnu/packages/python-science.scm (python-gpy): New variable.
---
gnu/packages/python-science.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)

Toggle diff (43 lines)
diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index a871bcf89e..fcc17a0b26 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -1279,3 +1279,31 @@ (define-public python-paramz
@item Efficient caching.
@end itemize")
(license license:bsd-3)))
+
+(define-public python-gpy
+ (package
+ (name "python-gpy")
+ (version "1.10.0")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "GPy" version))
+ (sha256
+ (base32
+ "1yx65ajrmqp02ykclhlb0n8s3bx5r0xj075swwwigiqaippr7dx2"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases (modify-phases %standard-phases
+ (add-before 'check 'remove-plotting-tests
+ ;; These fail
+ (lambda _
+ (delete-file "GPy/testing/plotting_tests.py"))))))
+ (native-inputs (list python-cython python-nose python-climin))
+ (propagated-inputs (list python-numpy python-paramz python-scipy
+ python-six))
+ (home-page "https://sheffieldml.github.io/GPy/")
+ (synopsis "The Gaussian Process Toolbox")
+ (description
+ "@command{GPy} is a Gaussian Process (GP) framework written in
+Python, from the Sheffield machine learning group. GPy implements a range of
+machine learning algorithms based on GPs.")
+ (license license:bsd-3)))
--
2.36.0

--
Tato zprava byla prohledana na vyskyt viru
a nebezpecneho obsahu antivirovym systemem
MailScanner a zda se byt cista.
L
L
Ludovic Courtès wrote on 29 May 2022 23:55
Re: bug#55502: [PATCH 0/3] Add python-gpy
(name . Wiktor Zelazny)(address . wzelazny@vurv.cz)(address . 55502-done@debbugs.gnu.org)
87k0a480m5.fsf@gnu.org
Hi,

Wiktor Zelazny <wzelazny@vurv.cz> skribis:

Toggle quote (4 lines)
> gnu: Add python-climin.
> gnu: Add python-paramz.
> gnu: Add python-gpy.

Applied, thanks!

Ludo’.
Closed
?