[PATCH] gnu: emacs-doom-themes: Include extension files.

  • Done
  • quality assurance status badge
Details
2 participants
  • Dominic Martinez
  • Ludovic Courtès
Owner
unassigned
Submitted by
Dominic Martinez
Severity
normal
D
D
Dominic Martinez wrote on 16 May 2022 20:30
(address . guix-patches@gnu.org)(name . Dominic Martinez)(address . dom@dominicm.dev)
20220516183045.14501-1-dom@dominicm.dev
Newer versions of `emacs-doom-themes' separated extension support into a
separate directory, so this change includes those files.
---
gnu/packages/emacs-xyz.scm | 4 +++-
1 file changed, 3 insertions(+), 1 deletion(-)

Toggle diff (17 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 8d66278b8f..fa3af93b61 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -27554,7 +27554,9 @@ (define-public emacs-doom-themes
;; EMACSLOADPATH.
(for-each (lambda (f)
(rename-file f (basename f)))
- (find-files "./themes" ".*\\.el$"))
+ (append
+ (find-files "./themes" ".*\\.el$")
+ (find-files "./extensions" ".*\\.el$")))
#t)))))
(synopsis "Wide collection of color themes for Emacs")
(description "Emacs-doom-themes contains numerous popular color themes for
--
2.36.0
D
D
Dominic Martinez wrote on 16 May 2022 20:50
[PATCH v2] gnu: emacs-doom-themes: Include extension files.
(address . 55460@debbugs.gnu.org)(name . Dominic Martinez)(address . dom@dominicm.dev)
20220516185006.17426-1-dom@dominicm.dev
Newer versions of `emacs-doom-themes' separated extension support into a
separate directory, so this change includes those files.
---
Sorry, small amendment to the previous patch as I forgot to include my copyright.

gnu/packages/emacs-xyz.scm | 5 ++++-
1 file changed, 4 insertions(+), 1 deletion(-)

Toggle diff (25 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 8d66278b8f..5e1f1f6c27 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -109,6 +109,7 @@
;;; Copyright © 2022 Brandon Lucas <br@ndon.dk>
;;; Copyright © 2022 Jai Vetrivelan <jaivetrivelan@gmail.com>
;;; Copyright © 2022 jgart <jgart@dismail.de>
+;;; Copyright © 2022 Dominic Martinez <dom@dominicm.dev>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -27554,7 +27555,9 @@ (define-public emacs-doom-themes
;; EMACSLOADPATH.
(for-each (lambda (f)
(rename-file f (basename f)))
- (find-files "./themes" ".*\\.el$"))
+ (append
+ (find-files "./themes" ".*\\.el$")
+ (find-files "./extensions" ".*\\.el$")))
#t)))))
(synopsis "Wide collection of color themes for Emacs")
(description "Emacs-doom-themes contains numerous popular color themes for
--
2.36.0
D
D
Dominic Martinez wrote on 18 May 2022 18:07
(address . 55460@debbugs.gnu.org)(name . Dominic Martinez)(address . dom@dominicm.dev)
87o7zuesbv.fsf@dominicm.dev
Bumping this patch as #55452 broke extension support.
-----BEGIN PGP SIGNATURE-----

iHUEARYIAB0WIQRtp6gAxeTcYmhxQ/1Bnl1fEVBrXQUCYoUaFAAKCRBBnl1fEVBr
XccrAP9m9NlcPdIJ4CTcOn9ZpTetHb+8LM6GM2xKDoMz/BLGOwEA7HCbDyE/vWr4
xcyk8njF9ke8A/mhk9by993U5mUi5wU=
=pZGg
-----END PGP SIGNATURE-----

L
L
Ludovic Courtès wrote on 1 Jun 2022 22:47
Re: bug#55460: [PATCH] gnu: emacs-doom-themes: Include extension files.
(name . Dominic Martinez)(address . dom@dominicm.dev)(address . 55460-done@debbugs.gnu.org)
87wne0ru0d.fsf_-_@gnu.org
Hi,

Dominic Martinez <dom@dominicm.dev> skribis:

Toggle quote (8 lines)
> Newer versions of `emacs-doom-themes' separated extension support into a
> separate directory, so this change includes those files.
> ---
> Sorry, small amendment to the previous patch as I forgot to include my copyright.
>
> gnu/packages/emacs-xyz.scm | 5 ++++-
> 1 file changed, 4 insertions(+), 1 deletion(-)

Applied, thanks, and sorry for the delay.

Ludo’.
Closed
?