[PATCH 0/1] gnu: python-rich: Update to 12.4.1.

  • Done
  • quality assurance status badge
Details
2 participants
  • Taiju HIGASHI
  • Ludovic Courtès
Owner
unassigned
Submitted by
Taiju HIGASHI
Severity
normal
T
T
Taiju HIGASHI wrote on 16 May 2022 17:04
(address . guix-patches@gnu.org)(name . Taiju HIGASHI)(address . higashi@taiju.info)
20220516150420.486-1-higashi@taiju.info
Hi,

Build of python-rich fails because the version of python-rich is out of date.
As a result, the build of pelican, which depends on python-rich, also fails.

I think this is because the version of pygments has been upgraded and the
problem fixed in the pull request below has occurred.

With this patch, both python-rich and pelican can be built.

Thank you

Taiju HIGASHI (1):
gnu: python-rich: Update to 12.4.1.

gnu/packages/python-xyz.scm | 12 ++++++++----
1 file changed, 8 insertions(+), 4 deletions(-)

--
2.35.1
T
T
Taiju HIGASHI wrote on 16 May 2022 17:09
[PATCH 1/1] gnu: python-rich: Update to 12.4.1.
(address . 55453@debbugs.gnu.org)(name . Taiju HIGASHI)(address . higashi@taiju.info)
20220516150959.895-2-higashi@taiju.info
* gnu/packages/python-xyz.scm (python-rich): Update to 12.4.1.
---
gnu/packages/python-xyz.scm | 12 ++++++++----
1 file changed, 8 insertions(+), 4 deletions(-)

Toggle diff (51 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 199fcf5fb8..f3efd49af6 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -121,6 +121,7 @@
;;; Copyright © 2022 Peter Polidoro <peter@polidoro.io>
;;; Copyright © 2022 Wamm K. D. <jaft.r@outlook.com>
;;; Copyright © 2022 Jai Vetrivelan <jaivetrivelan@gmail.com>
+;;; Copyright © 2022 Taiju HIGASHI <higashi@taiju.info>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -16500,13 +16501,13 @@ (define-public python-rarfile
(define-public python-rich
(package
(name "python-rich")
- (version "10.2.2")
+ (version "12.4.1")
(source (origin
(method url-fetch)
(uri (pypi-uri "rich" version))
(sha256
(base32
- "1z5m5brcdf3vndpavcqj5nl35xby4x5rfj48klhwqycfqf3g9cqp"))))
+ "149vjb4cpf9mz14iig0b6d8065dm8aslp6pc45g9ipmp1wf00ffj"))))
(build-system python-build-system)
(arguments
`(#:phases
@@ -16519,7 +16520,10 @@ (define-public python-rich
"tests")
(invoke "python" "-m" "pytest" "-vv")))))))
(propagated-inputs
- (list python-attrs python-colorama python-commonmark python-pygments
+ (list python-commonmark
+ python-dataclasses
+ python-ipywidgets
+ python-pygments
python-typing-extensions))
(native-inputs
`(("python-pytest" ,python-pytest)
@@ -16535,7 +16539,7 @@ (define-public python-rich
(file-name (git-file-name name version))
(sha256
(base32
- "19f4svb363sn5708qkpa6lakmiwzyb25h8kmh7bqrsbbrvi9hr70"))))))
+ "17c3gljn8zv32xnpsgd3fqgqn4r7cdfqri41hridcpbhssdgkyp9"))))))
(home-page "https://github.com/willmcgugan/rich")
(synopsis "Render rich text and more to the terminal")
(description
--
2.35.1
T
L
L
Ludovic Courtès wrote on 24 May 2022 16:50
Re: bug#55453: [PATCH 0/1] gnu: python-rich: Update to 12.4.1.
(name . Taiju HIGASHI)(address . higashi@taiju.info)(address . 55453-done@debbugs.gnu.org)
87r14jj880.fsf@gnu.org
Hi,

Taiju HIGASHI <higashi@taiju.info> skribis:

Toggle quote (8 lines)
> Build of python-rich fails because the version of python-rich is out of date.
> As a result, the build of pelican, which depends on python-rich, also fails.
>
> I think this is because the version of pygments has been upgraded and the
> problem fixed in the pull request below has occurred.
>
> With this patch, both python-rich and pelican can be built.

Python-rich was updated independently in
93ef1eecd96a0dd0ebfe44adac8b027151697f2e.

Closing!

Thanks,
Ludo’.
Closed
?