[PATCH] gnu: emacs-haskell-snippets: Update to 0.1.0-1-1c29c4a6.

  • Done
  • quality assurance status badge
Details
2 participants
  • Aleksandr Vityazev
  • Maxim Cournoyer
Owner
unassigned
Submitted by
Aleksandr Vityazev
Severity
normal

Debbugs page

Aleksandr Vityazev wrote 3 years ago
(address . guix-patches@gnu.org)
97a6207831decafe14b318304996059543bbebce.1652649360.git.avityazev@posteo.org
* gnu/packages/emacs-xyz.scm (emacs-haskell-snippets): Update to
0.1.0-1-1c29c4a6.
[arguments]: Convert to list of G-Expressions. Drop trailing ‘#t’s.
---
gnu/packages/emacs-xyz.scm | 28 ++++++++++++++--------------
1 file changed, 14 insertions(+), 14 deletions(-)

Toggle diff (59 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 7a5c6235fc..46fbefd47f 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -29532,11 +29532,12 @@ (define-public emacs-objed
(license license:gpl3+)))
(define-public emacs-haskell-snippets
- ;; The commit below is 5 commits ahead of release, and includes a build fix.
- (let ((commit "07b0f460b946fd1be26c29652cb0468b47782f3a"))
+ ;; The commit below is 7 commits ahead of release, and includes a build fix.
+ ;; And also a fix in one snippet.
+ (let ((commit "1c29c4a68ce89848b8d371c6510d1de3b586c8b3"))
(package
(name "emacs-haskell-snippets")
- (version (git-version "0.1.0" "0" commit))
+ (version (git-version "0.1.0" "1" commit))
(source
(origin
(method git-fetch)
@@ -29546,20 +29547,19 @@ (define-public emacs-haskell-snippets
(commit commit)))
(file-name (git-file-name name version))
(sha256
- (base32 "0a7y3awi9hcyahggf0ghsdwvsmrhr9yq634wy9lkqjzrm2hqj0ci"))))
+ (base32 "1lwnggarmavyf164cfzbzzkq9ffahhd3bz7gw644czs49sndcawf"))))
(build-system emacs-build-system)
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-after 'install 'install-snippets
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (snippets
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'install 'install-snippets
+ (lambda _
+ (let ((snippets
(string-append
- out "/share/emacs/site-lisp/snippets/haskell-mode")))
- (mkdir-p snippets)
- (copy-recursively "snippets/haskell-mode" snippets)
- #t))))))
+ #$output "/share/emacs/site-lisp/snippets/haskell-mode")))
+ (mkdir-p snippets)
+ (copy-recursively "snippets/haskell-mode" snippets)))))))
(propagated-inputs
(list emacs-yasnippet))
(home-page "https://github.com/haskell/haskell-snippets")
--
2.36.0



--

Aleksandr Vityazev
Maxim Cournoyer wrote 3 years ago
(name . Aleksandr Vityazev)(address . avityazev@posteo.org)(address . 55434-done@debbugs.gnu.org)
87tu9n1n2z.fsf@gmail.com
Hello,

Aleksandr Vityazev <avityazev@posteo.org> writes:

Toggle quote (4 lines)
> * gnu/packages/emacs-xyz.scm (emacs-haskell-snippets): Update to
> 0.1.0-1-1c29c4a6.
> [arguments]: Convert to list of G-Expressions. Drop trailing ‘#t’s.

Applied, thanks!

Maxim
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 55434@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 55434
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help