[PATCH] gnu: emacs-lispy: Fix failing test under Emacs 28.

  • Done
  • quality assurance status badge
Details
2 participants
  • Kyle Meyer
  • Maxim Cournoyer
Owner
unassigned
Submitted by
Kyle Meyer
Severity
normal

Debbugs page

Kyle Meyer wrote 3 years ago
(address . guix-patches@gnu.org)
20220515182537.142078-1-kyle@kyleam.com
* gnu/packages/patches/emacs-lispy-fix-thread-last-test.patch: New file.
* gnu/packages/emacs-xyz.scm (emacs-lispy): Use it here.
* gnu/local.mk (dist_patch_DATA): Register it here.
---

Note that successfully building this package depends on the emacs-buttercup
update that Michael Rohleder submitted at

gnu/local.mk | 1 +
gnu/packages/emacs-xyz.scm | 4 +-
.../emacs-lispy-fix-thread-last-test.patch | 39 +++++++++++++++++++
3 files changed, 43 insertions(+), 1 deletion(-)
create mode 100644 gnu/packages/patches/emacs-lispy-fix-thread-last-test.patch

Toggle diff (83 lines)
diff --git a/gnu/local.mk b/gnu/local.mk
index cfb499915a..864b32b6c6 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1034,6 +1034,7 @@ dist_patch_DATA = \
%D%/packages/patches/emacs-highlight-stages-add-gexp.patch \
%D%/packages/patches/emacs-hyperbole-toggle-messaging.patch \
%D%/packages/patches/emacs-libgit-use-system-libgit2.patch \
+ %D%/packages/patches/emacs-lispy-fix-thread-last-test.patch \
%D%/packages/patches/emacs-source-date-epoch.patch \
%D%/packages/patches/emacs-telega-path-placeholder.patch \
%D%/packages/patches/emacs-telega-test-env.patch \
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 8a319fc0ff..f2e59ae6c7 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -21,7 +21,7 @@
;;; Copyright © 2017, 2018, 2019, 2020, 2022 Mathieu Othacehe <m.othacehe@gmail.com>
;;; Copyright © 2017, 2018, 2019, 2020, 2021, 2022 Clément Lassieur <clement@lassieur.org>
;;; Copyright © 2017 Vasile Dumitrascu <va511e@yahoo.com>
-;;; Copyright © 2017, 2018 Kyle Meyer <kyle@kyleam.com>
+;;; Copyright © 2017, 2018, 2022 Kyle Meyer <kyle@kyleam.com>
;;; Copyright © 2017 Kei Kebreau <kkebreau@posteo.net>
;;; Copyright © 2017 George Clemmer <myglc2@gmail.com>
;;; Copyright © 2017, 2018 Feng Shu <tumashu@163.com>
@@ -9708,6 +9708,8 @@ (define-public emacs-lispy
(sha256
(base32
"1q3sgk8ffwajmh8l7c4p4fz36xw4fqds8yqblbi5kardaa8bs8cs"))
+ (patches
+ (search-patches "emacs-lispy-fix-thread-last-test.patch"))
(file-name (git-file-name name version))))
(build-system emacs-build-system)
(propagated-inputs
diff --git a/gnu/packages/patches/emacs-lispy-fix-thread-last-test.patch b/gnu/packages/patches/emacs-lispy-fix-thread-last-test.patch
new file mode 100644
index 0000000000..2690dabdc8
--- /dev/null
+++ b/gnu/packages/patches/emacs-lispy-fix-thread-last-test.patch
@@ -0,0 +1,39 @@
+From dbe23aec174001c42f6edc7a594863a82a24bcfa Mon Sep 17 00:00:00 2001
+From: Kyle Meyer <kyle@kyleam.com>
+Date: Sun, 15 May 2022 13:56:37 -0400
+Subject: [PATCH] lispy-test.el (lispy-toggle-threaded-last): Update for Emacs
+ 28
+
+Starting with Emacs 28.1, thread-first uses `(declare (indent 0) ...)`
+rather than `(declare (indent 1) ...)`.
+---
+
+ Proposed upstream at <https://github.com/abo-abo/lispy/pull/632>.
+
+ lispy-test.el | 8 +++++++-
+ 1 file changed, 7 insertions(+), 1 deletion(-)
+
+diff --git a/lispy-test.el b/lispy-test.el
+index d946731..87d8c87 100644
+--- a/lispy-test.el
++++ b/lispy-test.el
+@@ -150,7 +150,13 @@ (ert-deftest lispy-toggle-threaded-last ()
+ "|(thread-last (a 1) (b 2) (c 3))"))
+ (should (string= (lispy-with "|(equal 1443070800.0\n (ts-unix\n (ts-parse-org-element\n (org-element-context))))"
+ (lispy-toggle-thread-last))
+- "|(thread-last (org-element-context)\n (ts-parse-org-element)\n (ts-unix)\n (equal 1443070800.0))"))
++ (let ((indent (make-string
++ (if (version< emacs-version "28.1") 2 13)
++ ?\s)))
++ (concat "|(thread-last (org-element-context)\n"
++ indent "(ts-parse-org-element)\n"
++ indent "(ts-unix)\n"
++ indent "(equal 1443070800.0))"))))
+ (should (string= (lispy-with "|(thread-last (org-element-context)\n (ts-parse-org-element)\n (ts-unix)\n (equal 1443070800.0))"
+ (lispy-toggle-thread-last))
+ "|(equal 1443070800.0\n (ts-unix\n (ts-parse-org-element\n (org-element-context))))")))
+
+base-commit: df1b7e614fb0f73646755343e8892ddda310f427
+--
+2.36.0
+

base-commit: ebb43029506d994bee0c2b890881fd61a0b0c202
--
2.36.0
Maxim Cournoyer wrote 3 years ago
(name . Kyle Meyer)(address . kyle@kyleam.com)(address . 55432-done@debbugs.gnu.org)
87zgjf1n5v.fsf@gmail.com
Hi,

Kyle Meyer <kyle@kyleam.com> writes:

Toggle quote (4 lines)
> * gnu/packages/patches/emacs-lispy-fix-thread-last-test.patch: New file.
> * gnu/packages/emacs-xyz.scm (emacs-lispy): Use it here.
> * gnu/local.mk (dist_patch_DATA): Register it here.

Applied, well done and thanks!

Maxim
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 55432@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 55432
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help