Michael Rohleder wrote 3 years ago
(address . guix-patches@gnu.org)(name . Michael Rohleder)(address . mike@rohleder.de)
* gnu/packages/emacs-xyz.scm (emacs-dash)[phase]:
Add phase 'disable-byte-compile-error-on-warn.
---
gnu/packages/emacs-xyz.scm | 9 ++++++++-
1 file changed, 8 insertions(+), 1 deletion(-)
Toggle diff (22 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index c18505a681..928ca1c120 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -3677,7 +3677,14 @@ (define-public emacs-dash
(base32
"0z6f8y1m9amhg427iz1d4xcyr6n0kj5w7kmiz134p320ixsdnzd8"))))
(build-system emacs-build-system)
- (arguments `(#:tests? #t))
+ (arguments `(#:tests? #t
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'disable-byte-compile-error-on-warn
+ (lambda _
+ (substitute* "Makefile"
+ (("\\(setq byte-compile-error-on-warn t\\)")
+ "(setq byte-compile-error-on-warn nil)")))))))
(home-page "https://github.com/magnars/dash.el")
(synopsis "Modern list library for Emacs")
(description "This package provides a modern list API library for Emacs.")
--
2.36.0