[PATCH] gnu: emacs-dash: Fix build with emacs28.

  • Done
  • quality assurance status badge
Details
2 participants
  • Liliana Marie Prikler
  • Michael Rohleder
Owner
unassigned
Submitted by
Michael Rohleder
Severity
normal

Debbugs page

Michael Rohleder wrote 3 years ago
(address . guix-patches@gnu.org)(name . Michael Rohleder)(address . mike@rohleder.de)
20220514213957.21292-1-mike@rohleder.de
* gnu/packages/emacs-xyz.scm (emacs-dash)[phase]:
Add phase 'disable-byte-compile-error-on-warn.
---
gnu/packages/emacs-xyz.scm | 9 ++++++++-
1 file changed, 8 insertions(+), 1 deletion(-)

Toggle diff (22 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index c18505a681..928ca1c120 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -3677,7 +3677,14 @@ (define-public emacs-dash
(base32
"0z6f8y1m9amhg427iz1d4xcyr6n0kj5w7kmiz134p320ixsdnzd8"))))
(build-system emacs-build-system)
- (arguments `(#:tests? #t))
+ (arguments `(#:tests? #t
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'disable-byte-compile-error-on-warn
+ (lambda _
+ (substitute* "Makefile"
+ (("\\(setq byte-compile-error-on-warn t\\)")
+ "(setq byte-compile-error-on-warn nil)")))))))
(home-page "https://github.com/magnars/dash.el")
(synopsis "Modern list library for Emacs")
(description "This package provides a modern list API library for Emacs.")
--
2.36.0
Liliana Marie Prikler wrote 3 years ago
1e6b422d54468fcf7550023f7d6247babc0f6217.camel@gmail.com
Am Samstag, dem 14.05.2022 um 23:39 +0200 schrieb Michael Rohleder:
Toggle quote (3 lines)
> * gnu/packages/emacs-xyz.scm (emacs-dash)[phase]:
> Add phase 'disable-byte-compile-error-on-warn.
> ---
Applied with a small fix in the commit message.

Thanks
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 55418@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 55418
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help