[PATCH 05/14] gnu: Add r-unglue.

  • Done
  • quality assurance status badge
Details
3 participants
  • kyle
  • Maxime Devos
  • Ricardo Wurmus
Owner
unassigned
Submitted by
kyle
Severity
normal

Debbugs page

kyle wrote 3 years ago
(address . guix-patches@gnu.org)(name . Kyle Andrews)(address . kyle@posteo.net)
20c51184bbe6034ed7b4be6fc3f2b36f212ea60e.1651893551.git.kyle@posteo.net
From: Kyle Andrews <kyle@posteo.net>

---
gnu/packages/cran.scm | 20 ++++++++++++++++++++
1 file changed, 20 insertions(+)

Toggle diff (33 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 213f810d04..516c335822 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -33338,6 +33338,26 @@ (define-public r-unpivotr
with one other by their proximity in given directions. Functions for data
frames and HTML tables are provided.")
(license license:expat)))
+
+(define-public r-unglue
+ (package
+ (name "r-unglue")
+ (version "0.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "unglue" version))
+ (sha256
+ (base32 "0w8ld4xllx0lj1jz8i2sj92f8136hlwri1d8ldpg1ymxj7aw93vg"))))
+ (properties `((upstream-name . "unglue")))
+ (build-system r-build-system)
+ (home-page "https://cran.r-project.org/package=unglue")
+ (synopsis "Extract Matched Substrings Using a Pattern")
+ (description
+ "Use syntax inspired by the package 'glue' to extract matched substrings in a
+more intuitive and compact way than by using standard regular expressions.")
+ (license license:gpl3)))
+
(define r-gpg
(package
(name "r-gpg")
--
2.36.0
Maxime Devos wrote 3 years ago
464037be8d677efd5402d66a0c59db221cb960a6.camel@telenet.be
kyle schreef op do 12-05-2022 om 02:10 [+0000]:
Toggle quote (2 lines)
> Use syntax inspired by the package 'glue'

Shouldn't this be 'r-glue'? Guix doesn't have a package named 'glue'.
Also, writing a description (+- = some factual statements) in the
imperative mood ... is technically possible, but I wouldn't recommend
it. Referring to another package for more information on what 'rust-
unglue' is about is technically possible, but a bit cumbersome for the
reader I think. Maybe you can re-use parts of the description of
'r-glue'.

Toggle quote (3 lines)
> to extract matched substrings in a
> +more intuitive and compact way than by using standard regular expressions.

This is a bit markety language.

More generally, upstream descriptions often aren't great and require
some tweaking, expanding (and sometimes abbreviation, though not in
this particular case). The manual has some general guidelines in
(guix)Synopses and Descriptions.

FWIW, I consider 'emacs', 'hello' and 'sed' to have good descriptions,
though the emacs description goes a bit markety with ‘highly
customizable ... extensive documention on everything’ and such ...
though in the case of Emacs those claims appear to be actually true so
maybe it's a good description after all.

Greetings,
Maxime.
-----BEGIN PGP SIGNATURE-----

iI0EABYKADUWIQTB8z7iDFKP233XAR9J4+4iGRcl7gUCYn/yYRccbWF4aW1lZGV2
b3NAdGVsZW5ldC5iZQAKCRBJ4+4iGRcl7qx1AP0VUGU7by25x9Wm3hmTlu9kh9LL
6+COwAN+uZDO3gDlSwEAkHw1h6DJ4w09Xw9KA8u7ARqqkhhhxP6yMH7GIXLikw0=
=YgzU
-----END PGP SIGNATURE-----


Kyle Andrews wrote 3 years ago
(name . Maxime Devos)(address . maximedevos@telenet.be)(address . 55381@debbugs.gnu.org)
87czge67sd.fsf@posteo.net
Hi Maxime,

Maxime Devos <maximedevos@telenet.be> writes:

Toggle quote (13 lines)
> [[PGP Signed Part:Undecided]]
> kyle schreef op do 12-05-2022 om 02:10 [+0000]:
>> Use syntax inspired by the package 'glue'
>
> Shouldn't this be 'r-glue'? Guix doesn't have a package named 'glue'.
> Also, writing a description (+- = some factual statements) in the
> imperative mood ... is technically possible, but I wouldn't recommend
> it. Referring to another package for more information on what 'rust-
> unglue' is about is technically possible, but a bit cumbersome for the
> reader I think. Maybe you can re-use parts of the description of
> 'r-glue'.
>

This (and r-glue too) is an R package designed to be installed and used
from within R. I noticed that the Pandas python package, for example,
doesn't refer to itself as python-pandas in its Guix documentation.
There are numerous other instances in Guix where such library software
for high-level languages refer to themselves and other related packages
as within their own ecosystems instead of the Guix ecosystem. However,
in this particular case I included in parenthesis "(provided by r-glue
in Guix)".

Toggle quote (10 lines)
>> to extract matched substrings in a
>> +more intuitive and compact way than by using standard regular expressions.
>
> This is a bit markety language.
>
> More generally, upstream descriptions often aren't great and require
> some tweaking, expanding (and sometimes abbreviation, though not in
> this particular case). The manual has some general guidelines in
> (guix)Synopses and Descriptions.

Thanks, I had a look.

Toggle quote (7 lines)
> FWIW, I consider 'emacs', 'hello' and 'sed' to have good descriptions,
> though the emacs description goes a bit markety with ‘highly
> customizable ... extensive documention on everything’ and such ...
> though in the case of Emacs those claims appear to be actually true so
> maybe it's a good description after all.
>

I made a few small tweaks which I feel significantly reduces the
"marketing" aspect. See the included patch.
From 9a30410e850000e839002649a5f6183f174fdfa2 Mon Sep 17 00:00:00 2001
Message-Id: <9a30410e850000e839002649a5f6183f174fdfa2.1652634138.git.kyle@posteo.net>
From: Kyle Andrews <kyle@posteo.net>
Date: Sun, 15 May 2022 13:01:30 -0400
Subject: [PATCH] gnu: Add r-unglue.

---
gnu/packages/cran.scm | 20 ++++++++++++++++++++
1 file changed, 20 insertions(+)

Toggle diff (30 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 5c05f20ea7..bbe18e1d67 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -33255,3 +33255,23 @@ (define-public r-zoeppritz
coefficients or scattering amplitudes, for seismological P and S-waves at an
interface.")
(license license:gpl2+)))
+
+(define-public r-unglue
+ (package
+ (name "r-unglue")
+ (version "0.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "unglue" version))
+ (sha256
+ (base32 "0w8ld4xllx0lj1jz8i2sj92f8136hlwri1d8ldpg1ymxj7aw93vg"))))
+ (properties `((upstream-name . "unglue")))
+ (build-system r-build-system)
+ (home-page "https://cran.r-project.org/package=unglue")
+ (synopsis "Extract Matched Substrings Using a Pattern")
+ (description
+ "Use syntax inspired by the package 'glue' (provided by r-glue in
+Guix) to extract matched substrings in a more compact way than by
+using regular expressions.")
+ (license license:gpl3)))
--
2.36.0
Cheers,
Kyle
Ricardo Wurmus wrote 2 years ago
[PATCH 05/14] gnu: Add r-unglue.
(address . 55381-done@debbugs.gnu.org)
87o7rm7zl7.fsf@elephly.net
Applied, thank you!

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 55381@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 55381
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help