[PATCH 02/14] gnu: Add r-piton.

  • Done
  • quality assurance status badge
Details
2 participants
  • kyle
  • Ricardo Wurmus
Owner
unassigned
Submitted by
kyle
Severity
normal

Debbugs page

kyle wrote 3 years ago
(address . guix-patches@gnu.org)(name . Kyle Andrews)(address . kyle@posteo.net)
e36bbb83ba5829d6746620984eb0e243d61acdc4.1651893551.git.kyle@posteo.net
From: Kyle Andrews <kyle@posteo.net>

---
gnu/packages/cran.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (35 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index f69a7dd605..57166bacdc 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -33257,6 +33257,28 @@ (define-public r-zoeppritz
interface.")
(license license:gpl2+)))
+(define-public r-piton
+ (package
+ (name "r-piton")
+ (version "1.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "piton" version))
+ (sha256
+ (base32 "1krf6zi238m275nxjlpyayv8y2drbgs2kg19dpkqm0lmlz5y5ar8"))))
+ (properties `((upstream-name . "piton")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-rcpp))
+ (home-page "https://github.com/Ironholds/piton")
+ (synopsis "Parsing Expression Grammars in Rcpp")
+ (description
+ "This package provides a wrapper around the 'Parsing Expression Grammar Template
+Library', a C++11 library for generating Parsing Expression Grammars, that makes
+it accessible within Rcpp. With this, developers can implement their own
+grammars and easily expose them in R packages.")
+ (license license:expat)))
+
(define r-gpg
(package
(name "r-gpg")
--
2.36.0
Ricardo Wurmus wrote 2 years ago
(address . 55380-done@debbugs.gnu.org)
87sfgy8003.fsf@elephly.net
My apologies, I only just saw this patch. Feel free to Cc (or
X-Debbugs-Cc) the R team in the future to get more eyes on your patches
from people who can review them for you.

I rebased and applied the patch just now.

Thanks!

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 55380@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 55380
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help