[PATCH 02/14] gnu: Add r-piton.

  • Done
  • quality assurance status badge
Details
2 participants
  • kyle
  • Ricardo Wurmus
Owner
unassigned
Submitted by
kyle
Severity
normal
K
(address . guix-patches@gnu.org)(name . Kyle Andrews)(address . kyle@posteo.net)
e36bbb83ba5829d6746620984eb0e243d61acdc4.1651893551.git.kyle@posteo.net
From: Kyle Andrews <kyle@posteo.net>

---
gnu/packages/cran.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (35 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index f69a7dd605..57166bacdc 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -33257,6 +33257,28 @@ (define-public r-zoeppritz
interface.")
(license license:gpl2+)))
+(define-public r-piton
+ (package
+ (name "r-piton")
+ (version "1.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "piton" version))
+ (sha256
+ (base32 "1krf6zi238m275nxjlpyayv8y2drbgs2kg19dpkqm0lmlz5y5ar8"))))
+ (properties `((upstream-name . "piton")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-rcpp))
+ (home-page "https://github.com/Ironholds/piton")
+ (synopsis "Parsing Expression Grammars in Rcpp")
+ (description
+ "This package provides a wrapper around the 'Parsing Expression Grammar Template
+Library', a C++11 library for generating Parsing Expression Grammars, that makes
+it accessible within Rcpp. With this, developers can implement their own
+grammars and easily expose them in R packages.")
+ (license license:expat)))
+
(define r-gpg
(package
(name "r-gpg")
--
2.36.0
R
R
Ricardo Wurmus wrote on 29 Dec 2022 20:47
(address . 55380-done@debbugs.gnu.org)
87sfgy8003.fsf@elephly.net
My apologies, I only just saw this patch. Feel free to Cc (or
X-Debbugs-Cc) the R team in the future to get more eyes on your patches
from people who can review them for you.

I rebased and applied the patch just now.

Thanks!

--
Ricardo
Closed
?