[PATCH 01/14] gnu: Add r-gpg.

  • Open
  • quality assurance status badge
Details
3 participants
  • kyle
  • Maxime Devos
  • Ricardo Wurmus
Owner
unassigned
Submitted by
kyle
Severity
normal
K
(address . guix-patches@gnu.org)(name . Kyle Andrews)(address . kyle@posteo.net)
d28d8263c5619db922a5ca3aa494fb96dd13786d.1651893550.git.kyle@posteo.net
From: Kyle Andrews <kyle@posteo.net>

---
gnu/packages/cran.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)

Toggle diff (44 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 5c05f20ea7..f69a7dd605 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -103,6 +103,7 @@ (define-module (gnu packages cran)
#:use-module (gnu packages python-xyz)
#:use-module (gnu packages sqlite)
#:use-module (gnu packages statistics)
+ #:use-module (gnu packages gnupg)
#:use-module (gnu packages tcl)
#:use-module (gnu packages textutils)
#:use-module (gnu packages tls)
@@ -33255,3 +33256,29 @@ (define-public r-zoeppritz
coefficients or scattering amplitudes, for seismological P and S-waves at an
interface.")
(license license:gpl2+)))
+
+(define r-gpg
+ (package
+ (name "r-gpg")
+ (version "1.2.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "gpg" version))
+ (sha256
+ (base32
+ "1qc7w4d6frp0j4yk0q7slkj1mps80bv78lixcpw1shgx48rp41kh"))))
+ (properties `((upstream-name . "gpg")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-askpass" ,r-askpass) ("r-curl" ,r-curl)))
+ (inputs
+ `(("gpgme" ,gpgme) ("gnupg" ,gnupg)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config) ("r-knitr" ,r-knitr)))
+ (home-page
+ "https://jeroen.cran.dev/gpg/https://github.com/jeroen/gpg")
+ (synopsis "GNU Privacy Guard for R")
+ (description
+ "Bindings to GnuPG for working with OpenGPG (RFC4880) cryptographic methods. Includes utilities for public key encryption, creating and verifying digital signatures, and managing your local keyring. Note that some functionality depends on the version of GnuPG that is installed on the system. On Windows this package can be used together with 'GPG4Win' which provides a GUI for managing keys and entering passphrases.")
+ (license license:expat)))
--
2.36.0
K
[PATCH 04/14] gnu: Add r-unpivotr.
(address . guix-patches@gnu.org)(name . Kyle Andrews)(address . kyle@posteo.net)
1f41a6214bca3a6d4ce93866e9c4467319309084.1651893551.git.kyle@posteo.net
From: Kyle Andrews <kyle@posteo.net>

---
gnu/packages/cran.scm | 35 +++++++++++++++++++++++++++++++++++
1 file changed, 35 insertions(+)

Toggle diff (48 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 9578263789..213f810d04 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -33303,6 +33303,41 @@ (define-public r-tidyxl
<http://rapidxml.sourceforge.net>. Does not support '.xlsb' or '.xls'.")
(license license:gpl3)))
+(define-public r-unpivotr
+ (package
+ (name "r-unpivotr")
+ (version "0.6.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "unpivotr" version))
+ (sha256
+ (base32 "1paqx2jn8gh4nd4zm8iwxpf38znzwwqli62ww7f3k5vwkf34r078"))))
+ (properties `((upstream-name . "unpivotr")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-cellranger
+ r-dplyr
+ r-forcats
+ r-magrittr
+ r-pillar
+ r-purrr
+ r-rlang
+ r-tibble
+ r-tidyr
+ r-tidyselect
+ r-xml2))
+ (native-inputs (list r-knitr))
+ (home-page "https://github.com/nacnudus/unpivotr")
+ (synopsis "Unpivot Complex and Irregular Data Layouts")
+ (description
+ "Tools for converting data from complex or irregular layouts to a columnar
+structure. For example, tables with multilevel column or row headers, or
+spreadsheets. Header and data cells are selected by their contents and
+position, as well as formatting and comments where available, and are associated
+with one other by their proximity in given directions. Functions for data
+frames and HTML tables are provided.")
+ (license license:expat)))
(define r-gpg
(package
(name "r-gpg")
--
2.36.0
K
[PATCH 06/14] gnu: Add r-vcdextra.
(address . guix-patches@gnu.org)(name . Kyle Andrews)(address . kyle@posteo.net)
74710027f542c8fbcececf8a3a3aad16fdd3a5a9.1651893551.git.kyle@posteo.net
From: Kyle Andrews <kyle@posteo.net>

---
gnu/packages/cran.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)

Toggle diff (40 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 516c335822..2cd4b8d2a6 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -33358,6 +33358,33 @@ (define-public r-unglue
more intuitive and compact way than by using standard regular expressions.")
(license license:gpl3)))
+(define-public r-vcdextra
+ (package
+ (name "r-vcdextra")
+ (version "0.8-0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "vcdExtra" version))
+ (sha256
+ (base32 "1wv1ypjdvw639jlphwfpqgpjkk4ki98l2lfbpncsbpy9jpknjsmk"))))
+ (properties `((upstream-name . "vcdExtra")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-ca r-gnm r-mass r-vcd))
+ (native-inputs (list r-knitr))
+ (home-page "https://friendly.github.io/vcdExtra/")
+ (synopsis "'vcd' Extensions and Additions")
+ (description
+ "This package provides additional data sets, methods and documentation to
+complement the 'vcd' package for Visualizing Categorical Data and the 'gnm'
+package for Generalized Nonlinear Models. In particular, 'vcdExtra' extends
+mosaic, assoc and sieve plots from 'vcd' to handle 'glm()' and 'gnm()' models
+and adds a 3D version in 'mosaic3d'. Additionally, methods are provided for
+comparing and visualizing lists of 'glm' and 'loglm' objects. This package is
+now a support package for the book, \"Discrete Data Analysis with R\" by Michael
+Friendly and David Meyer.")
+ (license license:gpl2+)))
+
(define r-gpg
(package
(name "r-gpg")
--
2.36.0
K
[PATCH 07/14] gnu: Add r-ca.
(address . guix-patches@gnu.org)(name . Kyle Andrews)(address . kyle@posteo.net)
c8bc2ad2c32f9047171f7fd992baa78b4bcb2371.1651893551.git.kyle@posteo.net
From: Kyle Andrews <kyle@posteo.net>

---
gnu/packages/cran.scm | 20 ++++++++++++++++++++
1 file changed, 20 insertions(+)

Toggle diff (33 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 2cd4b8d2a6..b5946070b0 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -33385,6 +33385,26 @@ (define-public r-vcdextra
Friendly and David Meyer.")
(license license:gpl2+)))
+(define-public r-ca
+ (package
+ (name "r-ca")
+ (version "0.71.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "ca" version))
+ (sha256
+ (base32
+ "095lk7p2b9835hc3a03c4019wg0baf0dhz6c2vqpaq1m9k4jy304"))))
+ (properties `((upstream-name . "ca")))
+ (build-system r-build-system)
+ (home-page "http://www.carme-n.org/")
+ (synopsis
+ "Simple, Multiple and Joint Correspondence Analysis")
+ (description
+ "Computation and visualization of simple, multiple and joint correspondence analysis.")
+ (license (list license:gpl2+ license:gpl3+))))
+
(define r-gpg
(package
(name "r-gpg")
--
2.36.0
K
[PATCH 03/14] gnu: Add r-tidyxl.
(address . guix-patches@gnu.org)(name . Kyle Andrews)(address . kyle@posteo.net)
e01ab4fdc4394b5c45f995e803ef7f021db0a3d7.1651893551.git.kyle@posteo.net
From: Kyle Andrews <kyle@posteo.net>

---
gnu/packages/cran.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (37 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 57166bacdc..9578263789 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -33279,6 +33279,30 @@ (define-public r-piton
grammars and easily expose them in R packages.")
(license license:expat)))
+
+(define-public r-tidyxl
+ (package
+ (name "r-tidyxl")
+ (version "1.0.7")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "tidyxl" version))
+ (sha256
+ (base32 "1wg8h5fd2hd8ilshrbcs99q18p15687dx8j51v5pyd30pg5cab7b"))))
+ (properties `((upstream-name . "tidyxl")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-piton r-rcpp))
+ (native-inputs (list r-knitr))
+ (home-page "https://github.com/nacnudus/tidyxl")
+ (synopsis "Read Untidy Excel Files")
+ (description
+ "Imports non-tabular from Excel files into R. Exposes cell content, position and
+formatting in a tidy structure for further manipulation. Tokenizes Excel
+formulas. Supports '.xlsx' and '.xlsm' via the embedded 'RapidXML' C++ library
+<http://rapidxml.sourceforge.net>. Does not support '.xlsb' or '.xls'.")
+ (license license:gpl3)))
+
(define r-gpg
(package
(name "r-gpg")
--
2.36.0
K
[PATCH 08/14] gnu: Add r-qvcalc.
(address . guix-patches@gnu.org)(name . Kyle Andrews)(address . kyle@posteo.net)
00263f4ce3e94329d02543d712b64424a7b6d931.1651893551.git.kyle@posteo.net
From: Kyle Andrews <kyle@posteo.net>

---
gnu/packages/cran.scm | 21 +++++++++++++++++++++
1 file changed, 21 insertions(+)

Toggle diff (34 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index b5946070b0..b86ab6127d 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -33405,6 +33405,27 @@ (define-public r-ca
"Computation and visualization of simple, multiple and joint correspondence analysis.")
(license (list license:gpl2+ license:gpl3+))))
+(define-public r-qvcalc
+ (package
+ (name "r-qvcalc")
+ (version "1.0.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "qvcalc" version))
+ (sha256
+ (base32
+ "0banzv78kb53ybfbh1hmgx7kxvpbbdxzg4dsn7vrwhmxs72srkch"))))
+ (properties `((upstream-name . "qvcalc")))
+ (build-system r-build-system)
+ (home-page "https://davidfirth.github.io/qvcalc")
+ (synopsis
+ "Quasi Variances for Factor Effects in Statistical Models")
+ (description
+ "This package provides functions to compute quasi variances and associated measures of approximation error.")
+ (license (list license:gpl2+ license:gpl3+))))
+
+
(define r-gpg
(package
(name "r-gpg")
--
2.36.0
K
[PATCH 09/14] gnu: Add r-gnm.
(address . guix-patches@gnu.org)(name . Kyle Andrews)(address . kyle@posteo.net)
ee708df2ec6356cafb183b64d2ca2c59a1b62c18.1651893551.git.kyle@posteo.net
From: Kyle Andrews <kyle@posteo.net>

---
gnu/packages/cran.scm | 21 +++++++++++++++++++++
1 file changed, 21 insertions(+)

Toggle diff (34 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index b86ab6127d..0114be8b0f 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -33405,6 +33405,27 @@ (define-public r-ca
"Computation and visualization of simple, multiple and joint correspondence analysis.")
(license (list license:gpl2+ license:gpl3+))))
+(define-public r-gnm
+ (package
+ (name "r-gnm")
+ (version "1.1-1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "gnm" version))
+ (sha256
+ (base32
+ "1lddsdsg43wpg681s906i4xqqfbjdd1qb9ml5dfprb02i1806aa2"))))
+ (properties `((upstream-name . "gnm")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-mass r-matrix r-nnet r-qvcalc r-relimp))
+ (home-page "https://github.com/hturner/gnm")
+ (synopsis "Generalized Nonlinear Models")
+ (description
+ "This package provides functions to specify and fit generalized nonlinear models, including models with multiplicative interaction terms such as the UNIDIFF model from sociology and the AMMI model from crop science, and many others. Over-parameterized representations of models are used throughout; functions are provided for inference on estimable parameter combinations, as well as standard methods for diagnostics etc.")
+ (license (list license:gpl2+ license:gpl3+))))
+
(define-public r-qvcalc
(package
(name "r-qvcalc")
--
2.36.0
K
[PATCH 11/14] gnu: Add r-picosat.
(address . guix-patches@gnu.org)(name . Kyle Andrews)(address . kyle@posteo.net)
39718183c1f2cb1ca010bcb905d5f1b44ac9a47f.1651893551.git.kyle@posteo.net
From: Kyle Andrews <kyle@posteo.net>

---
gnu/packages/cran.scm | 21 +++++++++++++++++++++
1 file changed, 21 insertions(+)

Toggle diff (34 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index f578cdfa2a..0c7a3d55ff 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -33466,6 +33466,27 @@ (define-public r-relimp
"This package provides functions to facilitate inference on the relative importance of predictors in a linear or generalized linear model, and a couple of useful Tcl/Tk widgets.")
(license license:gpl2+)))
+(define-public r-rpicosat
+ (package
+ (name "r-rpicosat")
+ (version "1.0.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "rpicosat" version))
+ (sha256
+ (base32
+ "1zj2d6jairmvya91vhv9kpkf34zmzl9vlha5yvfjj0j0apmqc0li"))))
+ (properties `((upstream-name . "rpicosat")))
+ (build-system r-build-system)
+ (home-page
+ "https://github.com/dirkschumacher/rpicosat")
+ (synopsis
+ "R Bindings for the 'PicoSAT' SAT Solver")
+ (description
+ "Bindings for the 'PicoSAT' solver to solve Boolean satisfiability problems (SAT). The boolean satisfiability problem asks the question if a given boolean formula can be TRUE; i.e. does there exist an assignment of TRUE/FALSE for each variable such that the whole formula is TRUE? The package bundles 'PicoSAT' solver release 965 <http://www.fmv.jku.at/picosat/>.")
+ (license license:expat)))
+
(define r-gpg
(package
--
2.36.0
K
[PATCH 12/14] gnu: Add r-ryacas.
(address . guix-patches@gnu.org)(name . Kyle Andrews)(address . kyle@posteo.net)
4ac9c8db561a0486186ed4daabb36c4e801f5179.1651893551.git.kyle@posteo.net
From: Kyle Andrews <kyle@posteo.net>

---
gnu/packages/cran.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (35 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 0c7a3d55ff..a2a29f8cdb 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -33487,6 +33487,28 @@ (define-public r-rpicosat
"Bindings for the 'PicoSAT' solver to solve Boolean satisfiability problems (SAT). The boolean satisfiability problem asks the question if a given boolean formula can be TRUE; i.e. does there exist an assignment of TRUE/FALSE for each variable such that the whole formula is TRUE? The package bundles 'PicoSAT' solver release 965 <http://www.fmv.jku.at/picosat/>.")
(license license:expat)))
+(define-public r-ryacas
+ (package
+ (name "r-ryacas")
+ (version "1.1.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "Ryacas" version))
+ (sha256
+ (base32
+ "12vkylq06c7kqvvf662cyzhdcnpy928xsjflf1kf0nh6y00gywf8"))))
+ (properties `((upstream-name . "Ryacas")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-magrittr r-rcpp))
+ (native-inputs (list r-knitr))
+ (home-page "https://github.com/r-cas/ryacas")
+ (synopsis
+ "R Interface to the 'Yacas' Computer Algebra System")
+ (description
+ "Interface to the 'yacas' computer algebra system (<http://www.yacas.org/>).")
+ (license (list license:gpl2+ license:gpl3+))))
+
(define r-gpg
(package
--
2.36.0
K
[PATCH 13/14] gnu: Add r-showimage.
(address . guix-patches@gnu.org)(name . Kyle Andrews)(address . kyle@posteo.net)
d0e924db67d0ae04897d6d9c655700c946accdf1.1651893551.git.kyle@posteo.net
From: Kyle Andrews <kyle@posteo.net>

---
gnu/packages/cran.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (35 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index a2a29f8cdb..30ca01c0a0 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -33509,6 +33509,28 @@ (define-public r-ryacas
"Interface to the 'yacas' computer algebra system (<http://www.yacas.org/>).")
(license (list license:gpl2+ license:gpl3+))))
+(define-public r-showimage
+ (package
+ (name "r-showimage")
+ (version "1.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "showimage" version))
+ (sha256
+ (base32
+ "1c0x3iqjdjsz3cdhc02b3qm2pwxjr1q2k87jwvxj9lnzzw81f1pl"))))
+ (properties `((upstream-name . "showimage")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-png))
+ (home-page
+ "https://github.com/r-lib/showimage#readme")
+ (synopsis
+ "Show an Image on an 'R' Graphics Device")
+ (description
+ "Sometimes it is handy to be able to view an image file on an 'R' graphics device. This package just does that. Currently it supports 'PNG' files.")
+ (license (list license:gpl2 license:gpl3))))
+
(define r-gpg
(package
--
2.36.0
K
[PATCH 10/14] gnu: Add r-relimp.
(address . guix-patches@gnu.org)(name . Kyle Andrews)(address . kyle@posteo.net)
f6c73891b79ae28903f9a2733f950ef6c5f2c28e.1651893551.git.kyle@posteo.net
From: Kyle Andrews <kyle@posteo.net>

---
gnu/packages/cran.scm | 20 ++++++++++++++++++++
1 file changed, 20 insertions(+)

Toggle diff (33 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 0114be8b0f..f578cdfa2a 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -33446,6 +33446,26 @@ (define-public r-qvcalc
"This package provides functions to compute quasi variances and associated measures of approximation error.")
(license (list license:gpl2+ license:gpl3+))))
+(define-public r-relimp
+ (package
+ (name "r-relimp")
+ (version "1.0-5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "relimp" version))
+ (sha256
+ (base32
+ "0ydn82g8xdqzhf34187080bbpcpw1zdjbj2i3dv1d6d35vvprb5c"))))
+ (properties `((upstream-name . "relimp")))
+ (build-system r-build-system)
+ (home-page "http://warwick.ac.uk/relimp")
+ (synopsis
+ "Relative Contribution of Effects in a Regression Model")
+ (description
+ "This package provides functions to facilitate inference on the relative importance of predictors in a linear or generalized linear model, and a couple of useful Tcl/Tk widgets.")
+ (license license:gpl2+)))
+
(define r-gpg
(package
--
2.36.0
K
[PATCH 14/14] gnu: Add r-genoud.
(address . guix-patches@gnu.org)(name . Kyle Andrews)(address . kyle@posteo.net)
70ddce67a95804b32dd72ae4cf53066c7b9aacd9.1651893551.git.kyle@posteo.net
From: Kyle Andrews <kyle@posteo.net>

---
gnu/packages/cran.scm | 20 ++++++++++++++++++++
1 file changed, 20 insertions(+)

Toggle diff (33 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 30ca01c0a0..2bd741d254 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -33531,6 +33531,26 @@ (define-public r-showimage
"Sometimes it is handy to be able to view an image file on an 'R' graphics device. This package just does that. Currently it supports 'PNG' files.")
(license (list license:gpl2 license:gpl3))))
+(define-public r-rgenoud
+ (package
+ (name "r-rgenoud")
+ (version "5.8-3.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "rgenoud" version))
+ (sha256
+ (base32
+ "0p93wf6ghgz2nifxbscb6bhahh5jd2ba7nh1c2mb6fmbxnsi3swv"))))
+ (properties `((upstream-name . "rgenoud")))
+ (build-system r-build-system)
+ (home-page "http://sekhon.berkeley.edu/rgenoud/")
+ (synopsis
+ "R Version of GENetic Optimization Using Derivatives")
+ (description
+ "This package provides a genetic algorithm plus derivative optimizer.")
+ (license license:gpl3)))
+
(define r-gpg
(package
--
2.36.0
M
M
Maxime Devos wrote on 13 May 2022 09:10
Re: [bug#55379] [PATCH 01/14] gnu: Add r-gpg.
1ff91bc19a74b5d2418c70804abe3f3a5afc8b31.camel@telenet.be
kyle schreef op do 12-05-2022 om 02:10 [+0000]:
Toggle quote (3 lines)
> +   (propagated-inputs
> +    `(("r-askpass" ,r-askpass) ("r-curl" ,r-curl)))

Can probably be simplified to (propagated-inputs (list r-askpass)).

Toggle quote (3 lines)
> +   (inputs
> +    `(("gpgme" ,gpgme) ("gnupg" ,gnupg)))

Likewise.

Toggle quote (4 lines)
> +   (native-inputs
> +    `(("pkg-config" ,pkg-config) ("r-knitr" ,r-knitr)))


Likewise.


Toggle quote (3 lines)
> + (home-page
> + "https://jeroen.cran.dev/gpg/https://github.com/jeroen/gpg")

Either https://jeroen.cran.dev/gpg/or https://github.com/jeroen/gpg ,
the combination gives a 404 Not Found.

Toggle quote (3 lines)
> Note that some functionality depends on the version of GnuPG that is
> installed on the system.

Maybe make sure that it only invokes the "gnupg" by absolute file name
such that this isn't the case.

Toggle quote (3 lines)
> On Windows this package can be used together with 'GPG4Win' which
> provides a GUI for managing keys and entering passphrases.

While theoretically Guix supports cross-compilation to Windows, I don't
see GPG4Win in the package inputs and I'd expect cross-compiling r-gpg
to Windows to fail, so I would remove this paragraph since currently
it's a bit misleading.

Greetings,
Maxime.
-----BEGIN PGP SIGNATURE-----

iI0EABYKADUWIQTB8z7iDFKP233XAR9J4+4iGRcl7gUCYn4EeBccbWF4aW1lZGV2
b3NAdGVsZW5ldC5iZQAKCRBJ4+4iGRcl7gjTAP0S6NeJZrRLR1cJxOb+mva580fL
hrmzAGKfs+gfKPBa7QD9HVptZ7W6BG3+7Lay2CTGFZEroEX6wGr4/+TdjeusCwQ=
=4RR3
-----END PGP SIGNATURE-----


M
M
Maxime Devos wrote on 14 May 2022 12:53
Re: [bug#55379] [PATCH 04/14] gnu: Add r-unpivotr.
a4e18988582b5a99613048ac6710b8f7e4bdb64b.camel@telenet.be
kyle schreef op do 12-05-2022 om 02:10 [+0000]:
Toggle quote (3 lines)
> +   (license license:expat)))


The license text appears to be missing, even though the Expat license
says:

[...] subject to the following conditions:

The above copyright notice and this permission notice shall be
included in all copies or substantial portions of the Software.

So as-is, I don't think we can include r-unpivotr in Guix. Would
probably be easily resolved with a PR or issue at

Greetings,
Maxime.
-----BEGIN PGP SIGNATURE-----

iI0EABYKADUWIQTB8z7iDFKP233XAR9J4+4iGRcl7gUCYn+KKBccbWF4aW1lZGV2
b3NAdGVsZW5ldC5iZQAKCRBJ4+4iGRcl7kmfAP92riYjFDLbIMJjNt0SLets6lMg
JYQdLhwizwkVlQfRigD8CDxq5m/5bGkMHz9BsJ7bkYsIc0Q24PFIiiMG99K8WQY=
=Wzex
-----END PGP SIGNATURE-----


M
M
Maxime Devos wrote on 14 May 2022 20:02
Re: [bug#55379] [PATCH 01/14] gnu: Add r-gpg.
(name . Kyle Andrews)(address . kyle@posteo.net)(address . 55379@debbugs.gnu.org)
9690cc4c8dec19308087c81cf50c596618fcddde.camel@telenet.be
Kyle Andrews schreef op za 14-05-2022 om 16:53 [+0000]:
Toggle quote (12 lines)
> > [[PGP Signed Part:Undecided]]
> > kyle schreef op do 12-05-2022 om 02:10 [+0000]:
> > > +   (propagated-inputs
> > > +    `(("r-askpass" ,r-askpass) ("r-curl" ,r-curl)))
> >
> > Can probably be simplified to (propagated-inputs (list r-askpass)).
> >
>
> According to the ~DESCRIPTION~ file the package will not build
> without
> both askpass and curl R packages. So, I will leave those in.

Oops I meant (propagated-inputs (list r-askpass r-curl)) here -- keep
the inputs, but remove the labels, as per

Greetings,
Maxime.
-----BEGIN PGP SIGNATURE-----

iI0EABYKADUWIQTB8z7iDFKP233XAR9J4+4iGRcl7gUCYn/uoxccbWF4aW1lZGV2
b3NAdGVsZW5ldC5iZQAKCRBJ4+4iGRcl7gDpAQCauxq383ySU4iLNJWnuhDN0UEF
kA8Z3uAtYcSQ7LzWjwEAl0TlHBXtGgXoJx4l531vfe6AfkRklEiWT/xG//UgfQs=
=f+Ea
-----END PGP SIGNATURE-----


M
M
Maxime Devos wrote on 14 May 2022 20:07
(name . Kyle Andrews)(address . kyle@posteo.net)(address . 55379@debbugs.gnu.org)
1b2f89411c60978a60844f41a4fd79c0c524e694.camel@telenet.be
TBC I just looked at the package definitions a bit, it's not in-depth.

E.g., in this case:

+ "R Interface to the 'Yacas' Computer Algebra System")
+ [...]


TeXinfo markup can be used to make the 'Yacas' teletype when viewed
from https://guix.gnu.org/en/packages/ and to make the link hyperlink
a hyperlink in "guix show" and the HTML. And a synopsis isn't a book
title or such, it's just a phrase (though often not a complete
sentence), so no need for mid-phrase capitals.

There are also some other packages with missing license text, e.g. the
first next package I chose (rust-gnm) doesn't seem to carry a copy of
the GPL.

Greetings,
Maxime.
-----BEGIN PGP SIGNATURE-----

iI0EABYKADUWIQTB8z7iDFKP233XAR9J4+4iGRcl7gUCYn/v8hccbWF4aW1lZGV2
b3NAdGVsZW5ldC5iZQAKCRBJ4+4iGRcl7iduAQCWzxySCfp2y7YUUPIKzot3cxNG
yoVtIUVS9k0tFGvhUgEAmIEb/o59Xcy6Bh/bXpOxrCnnxltu1omcuuX87PaGfQ0=
=IdHW
-----END PGP SIGNATURE-----


K
K
Kyle Andrews wrote on 15 May 2022 18:24
(name . Maxime Devos)(address . maximedevos@telenet.be)(address . 55379@debbugs.gnu.org)
87h75q69e5.fsf@posteo.net
Hi Maxime,

Here is the version of the GPG package which I intended to send in the
first place with the verbiage about GPG4WIN removed per your suggestion.

8<------------------------------------------------------------------------------------
(define-public r-gpg
(package
(name "r-gpg")
(version "1.2.6")
(source
(origin
(method url-fetch)
(uri (cran-uri "gpg" version))
(sha256
(base32 "17rvi3qff2kanqr3g20dzhn48bfh5sv57g0wsamndzcif7rhjhby"))))
(properties `((upstream-name . "gpg")))
(build-system r-build-system)
(propagated-inputs (list r-askpass r-curl))
(native-inputs (list pkg-config r-knitr gpgme gnupg))
(synopsis "GNU Privacy Guard for R")
(description
"Bindings to GnuPG for working with OpenGPG (RFC4880) cryptographic methods.
Includes utilities for public key encryption, creating and verifying digital
signatures, and managing your local keyring. Some functionality depends on the
version of GnuPG that is installed on the system.")
(license license:expat)))
------------------------------------------------------------------------------------>8

I have also attached a new patch.

Kyle
From 23af100007b123ee093cff333b2235b9cb394d2e Mon Sep 17 00:00:00 2001
Message-Id: <23af100007b123ee093cff333b2235b9cb394d2e.1652632450.git.kyle@posteo.net>
From: Kyle Andrews <kyle@posteo.net>
Date: Sun, 15 May 2022 12:33:26 -0400
Subject: [PATCH] gnu: Add r-gpg.

---
gnu/packages/cran.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)

Toggle diff (33 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 5c05f20ea7..b34eba8f76 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -33255,3 +33255,26 @@ (define-public r-zoeppritz
coefficients or scattering amplitudes, for seismological P and S-waves at an
interface.")
(license license:gpl2+)))
+
+(define-public r-gpg
+ (package
+ (name "r-gpg")
+ (version "1.2.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "gpg" version))
+ (sha256
+ (base32 "17rvi3qff2kanqr3g20dzhn48bfh5sv57g0wsamndzcif7rhjhby"))))
+ (properties `((upstream-name . "gpg")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-askpass r-curl))
+ (native-inputs (list pkg-config r-knitr gpgme gnupg))
+ (home-page "https://github.com/jeroen/gpg")
+ (synopsis "GNU Privacy Guard for R")
+ (description
+ "Bindings to GnuPG for working with OpenGPG (RFC4880) cryptographic methods.
+Includes utilities for public key encryption, creating and verifying digital
+signatures, and managing your local keyring. Some functionality depends on the
+version of GnuPG that is installed on the system.")
+ (license license:expat)))
--
2.36.0
Maxime Devos <maximedevos@telenet.be> writes:

Toggle quote (22 lines)
> [[PGP Signed Part:Undecided]]
> Kyle Andrews schreef op za 14-05-2022 om 16:53 [+0000]:
>> > [[PGP Signed Part:Undecided]]
>> > kyle schreef op do 12-05-2022 om 02:10 [+0000]:
>> > > +   (propagated-inputs
>> > > +    `(("r-askpass" ,r-askpass) ("r-curl" ,r-curl)))
>> >
>> > Can probably be simplified to (propagated-inputs (list r-askpass)).
>> >
>>
>> According to the ~DESCRIPTION~ file the package will not build
>> without
>> both askpass and curl R packages. So, I will leave those in.
>
> Oops I meant (propagated-inputs (list r-askpass r-curl)) here -- keep
> the inputs, but remove the labels, as per
> <https://guix.gnu.org/en/blog/2021/the-big-change/>.
>
> Greetings,
> Maxime.
>
> [[End of PGP Signed Part]]
K
K
Kyle Andrews wrote on 18 May 2022 03:09
Re: [bug#55379] [PATCH 04/14] gnu: Add r-unpivotr.
(name . Maxime Devos)(address . maximedevos@telenet.be)(address . 55379@debbugs.gnu.org)
877d6jd4sz.fsf@posteo.net
Maxime Devos <maximedevos@telenet.be> writes:

Toggle quote (22 lines)
> [[PGP Signed Part:Undecided]]
> kyle schreef op do 12-05-2022 om 02:10 [+0000]:
>> +   (license license:expat)))
>
>
> The license text appears to be missing, even though the Expat license
> says:
>
> [...] subject to the following conditions:
>
> The above copyright notice and this permission notice shall be
> included in all copies or substantial portions of the Software.
>
> So as-is, I don't think we can include r-unpivotr in Guix. Would
> probably be easily resolved with a PR or issue at
> <https://github.com/nacnudus/unpivotr>.
>
> Greetings,
> Maxime.
>
> [[End of PGP Signed Part]]

I did just that and the package author merged my pull request with the
MIT license text.

Cheers,
Kyle
R
R
Ricardo Wurmus wrote on 18 Dec 2022 09:58
[PATCH 01/14] gnu: Add r-gpg.
(address . 55379@debbugs.gnu.org)
87tu1tniog.fsf@elephly.net
Hi Kyle,

I’ve been trying to apply these patches but haven’t been successful.
Have they been generated with “git format-patch”? It looks like they
haven’t. You can generate a patch series for the last 14 commits with
“git format-patch -14”, for example. To send an updated patch set you
can use “--reroll-count” (or “-v”), e.g. “--reroll-count 2”. This
generates emails with “[PATCH v2 …]” subjects, so we can automatically
extract all patches belonging to this new patch set.

I would be very happy if you could refresh this patch set on top of the
current “master” branch.

Please add each package definition to the file in alphabetic order. It
simplifies future maintenance.

I see that the descriptions contain straight single quotes for procedure
names and package names. We prefer to use texinfo syntax for procedures
instead, e.g. “@code{glm()}” instead of “'glm()'”. There are also some
packages that have only sentence fragments for descriptions (e.g. r-ca).
Could you please turn those into complete sentences? A common fix is to
prefix the description with “This package provides”.

Thanks!

--
Ricardo
R
R
Ricardo Wurmus wrote on 29 Dec 2022 20:39
(name . GNU bug tracker automated control server)(address . control@debbugs.gnu.org)
87wn6a80d2.fsf@elephly.net
tags 55379 moreinfo
thanks

--
Ricardo
?