(address . guix-patches@gnu.org)
TBD:
* [ ] Commit message
* [ ] Testing beyond ‘it builds’
* [ ] Proper usage of "git format-patch"
* [ ] 'guix style'
* [ ] "guix refresh --list-dependents" and such
Just sending it now such that it doesn't disappear, intend to make it a
proper patch submission later ...
Toggle diff (32 lines)
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 4472677ab3..ffadb1312b 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -1569,18 +1569,17 @@ (define-public recutils
"14xiln4immfsw8isnvwvq0h23f6z0wilpgsc4qzabnrzb5lsx3nz"))))
(build-system gnu-build-system)
- (arguments '(#:configure-flags
- (list (string-append "--with-bash-headers="
- (assoc-ref %build-inputs
"bash:include")
- "/include/bash"))))
-
+ (arguments
+ (list #:configure-flags
+ #~(list (string-append "--with-bash-headers="
+ (search-input-directory %build-
inputs "/include/bash")))))
(native-inputs `(("bc" ,bc)
- ("bash:include" ,bash "include")
("check" ,check-0.14)
("pkg-config" ,pkg-config)))
;; TODO: Add more optional inputs.
- (inputs `(("curl" ,curl)
+ (inputs `(("bash:include" ,bash "include")
+ ("curl" ,curl)
("libgcrypt" ,libgcrypt)
("libuuid" ,util-linux "lib")))
(synopsis "Manipulate plain text files as databases")
-----BEGIN PGP SIGNATURE-----
iI0EABYKADUWIQTB8z7iDFKP233XAR9J4+4iGRcl7gUCYnwp3hccbWF4aW1lZGV2
b3NAdGVsZW5ldC5iZQAKCRBJ4+4iGRcl7iP2AQC2ukXXMQVhbUJXFAhqeBu+2qsZ
miHbK2RMPGHaI+8IIAD/aMNABY4nbV4Od3yZxzVwKn38NBln5G7x1VtjNnIhuwo=
=rgKO
-----END PGP SIGNATURE-----