[PATCH 3/4] gnu: Add r-smurf.

  • Done
  • quality assurance status badge
Details
2 participants
  • MadalinIonel.Patrascu@mdc-berlin.de
  • Mădălin Ionel Patrașcu
Owner
unassigned
Submitted by
Mădălin Ionel Patrașcu
Severity
normal
Merged with

Debbugs page

Mădălin Ionel Patrașcu wrote 3 years ago
(address . guix-patches@gnu.org)
20220503065311.9192-3-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/cran.scm (r-smurf): New variable.
---
gnu/packages/cran.scm | 42 ++++++++++++++++++++++++++++++++++++++++++
1 file changed, 42 insertions(+)

Toggle diff (55 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 63e2b71cd3..099bfb8002 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -5907,6 +5907,48 @@ (define-public r-sm
and density estimation")
(license license:gpl2+)))
+(define-public r-smurf
+ (package
+ (name "r-smurf")
+ (version "1.1.2")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "smurf" version))
+ (sha256
+ (base32
+ "00q54pg42anilhcshhjvv277mkszbpzpkf1g7srs7cjd5skjvsaf"))))
+ (properties `((upstream-name . "smurf")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-catdata
+ r-glmnet
+ r-mass
+ r-matrix
+ r-mgcv
+ r-rcolorbrewer
+ r-rcpp
+ r-rcpparmadillo
+ r-speedglm))
+ (native-inputs (list r-knitr))
+ (home-page "https://gitlab.com/TReynkens/smurf")
+ (synopsis "Sparse multi-type regularized feature modeling")
+ (description
+ "The @code{smurf} package contains the implementation of the @dfn{Sparse
+Multi-type Regularized Feature} (SMuRF) modeling algorithm to fit
+@dfn{generalized linear models} (GLMs) with multiple types of predictors via
+regularized maximum likelihood. Next to the fitting procedure, following
+functionality is available:
+
+@itemize @bullet
+@item
+Selection of the regularization tuning parameter lambda using three different
+approaches: in-sample, out-of-sample or using cross-validation.
+@item
+S3 methods to handle the fitted object including visualization of the coefficients
+and a model summary.
+@end itemize")
+ (license license:gpl2+)))
+
(define-public r-venndiagram
(package
(name "r-venndiagram")
--
2.36.0
MadalinIonel.Patrascu@mdc-berlin.de wrote 3 years ago
(name . control@debbugs.gnu.org)(address . control@debbugs.gnu.org)
f3718a5c6cc249e6a684efc4e61e9833@mdc-berlin.de
merge 55237 55239 55238 55241 55240

thanks
Attachment: file
?
Your comment

This issue is archived.

To comment on this conversation send an email to 55241@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 55241
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help