[PATCH 1/2] gnu: lua-luv: upgrade to version 1.43.0

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Ryan Sundberg
Owner
unassigned
Submitted by
Ryan Sundberg
Severity
normal
Merged with

Debbugs page

Ryan Sundberg wrote 3 years ago
(address . guix-patches@gnu.org)(name . Ryan Sundberg)(address . ryan@arctype.co)
20220502191338.5032-1-ryan@arctype.co
* gnu/packages/lua.scm (lua-luv, lua5.1-luv, lua5.2-luv): Upgrade to 1.43.0
---
gnu/packages/lua.scm | 12 ++++++------
1 file changed, 6 insertions(+), 6 deletions(-)

Toggle diff (50 lines)
diff --git a/gnu/packages/lua.scm b/gnu/packages/lua.scm
index ee4b7727e0..1061977f3b 100644
--- a/gnu/packages/lua.scm
+++ b/gnu/packages/lua.scm
@@ -785,7 +785,7 @@ (define-public lua5.2-lpeg
(define (make-lua-luv name lua)
(package
(name name)
- (version "1.32.0-0")
+ (version "1.43.0-0")
(source (origin
;; The release tarball includes the sources of libuv but does
;; not include the pkg-config files.
@@ -796,7 +796,7 @@ (define (make-lua-luv name lua)
(file-name (git-file-name name version))
(sha256
(base32
- "0c65c1lhbl0axnyks3910gjs0z0hw7w6jvl07g8kbpnbvfl4qajh"))))
+ "1yzi4bm845vl84wyv2qw4z1n1v285lgwm681swmp84brfy2s7czp"))))
(build-system cmake-build-system)
(arguments
`(#:tests? #f ; there are none
@@ -811,9 +811,9 @@ (define (make-lua-luv name lua)
(add-after 'unpack 'copy-lua-compat
(lambda* (#:key inputs #:allow-other-keys)
(copy-recursively (assoc-ref inputs "lua-compat")
- "lua-compat")
+ "deps/lua-compat-5.3")
(setenv "CPATH"
- (string-append (getcwd) "/lua-compat:"
+ (string-append (getcwd) "/deps/lua-compat-5.3:"
(or (getenv "CPATH") "")))
#t)))))
(inputs
@@ -824,11 +824,11 @@ (define (make-lua-luv name lua)
(method git-fetch)
(uri (git-reference
(url "https://github.com/keplerproject/lua-compat-5.3")
- (commit "daebe77a2f498817713df37f0bb316db1d82222f")))
+ (commit "v0.10")))
(file-name "lua-compat-5.3-checkout")
(sha256
(base32
- "02a14nvn7aggg1yikj9h3dcf8aqjbxlws1bfvqbpfxv9d5phnrpz"))))))
+ "1caxn228gx48g6kymp9w7kczgxcg0v0cd5ixsx8viybzkd60dcn4"))))))
(home-page "https://github.com/luvit/luv/")
(synopsis "Libuv bindings for Lua")
(description
--
2.34.0
Ludovic Courtès wrote 3 years ago
control message for bug #55228
(address . control@debbugs.gnu.org)
874k1kxe4t.fsf@gnu.org
merge 55228 55229
quit
?
Your comment

This issue is archived.

To comment on this conversation send an email to 55229@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 55229
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help