[PATCH] gnu: Add r-aims.

  • Done
  • quality assurance status badge
Details
2 participants
  • Mădălin Ionel Patrașcu
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Mădălin Ionel Patrașcu
Severity
normal

Debbugs page

Mădălin Ionel Patrașcu wrote 3 years ago
(address . guix-patches@gnu.org)
20220502094955.32309-1-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/bioconductor.scm (r-aims): New variable.
---
gnu/packages/bioconductor.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)

Toggle diff (38 lines)
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index a78903becc..17fa746fae 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -1877,6 +1877,29 @@ (define-public r-agilp
;; GPLv3.
(license license:gpl3)))
+(define-public r-aims
+ (package
+ (name "r-aims")
+ (version "1.28.0")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "AIMS" version))
+ (sha256
+ (base32
+ "1z7yzaizyzcv556w8880603nd947k0d6raadjm42mdl66mma0cdx"))))
+ (properties `((upstream-name . "AIMS")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-biobase r-e1071))
+ (home-page "https://git.bioconductor.org/packages/AIMS")
+ (synopsis
+ "Absolute assignment of breast cancer intrinsic molecular subtype")
+ (description
+ "This package contains the @code{AIMS} implementation. It contains
+necessary functions to assign the five intrinsic molecular subtypes (Luminal A,
+Luminal B, Her2-enriched, Basal-like, Normal-like). Assignments could be done
+on individual samples as well as on dataset of gene expression data.")
+ (license license:artistic2.0)))
+
(define-public r-aneufinder
(package
(name "r-aneufinder")

base-commit: 098f2eea331121905e3c867f478b22cea3510841
--
2.36.0
Ricardo Wurmus wrote 2 years ago
(address . 55219-done@debbugs.gnu.org)
878rk0o1vf.fsf@elephly.net
Applied and updated, thanks!

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 55219@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 55219
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help