Intermittent ldap test failure

  • Done
  • quality assurance status badge
Details
2 participants
  • Mathieu Othacehe
  • Timotej Lazar
Owner
unassigned
Submitted by
Mathieu Othacehe
Severity
normal
M
M
Mathieu Othacehe wrote on 1 May 2022 13:09
(address . bug-guix@gnu.org)(name . Ricardo Wurmus)(address . rekado@elephly.net)
87r15dmrvk.fsf@gnu.org
Hello,

The ldap test in intermittently failing:

It looks like the ldap_bind call is failing:
ldap_bind: Invalid credentials (49)

and the "eva" user is hence not created. Ricardo any idea what could be
going wrong?

Here is the log of a successful run to compare:

Thanks,

Mathieu
T
T
Timotej Lazar wrote on 23 Jun 2022 18:28
(name . Ricardo Wurmus)(address . rekado@elephly.net)
87wnd7pcmy.fsf@araneo.si
Hi,

Mathieu Othacehe <othacehe@gnu.org> [2022-05-01 13:09:19+0200]:
Toggle quote (3 lines)
> The ldap test in intermittently failing:
> https://ci.guix.gnu.org/build/703858/log/raw.

I just encountered the same failure with a different error:

komputilo login: Traceback (most recent call last):
File "/gnu/store/jkfbqqv7dk38xr1a214razjlxip49hip-389-ds-base-1.4.4.17/sbin/.dsctl-real", line 20, in <module>
OSError: [Errno 12] Cannot allocate memory: '/gnu/store/jkfbqqv7dk38xr1a214razjlxip49hip-389-ds-base-1.4.4.17/lib/python3.9/site-packages/lib389/cli_ctl'

About 50% of test runs fail, either with this error or the one from the
original report.

After increasing the memory limit for the test VM, I was able to run the
test successfully ten times on two different machines. The patch is
attached.
From 7e187015b49469671d9a25e5c1f3892f5e396ac6 Mon Sep 17 00:00:00 2001
From: Timotej Lazar <timotej.lazar@araneo.si>
Date: Thu, 23 Jun 2022 18:13:29 +0200
Subject: [PATCH] tests: ldap: Increase VM memory size.
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

With the default limit of 512 MB the test sometimes fails, in different

* gnu/tests/ldap.scm (run-ldap-test): Increase memory size to 1024 MiB.
---
gnu/tests/ldap.scm | 4 +++-
1 file changed, 3 insertions(+), 1 deletion(-)

Toggle diff (17 lines)
diff --git a/gnu/tests/ldap.scm b/gnu/tests/ldap.scm
index d5403b3539..47e77c0c53 100644
--- a/gnu/tests/ldap.scm
+++ b/gnu/tests/ldap.scm
@@ -58,7 +58,9 @@ (define os
(guix combinators))))
(define vm
- (virtual-machine os))
+ (virtual-machine
+ (operating-system os)
+ (memory-size 1024)))
(define test
(with-imported-modules '((gnu build marionette))
--
2.36.1
M
M
Mathieu Othacehe wrote on 24 Jun 2022 10:26
(name . Timotej Lazar)(address . timotej.lazar@araneo.si)
875ykqjwlw.fsf@gnu.org
Hey Timotej,

Toggle quote (4 lines)
> After increasing the memory limit for the test VM, I was able to run the
> test successfully ten times on two different machines. The patch is
> attached.

Great, that wouldn't be the first time that the RAM limitation causes
strange transient issues.

I'm pushing the proposed patch and closing this bug,

Thanks,

Mathieu
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 55206@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 55206
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch