guix refresh -u has wrong hash update

  • Open
  • quality assurance status badge
Details
One participant
  • kiasoc5
Owner
unassigned
Submitted by
kiasoc5
Severity
normal
K
K
kiasoc5 wrote on 30 Apr 2022 01:31
(name . Bug Guix)(address . bug-guix@gnu.org)
N0reUAF--3-2@tutanota.com
./pre-inst-env guix refresh -u gnome-shell-extension-burn-my-windows results in the following:

Toggle diff (24 lines)
diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index fb071cb89b..582810e3c9 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -825,7 +825,7 @@ (define-public gnome-shell-extension-jiggle
(define-public gnome-shell-extension-burn-my-windows
   (package
     (name "gnome-shell-extension-burn-my-windows")
-    (version "7")
+    (version "15")
     (source
      (origin
        (method git-fetch)
@@ -834,7 +834,7 @@ (define-public gnome-shell-extension-burn-my-windows
              (commit (string-append "v" version))))
        (sha256
         (base32
-         "1513kh6dfvnaj5jq2mm7rv1k54v91hjckgim1dpqlxwnv4gi9krd"))
+         "1513kh6dfvnaj5jq2mm15rv1k54v91hjckgim1dpqlxwnv4gi9krd"))
        (file-name (git-file-name name version))))
     (build-system copy-build-system)
     (arguments

For the hash has the wrong length and is different only at one character in the middle (7 vs 15).
?