(address . guix-patches@gnu.org)
From 53b4108bf283b4e54da069078f18716dadf91b9b Mon Sep 17 00:00:00 2001
From: Peter Polidoro <peter@polidoro.io>
Date: Fri, 29 Apr 2022 13:12:46 -0400
Subject: [PATCH] gnu: Add python-vitables.
* gnu/packages/python-xyz.scm (python-vitables): New variable.
---
gnu/packages/python-xyz.scm | 29 +++++++++++++++++++++++++++++
1 file changed, 29 insertions(+)
Toggle diff (39 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index f8e599a453..20ecb372db 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -29587,3 +29587,32 @@ (define-public python-mike
versions of MkDocs-powered docs to a Git branch. It is suitable for deploying
to Github via gh-pages.")
(license license:bsd-3)))
+
+(define-public python-vitables
+ (package
+ (name "python-vitables")
+ (version "3.0.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "ViTables" version))
+ (sha256
+ (base32 "1vk80a8jbg0phxgf31rnm7gq34mllv7hb5h0bypz4kv7n3150iln"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ (list python-numexpr
+ python-numpy
+ python-pyqt
+ python-qtpy
+ python-tables))
+ (arguments
+ `(#:tests? #f))
+ (home-page "https://vitables.org")
+ (synopsis "GUI for browsing PyTables and HDF5 files")
+ (description "ViTables is a GUI for browsing and editing files in both
+PyTables and HDF5 formats. ViTables capabilities include easy navigation
+through the data hierarchy, displaying of real data and its associated
+metadata, a simple, yet powerful, browsing of multidimensional data and much
+more. As a viewer, one of the greatest strengths of ViTables is its ability to
+display very large datasets.")
+ (license license:gpl3)))
--
2.36.0