[PATCH] gnu: Add python-vitables.

  • Open
  • quality assurance status badge
Details
2 participants
  • Mathieu Othacehe
  • Peter Polidoro
Owner
unassigned
Submitted by
Peter Polidoro
Severity
normal
P
P
Peter Polidoro wrote on 29 Apr 2022 19:13
(address . guix-patches@gnu.org)
86levnizgk.fsf@polidoro.io
From 53b4108bf283b4e54da069078f18716dadf91b9b Mon Sep 17 00:00:00 2001
From: Peter Polidoro <peter@polidoro.io>
Date: Fri, 29 Apr 2022 13:12:46 -0400
Subject: [PATCH] gnu: Add python-vitables.

* gnu/packages/python-xyz.scm (python-vitables): New variable.
---
gnu/packages/python-xyz.scm | 29 +++++++++++++++++++++++++++++
1 file changed, 29 insertions(+)

Toggle diff (39 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index f8e599a453..20ecb372db 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -29587,3 +29587,32 @@ (define-public python-mike
versions of MkDocs-powered docs to a Git branch. It is suitable for deploying
to Github via gh-pages.")
(license license:bsd-3)))
+
+(define-public python-vitables
+ (package
+ (name "python-vitables")
+ (version "3.0.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "ViTables" version))
+ (sha256
+ (base32 "1vk80a8jbg0phxgf31rnm7gq34mllv7hb5h0bypz4kv7n3150iln"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ (list python-numexpr
+ python-numpy
+ python-pyqt
+ python-qtpy
+ python-tables))
+ (arguments
+ `(#:tests? #f))
+ (home-page "https://vitables.org")
+ (synopsis "GUI for browsing PyTables and HDF5 files")
+ (description "ViTables is a GUI for browsing and editing files in both
+PyTables and HDF5 formats. ViTables capabilities include easy navigation
+through the data hierarchy, displaying of real data and its associated
+metadata, a simple, yet powerful, browsing of multidimensional data and much
+more. As a viewer, one of the greatest strengths of ViTables is its ability to
+display very large datasets.")
+ (license license:gpl3)))
--
2.36.0
M
M
Mathieu Othacehe wrote on 9 May 2022 11:29
(name . Peter Polidoro)(address . peter@polidoro.io)(address . 55188@debbugs.gnu.org)
87tu9zjbp9.fsf@gnu.org
Hello Peter,

Toggle quote (3 lines)
> + (arguments
> + `(#:tests? #f))

You should add a comment stating why the tests are disabled. Because
there are no tests or because they are failing, and if so why?

Toggle quote (8 lines)
> + (description "ViTables is a GUI for browsing and editing files in both
> +PyTables and HDF5 formats. ViTables capabilities include easy navigation
> +through the data hierarchy, displaying of real data and its associated
> +metadata, a simple, yet powerful, browsing of multidimensional data and much
> +more. As a viewer, one of the greatest strengths of ViTables is its ability to
> +display very large datasets.")
> + (license license:gpl3)))

The description could be more neutral: you could remove the "yet
powerful" and "much more" parts. The last sentence could also be
reworded: "As a viewer, ViTables is able to display very large datasets."
feels more factual.

Could you send an updated patch :) ?

Thanks,

Mathieu
P
P
Peter Polidoro wrote on 12 May 2022 16:55
(name . Mathieu Othacehe)(address . othacehe@gnu.org)(address . 55188@debbugs.gnu.org)
86bkw2aj73.fsf@polidoro.io
Hi,

I have made changes you suggested to the description and have
attached a new patch, thank you.

I tried to get the tests to run, but they have errors and I do not
know enough yet to fix them myself:

qt.qpa.xcb: could not connect to display
qt.qpa.plugin: Could not load the Qt platform plugin "xcb" in ""
even though it was found.

Is it possible to get tests like this to work when building
packages in isolated environments? Or is it necessary to disable
these tests?

Thank you for your time!


Mathieu Othacehe <othacehe@gnu.org> writes:

Toggle quote (33 lines)
> Hello Peter,
>
>> + (arguments
>> + `(#:tests? #f))
>
> You should add a comment stating why the tests are disabled.
> Because
> there are no tests or because they are failing, and if so why?
>
>> + (description "ViTables is a GUI for browsing and editing
>> files in both
>> +PyTables and HDF5 formats. ViTables capabilities include easy
>> navigation
>> +through the data hierarchy, displaying of real data and its
>> associated
>> +metadata, a simple, yet powerful, browsing of multidimensional
>> data and much
>> +more. As a viewer, one of the greatest strengths of ViTables
>> is its ability to
>> +display very large datasets.")
>> + (license license:gpl3)))
>
> The description could be more neutral: you could remove the "yet
> powerful" and "much more" parts. The last sentence could also be
> reworded: "As a viewer, ViTables is able to display very large
> datasets."
> feels more factual.
>
> Could you send an updated patch :) ?
>
> Thanks,
>
> Mathieu
From 693b8cf04dfd6a6c74e9d6d232a3a1f8aadb763c Mon Sep 17 00:00:00 2001
Message-Id: <693b8cf04dfd6a6c74e9d6d232a3a1f8aadb763c.1652367274.git.peter@polidoro.io>
From: Peter Polidoro <peter@polidoro.io>
Date: Thu, 12 May 2022 10:53:48 -0400
Subject: [PATCH] gnu: Add python-vitables.

* gnu/packages/python-xyz.scm (python-vitables): New variable.
---
gnu/packages/python-xyz.scm | 32 ++++++++++++++++++++++++++++++++
1 file changed, 32 insertions(+)

Toggle diff (42 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 659538d193..ed6992721b 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -29884,3 +29884,35 @@ (define-public python-deepmerge
"The @code{deep-merge} Python library provides a toolset to deeply merge
nested data structures in Python like lists and dictionaries.")
(license license:expat)))
+
+(define-public python-vitables
+ (package
+ (name "python-vitables")
+ (version "3.0.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "ViTables" version))
+ (sha256
+ (base32 "1vk80a8jbg0phxgf31rnm7gq34mllv7hb5h0bypz4kv7n3150iln"))))
+ (build-system python-build-system)
+ (native-inputs
+ (list python-pytest
+ qtbase-5))
+ (propagated-inputs
+ (list python-numexpr
+ python-numpy
+ python-pyqt
+ python-qtpy
+ python-tables))
+ ;; tests fail with qt.qpa.xcb: could not connect to display error
+ ;; (arguments
+ ;; `(#:tests? #f))
+ (home-page "https://vitables.org")
+ (synopsis "GUI for browsing PyTables and HDF5 files")
+ (description "ViTables is a GUI for browsing and editing files in both
+PyTables and HDF5 formats. ViTables capabilities include navigation through
+the data hierarchy, displaying of real data and its associated metadata, and
+browsing of multidimensional data. As a viewer, ViTables is able to display
+very large datasets.")
+ (license license:gpl3)))
--
2.36.0
?