[PATCH] gnu: Add r-zlog.

  • Done
  • quality assurance status badge
Details
2 participants
  • Navid Afkhami
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Navid Afkhami
Severity
normal

Debbugs page

Navid Afkhami wrote 3 years ago
(address . guix-patches@gnu.org)
20220429112732.14803-1-navid.afkhami@mdc-berlin.de
* gnu/packages/cran.scm (r-zlog): New variable.
---
gnu/packages/cran.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (37 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 1609682b8d..a828a9b4a7 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -6485,6 +6485,28 @@ right-hand side of an assignment into multiple values and assigns these values
to variables on the left-hand side of the assignment.")
(license license:expat)))
+(define-public r-zlog
+ (package
+ (name "r-zlog")
+ (version "1.0.0")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "zlog" version))
+ (sha256
+ (base32
+ "1d5j31p0h3rrn230087h3ngpvwknlisjv0f1qdbicdj9m177spci"))))
+ (properties `((upstream-name . "zlog")))
+ (build-system r-build-system)
+ (native-inputs (list r-knitr))
+ (home-page "https://cran.r-project.org/package=zlog")
+ (synopsis "Transformation for laboratory easurements")
+ (description
+ "The @code{zlog} package offers functions to transform laboratory
+measurements into standardised z or @math{z(log)-values}. Therefore the lower
+and upper reference limits are needed. If these are not known they could
+estimated from a given sample.")
+ (license license:gpl3+)))
+
(define-public r-vctrs
(package
(name "r-vctrs")

base-commit: 03f660027cb8abcdec0bd5acf466b3956cc2752c
--
2.25.1
Ricardo Wurmus wrote 3 years ago
(name . Navid Afkhami)(address . navid.afkhami@mdc-berlin.de)(address . 55185-done@debbugs.gnu.org)
87ee1f26w1.fsf@elephly.net
Hi Navid,

Toggle quote (2 lines)
> * gnu/packages/cran.scm (r-zlog): New variable.

looks good to me, thank you!

I applied it.

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 55185@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 55185
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help