[PATCH] gnu: Add python-arpeggio.

  • Done
  • quality assurance status badge
Details
3 participants
  • Ludovic Courtès
  • Paul A. Patience
  • Vincent Prat
Owner
unassigned
Submitted by
Vincent Prat
Severity
normal
V
V
Vincent Prat wrote on 29 Apr 2022 09:49
(address . guix-patches@gnu.org)
CAH9Ak7J1VNBfGgDwG1dtiSgSxZeWaUbSmL++F_Xd_LYsMyDkzg@mail.gmail.com

From 6dbafb4d9036cf76096b7860be6b2c91882efa3f Mon Sep 17 00:00:00 2001
From: Vincent Prat <vprat@deeplinks.com>
Date: Fri, 29 Apr 2022 09:43:35 +0200
Subject: [PATCH] gnu: Add python-arpeggio.

* gnu/packages/python-xyz.scm (python-arpeggio): New variable.
---
gnu/packages/python-xyz.scm | 29 +++++++++++++++++++++++++++++
1 file changed, 29 insertions(+)

Toggle diff (39 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index f8e599a453..af9244c3ea 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -29587,3 +29587,32 @@ and setting the color of terminal output, via HyDEV.")
versions of MkDocs-powered docs to a Git branch. It is suitable for deploying
to Github via gh-pages.")
(license license:bsd-3)))
+
+(define-public python-arpeggio
+ (package
+ (name "python-arpeggio")
+ (version "2.0.0")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "Arpeggio" version))
+ (sha256
+ (base32
+ "0ggdsck1wpladd5bh9drhkmm86bblgk2wagrhn3sdf4v04wkic6n"))))
+ (build-system python-build-system)
+ (native-inputs (list python-coverage
+ python-coveralls
+ python-flake8
+ python-mike
+ python-mkdocs
+ python-pytest
+ python-pytest-runner
+ python-twine
+ python-wheel))
+ (home-page "https://github.com/textX/Arpeggio")
+ (synopsis "Packrat parser interpreter for Python")
+ (description
+ "This Python library provides a recursive descent parser with backtracking
+and memoization (a.k.a. pacrat parser). Arpeggio grammars are based on PEG
+formalism. Arpeggio's main use is a foundation for a tool-chain for DSL
+development but it can be used for all sort of general purpose parsing.")
+ (license license:expat)))
--
2.30.2
P
P
Paul A. Patience wrote on 29 Apr 2022 10:28
(address . 55180@debbugs.gnu.org)
87czh0pa3j.fsf@apatience.com
Hello,

Some typos in the description:

- pacrat -> packrat
- tool-chain -> toolchain
- all sort of -> all sorts of

Cheers,
Paul
V
V
Vincent Prat wrote on 29 Apr 2022 11:10
[PATCH] gnu: Add python-arpeggio.
(address . 55180@debbugs.gnu.org)(address . paul@apatience.com)
CAH9Ak7KAsfAWik74XVRAsdTihw=ssWHe2_Uw9B8THB4=UfRfMQ@mail.gmail.com
Hello,

Thanks for pointing this out.
Here is a new patch that fixes the typos.

Cheers,
Vincent
From 5c5b630b91546482a9b40d27c42bd8ee2fedc2ee Mon Sep 17 00:00:00 2001
From: Vincent Prat <vprat@deeplinks.com>
Date: Fri, 29 Apr 2022 10:53:23 +0200
Subject: [PATCH 2/2] gnu: python-arpeggio: fixed typos in the description

---
gnu/packages/python-xyz.scm | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)

Toggle diff (17 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index af9244c3ea..d7a0e53424 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -29612,7 +29612,7 @@ to Github via gh-pages.")
(synopsis "Packrat parser interpreter for Python")
(description
"This Python library provides a recursive descent parser with backtracking
-and memoization (a.k.a. pacrat parser). Arpeggio grammars are based on PEG
-formalism. Arpeggio's main use is a foundation for a tool-chain for DSL
-development but it can be used for all sort of general purpose parsing.")
+and memoization (a.k.a. packrat parser). Arpeggio grammars are based on PEG
+formalism. Arpeggio's main use is a foundation for a toolchain for DSL
+development but it can be used for all sorts of general purpose parsing.")
(license license:expat)))
--
2.30.2
L
L
Ludovic Courtès wrote on 6 May 2022 10:29
(name . Vincent Prat)(address . vprat@deeplinks.com)(address . 55180-done@debbugs.gnu.org)
87sfpn3vzn.fsf@gnu.org
Hi,

Vincent Prat <vprat@deeplinks.com> skribis:

Toggle quote (7 lines)
> From 6dbafb4d9036cf76096b7860be6b2c91882efa3f Mon Sep 17 00:00:00 2001
> From: Vincent Prat <vprat@deeplinks.com>
> Date: Fri, 29 Apr 2022 09:43:35 +0200
> Subject: [PATCH] gnu: Add python-arpeggio.
>
> * gnu/packages/python-xyz.scm (python-arpeggio): New variable.

Applied together with the followup fixes, thanks!

Ludo’.
Closed
?