[PATCH] gnu: Add r-afpt.

  • Done
  • quality assurance status badge
Details
2 participants
  • Navid Afkhami
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Navid Afkhami
Severity
normal
N
N
Navid Afkhami wrote on 27 Apr 2022 16:40
(address . guix-patches@gnu.org)
20220427144001.43082-1-navid.afkhami@mdc-berlin.de
From: Navid <navid.afkhami@mdc-berlin.de>

* gnu/packages/cran.scm (r-afpt): New variable.
---
gnu/packages/cran.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (45 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index bc95eee065..e7d3fc19e0 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -35,6 +35,7 @@
;;; Copyright © 2020 Aniket Patil <aniket112.patil@gmail.com>
;;; Copyright © 2021 Marcel Schilling <marcel.schilling@uni-luebeck.de>
;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
+;;; Copyright © 2022 Navid Afkhami <navid.afkhami@mdc-berlin.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -112,6 +113,30 @@
#:use-module (gnu packages xml)
#:use-module (gnu packages xorg))
+(define-public r-afpt
+ (package
+ (name "r-afpt")
+ (version "1.1.0.1")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "afpt" version))
+ (sha256
+ (base32
+ "0cg5cdm9nl1hs6f3j0ljpw4bkqvh3ksyj615b9nnbqs5k28lyds9"))))
+ (properties `((upstream-name . "afpt")))
+ (build-system r-build-system)
+ (native-inputs (list r-knitr))
+ (home-page "https://github.com/MarcoKlH/afpt-r/")
+ (synopsis "Tools for modelling of animal flight performance")
+ (description
+ "This package allows estimation and modelling of flight costs in animal
+(vertebrate) flight, implementing the aerodynamic power model. Flight
+performance is estimated based on basic morphological measurements such as body
+mass, wingspan and wing area. @code{Afpt} can be used to make predictions on
+how animals should adjust their flight behaviour and wingbeat kinematics to
+varying flight conditions.")
+ (license license:gpl3+)))
+
(define-public r-aod
(package
(name "r-aod")
--
2.25.1
R
R
Ricardo Wurmus wrote on 29 Apr 2022 18:13
(name . Navid Afkhami)(address . navid.afkhami@mdc-berlin.de)(address . 55154-done@debbugs.gnu.org)
87ilqr274a.fsf@elephly.net
Hi Navid,

Toggle quote (4 lines)
> From: Navid <navid.afkhami@mdc-berlin.de>
>
> * gnu/packages/cran.scm (r-afpt): New variable.

Thank you, this is an excellent first contribution!

I applied it and pushed to the “master” branch with commit
325d53d5f634f6490e3291304fb5522400039224.

--
Ricardo
Closed
?