[PATCH] gnu: Add r-agilp.

  • Done
  • quality assurance status badge
Details
2 participants
  • M?d?lin Ionel Patra?cu
  • Ricardo Wurmus
Owner
unassigned
Submitted by
M?d?lin Ionel Patra?cu
Severity
normal
M
M
M?d?lin Ionel Patra?cu wrote on 27 Apr 2022 14:50
(address . guix-patches@gnu.org)
20220427125015.27456-1-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/bioconductor.scm (r-agilp): New variable.
---
gnu/packages/bioconductor.scm | 44 +++++++++++++++++++++++++++++++++++
1 file changed, 44 insertions(+)

Toggle diff (59 lines)
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 67ee6079c6..c0d874b423 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -1664,6 +1664,50 @@ (define-public r-adamgui
the @code{GFAGpathUi} function.")
(license license:gpl2+)))
+(define-public r-agilp
+ (package
+ (name "r-agilp")
+ (version "3.26.0")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "agilp" version))
+ (sha256
+ (base32
+ "02cyc2y4v3y16zlrnax2c96b2qfxj6b2j37ps4g2gdqgas08n9xp"))))
+ (properties `((upstream-name . "agilp")))
+ (build-system r-build-system)
+ (home-page "https://bioconductor.org/packages/agilp")
+ (synopsis "Processing of Agilent expression array")
+ (description
+ "This package @code{agilp} was developed to provide a pipeline for the
+low-level analysis of gene expression microarray data, primarily focused on the
+Agilent platform, but which also provides utilities which may be useful for
+other platforms. @code{Agilp} implements functions like:
+@itemize
+@item
+@code{AAProcess}: extracts raw expression data from Agilent expression array
+scanner files;
+@item
+@code{filenamex}: a file name listing utility;
+@item
+@code{Baseline}: constructs a file with the mean of each probe from a set of raw
+expression array data files
+@item
+@code{Loader}: selects a set of processed array files from directory according
+to criteria from a template file;
+@item
+@code{AALoess}: normalises a set of gene expression data files using @code{LOESS}
+against a reference data set;
+@item
+@code{IDswop}: maps expression data across different bioinformatic identifiers;
+@item
+@code{Equaliser}: trims a set of gene expression data files to include only the
+set of identifiers common to all files.
+@end itemize")
+ ;; Some files are under GPLv2+ but the combined work is released under the
+ ;; GPLv3.
+ (license license:gpl3)))
+
(define-public r-aneufinder
(package
(name "r-aneufinder")

base-commit: 4fb6ef6636acd7608889639c1b2e492517256f76
--
2.34.0
R
R
Ricardo Wurmus wrote on 27 Apr 2022 16:36
(name . M?d?lin Ionel Patra?cu)(address . madalinionel.patrascu@mdc-berlin.de)(address . 55148-done@debbugs.gnu.org)
8735hy4mn8.fsf@elephly.net
M?d?lin Ionel Patra?cu <madalinionel.patrascu@mdc-berlin.de> writes:

Toggle quote (2 lines)
> * gnu/packages/bioconductor.scm (r-agilp): New variable.

Thank you. I applied it after trimming the description, because all
that detail was probably a little much.

--
Ricardo
Closed
?