[PATCH] gnu: Add r-aggregatebiovar.

  • Done
  • quality assurance status badge
Details
2 participants
  • Mădălin Ionel Patrașcu
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Mădălin Ionel Patrașcu
Severity
normal

Debbugs page

Mădălin Ionel Patrașcu wrote 3 years ago
(address . guix-patches@gnu.org)
20220427114436.26482-1-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/bioconductor.scm (r-aggregatebiovar): New variable.
---
gnu/packages/bioconductor.scm | 34 ++++++++++++++++++++++++++++++++++
1 file changed, 34 insertions(+)

Toggle diff (49 lines)
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 67ee6079c6..8f76324330 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -1664,6 +1664,40 @@ (define-public r-adamgui
the @code{GFAGpathUi} function.")
(license license:gpl2+)))
+(define-public r-aggregatebiovar
+ (package
+ (name "r-aggregatebiovar")
+ (version "1.4.0")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "aggregateBioVar" version))
+ (sha256
+ (base32
+ "1wbfp1pf62di6pzxsf36lmzk6y9dllz1n4iv3mhpb1x8cvy4hqqk"))))
+ (properties `((upstream-name . "aggregateBioVar")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-matrix
+ r-rlang
+ r-s4vectors
+ r-singlecellexperiment
+ r-summarizedexperiment
+ r-tibble))
+ (native-inputs (list r-knitr))
+ (home-page "https://github.com/jasonratcliff/aggregateBioVar")
+ (synopsis
+ "Differential gene expression analysis for multi-subject scRNA-seq")
+ (description
+ "This package @code{aggregateBioVar} contains tools to summarize single
+cell gene expression profiles at the level of subject for single cell RNA-seq
+data collected from more than one subject (e.g. biological sample or technical
+replicates). A @code{SingleCellExperiment} object is taken as input and
+converted to a list of @code{SummarizedExperiment} objects, where each list
+element corresponds to an assigned cell type. The @code{SummarizedExperiment}
+objects contain aggregate gene-by-subject count matrices and inter-subject
+column metadata for individual subjects that can be processed using downstream
+bulk RNA-seq tools.")
+ (license license:gpl3)))
+
(define-public r-aneufinder
(package
(name "r-aneufinder")

base-commit: 4fb6ef6636acd7608889639c1b2e492517256f76
--
2.34.0
Ricardo Wurmus wrote 3 years ago
(name . Mădălin Ionel Patrașcu)(address . madalinionel.patrascu@mdc-berlin.de)(address . 55146-done@debbugs.gnu.org)
877d7a4mxm.fsf@elephly.net
Mădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de> writes:

Toggle quote (2 lines)
> * gnu/packages/bioconductor.scm (r-aggregatebiovar): New variable.

Applied with minor stylistic changes. Thanks!

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 55146@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 55146
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help