[PATCH] gnu: Add r-agdex.

  • Done
  • quality assurance status badge
Details
2 participants
  • Mădălin Ionel Patrașcu
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Mădălin Ionel Patrașcu
Severity
normal

Debbugs page

Mădălin Ionel Patrașcu wrote 3 years ago
(address . guix-patches@gnu.org)
20220427112014.25581-1-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/bioconductor.scm (r-agdex): New variable.
---
gnu/packages/bioconductor.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)

Toggle diff (42 lines)
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 67ee6079c6..1de7f83845 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -1664,6 +1664,33 @@ (define-public r-adamgui
the @code{GFAGpathUi} function.")
(license license:gpl2+)))
+(define-public r-agdex
+ (package
+ (name "r-agdex")
+ (version "1.42.0")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "AGDEX" version))
+ (sha256
+ (base32
+ "0y0q4zdybr5hlsi7qy2hf6c2sqr2z2211wz36dz70jkqyr0ggw64"))))
+ (properties `((upstream-name . "AGDEX")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-biobase r-gseabase))
+ (home-page "https://bioconductor.org/packages/AGDEX")
+ (synopsis
+ "Evaluate agreement of differential expression for cross-species genomics")
+ (description
+ "The objective of @code{AGDEX} is to evaluate whether the results of a pair
+of two-group differential expression analysis comparisons show a level of
+agreement that is greater than expected if the group labels for each two-group
+comparison are randomly assigned. The agreement is evaluated for the entire
+transcriptome and (optionally) for a collection of pre-defined gene-sets.
+Additionally, the procedure performs permutation-based differential expression
+and meta analysis at both gene and gene-set levels of the data from each
+experiment.")
+ (license license:gpl2+)))
+
(define-public r-aneufinder
(package
(name "r-aneufinder")

base-commit: 4fb6ef6636acd7608889639c1b2e492517256f76
--
2.34.0
Ricardo Wurmus wrote 3 years ago
(name . Mădălin Ionel Patrașcu)(address . madalinionel.patrascu@mdc-berlin.de)(address . 55145-done@debbugs.gnu.org)
87bkwm4n4z.fsf@elephly.net
Mădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de> writes:

Toggle quote (2 lines)
> * gnu/packages/bioconductor.scm (r-agdex): New variable.

Applied, thanks!

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 55145@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 55145
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help