keepassxc segfaults when merging databases

  • Done
  • quality assurance status badge
Details
4 participants
  • Thiago Jung Bauermann
  • Maxim Cournoyer
  • raingloom
  • Aurora
Owner
unassigned
Submitted by
raingloom
Severity
normal
R
R
raingloom wrote on 26 Apr 2022 17:25
(name . Guix Bugs)(address . bug-guix@gnu.org)
20220426172546.15675818@riseup.net
Sorry, can't really send the database files, obviously.

Here is the error message instead.

```
failed to register FdoSecrets::Item(0x5596b3d47a20) at
"/org/freedesktop/secrets/collection/passes/c417f89606a5463fa0746d0a5f5625ba"
"Failed to register item on DBus at path
'/org/freedesktop/secrets/collection/passes/c417f89606a5463fa0746d0a5f5625ba'"
QObject::connect(Group, Unknown): invalid nullptr parameter
QObject::connect(FdoSecrets::Item, FdoSecrets::Collection): invalid
nullptr parameter QObject::connect(FdoSecrets::Item,
FdoSecrets::Collection): invalid nullptr parameter [1] 1425
segmentation fault keepassxc
```
A
A
Aurora wrote on 28 Apr 2022 18:38
(name . raingloom)(address . raingloom@riseup.net)
87mtg54101.fsf@disp3269
raingloom <raingloom@riseup.net> writes:

Toggle quote (16 lines)
> Sorry, can't really send the database files, obviously.
>
> Here is the error message instead.
>
> ```
> failed to register FdoSecrets::Item(0x5596b3d47a20) at
> "/org/freedesktop/secrets/collection/passes/c417f89606a5463fa0746d0a5f5625ba"
> "Failed to register item on DBus at path
> '/org/freedesktop/secrets/collection/passes/c417f89606a5463fa0746d0a5f5625ba'"
> QObject::connect(Group, Unknown): invalid nullptr parameter
> QObject::connect(FdoSecrets::Item, FdoSecrets::Collection): invalid
> nullptr parameter QObject::connect(FdoSecrets::Item,
> FdoSecrets::Collection): invalid nullptr parameter [1] 1425
> segmentation fault keepassxc
> ```

It might be advisable to try a synthetic test using two new databases
with some dummy entries in them, to see if it's a general problem with
database merging or if there's something specifically about the
databases you're trying to merge that's not being accepted.
M
M
Maxim Cournoyer wrote on 8 Jun 2022 23:20
(name . Aurora)(address . rind38@disroot.org)
87wndqj1j1.fsf@gmail.com
Hello,

Aurora <rind38@disroot.org> writes:

Toggle quote (23 lines)
> raingloom <raingloom@riseup.net> writes:
>
>> Sorry, can't really send the database files, obviously.
>>
>> Here is the error message instead.
>>
>> ```
>> failed to register FdoSecrets::Item(0x5596b3d47a20) at
>> "/org/freedesktop/secrets/collection/passes/c417f89606a5463fa0746d0a5f5625ba"
>> "Failed to register item on DBus at path
>> '/org/freedesktop/secrets/collection/passes/c417f89606a5463fa0746d0a5f5625ba'"
>> QObject::connect(Group, Unknown): invalid nullptr parameter
>> QObject::connect(FdoSecrets::Item, FdoSecrets::Collection): invalid
>> nullptr parameter QObject::connect(FdoSecrets::Item,
>> FdoSecrets::Collection): invalid nullptr parameter [1] 1425
>> segmentation fault keepassxc
>> ```
>
> It might be advisable to try a synthetic test using two new databases
> with some dummy entries in them, to see if it's a general problem with
> database merging or if there's something specifically about the
> databases you're trying to merge that's not being accepted.

Keepassxc seems crashy; I tried creating a new database and it was
crashing randomly, without any error output.

Maxim
T
T
Thiago Jung Bauermann wrote on 9 Jun 2022 04:29
(name . Maxim Cournoyer)(address . maxim.cournoyer@gmail.com)
87h74u8t34.fsf@kolabnow.com
Hello,

Maxim Cournoyer <maxim.cournoyer@gmail.com> writes:

Toggle quote (30 lines)
> Hello,
>
> Aurora <rind38@disroot.org> writes:
>
>> raingloom <raingloom@riseup.net> writes:
>>
>>> Sorry, can't really send the database files, obviously.
>>>
>>> Here is the error message instead.
>>>
>>> ```
>>> failed to register FdoSecrets::Item(0x5596b3d47a20) at
>>> "/org/freedesktop/secrets/collection/passes/c417f89606a5463fa0746d0a5f5625ba"
>>> "Failed to register item on DBus at path
>>> '/org/freedesktop/secrets/collection/passes/c417f89606a5463fa0746d0a5f5625ba'"
>>> QObject::connect(Group, Unknown): invalid nullptr parameter
>>> QObject::connect(FdoSecrets::Item, FdoSecrets::Collection): invalid
>>> nullptr parameter QObject::connect(FdoSecrets::Item,
>>> FdoSecrets::Collection): invalid nullptr parameter [1] 1425
>>> segmentation fault keepassxc
>>> ```
>>
>> It might be advisable to try a synthetic test using two new databases
>> with some dummy entries in them, to see if it's a general problem with
>> database merging or if there's something specifically about the
>> databases you're trying to merge that's not being accepted.
>
> Keepassxc seems crashy; I tried creating a new database and it was
> crashing randomly, without any error output.

Strange, I use keepassxc regularly for a long time now and I've never
seen it crash. Though I don't do complex stuff such as merging
databases, just retrieval of users and passwords and creation of new
entries.

--
Thanks
Thiago
M
M
Maxim Cournoyer wrote on 9 Jun 2022 20:52
(name . Thiago Jung Bauermann)(address . bauermann@kolabnow.com)
87edzxis9m.fsf@gmail.com
Hello,

Thiago Jung Bauermann <bauermann@kolabnow.com> writes:

Toggle quote (39 lines)
> Hello,
>
> Maxim Cournoyer <maxim.cournoyer@gmail.com> writes:
>
>> Hello,
>>
>> Aurora <rind38@disroot.org> writes:
>>
>>> raingloom <raingloom@riseup.net> writes:
>>>
>>>> Sorry, can't really send the database files, obviously.
>>>>
>>>> Here is the error message instead.
>>>>
>>>> ```
>>>> failed to register FdoSecrets::Item(0x5596b3d47a20) at
>>>> "/org/freedesktop/secrets/collection/passes/c417f89606a5463fa0746d0a5f5625ba"
>>>> "Failed to register item on DBus at path
>>>> '/org/freedesktop/secrets/collection/passes/c417f89606a5463fa0746d0a5f5625ba'"
>>>> QObject::connect(Group, Unknown): invalid nullptr parameter
>>>> QObject::connect(FdoSecrets::Item, FdoSecrets::Collection): invalid
>>>> nullptr parameter QObject::connect(FdoSecrets::Item,
>>>> FdoSecrets::Collection): invalid nullptr parameter [1] 1425
>>>> segmentation fault keepassxc
>>>> ```
>>>
>>> It might be advisable to try a synthetic test using two new databases
>>> with some dummy entries in them, to see if it's a general problem with
>>> database merging or if there's something specifically about the
>>> databases you're trying to merge that's not being accepted.
>>
>> Keepassxc seems crashy; I tried creating a new database and it was
>> crashing randomly, without any error output.
>
> Strange, I use keepassxc regularly for a long time now and I've never
> seen it crash. Though I don't do complex stuff such as merging
> databases, just retrieval of users and passwords and creation of new
> entries.

I also use it everyday, but I simply open an existing (dated) database
and edit entries to it/use it. It seems to crash often when creating
new databases for me.

Maxim
A
A
Aurora wrote on 10 Jun 2022 05:42
(name . Maxim Cournoyer)(address . maxim.cournoyer@gmail.com)
8735gdyyj8.fsf@disp3269
Maxim Cournoyer <maxim.cournoyer@gmail.com> writes:
Toggle quote (11 lines)
>> Strange, I use keepassxc regularly for a long time now and I've never
>> seen it crash. Though I don't do complex stuff such as merging
>> databases, just retrieval of users and passwords and creation of new
>> entries.
>
> I also use it everyday, but I simply open an existing (dated) database
> and edit entries to it/use it. It seems to crash often when creating
> new databases for me.
>
> Maxim

I just tested Guix's Keepassxc v2.7.1 at Guix revision
01596f40a994a2bb39dde5867ca66e9f7e9e67e0 for merging newly created
databases (KDBX4) with and without conflicts in entries.

I experienced no crashes. Unless keepassxc or its dependencies changed
by the time I tested it, I think that something else might be
interacting.

- Aurora
R
R
raingloom wrote on 10 Jun 2022 15:11
(name . Aurora)(address . rind38@disroot.org)
20220610151120.63dbbee7@riseup.net
On Thu, 09 Jun 2022 23:42:35 -0400
Aurora <rind38@disroot.org> wrote:

Toggle quote (22 lines)
> Maxim Cournoyer <maxim.cournoyer@gmail.com> writes:
> >> Strange, I use keepassxc regularly for a long time now and I've
> >> never seen it crash. Though I don't do complex stuff such as
> >> merging databases, just retrieval of users and passwords and
> >> creation of new entries.
> >
> > I also use it everyday, but I simply open an existing (dated)
> > database and edit entries to it/use it. It seems to crash often
> > when creating new databases for me.
> >
> > Maxim
>
> I just tested Guix's Keepassxc v2.7.1 at Guix revision
> 01596f40a994a2bb39dde5867ca66e9f7e9e67e0 for merging newly created
> databases (KDBX4) with and without conflicts in entries.
>
> I experienced no crashes. Unless keepassxc or its dependencies changed
> by the time I tested it, I think that something else might be
> interacting.
>
> - Aurora

Might very well be an upstream bug, I'll try to build it with debug
symbols and see if I can reproduce it with the latest Guix commit.
M
M
Maxim Cournoyer wrote on 4 Oct 2023 05:14
(name . raingloom)(address . raingloom@riseup.net)
87bkdf3wpt.fsf@gmail.com
Hello,

raingloom <raingloom@riseup.net> writes:

Toggle quote (28 lines)
> On Thu, 09 Jun 2022 23:42:35 -0400
> Aurora <rind38@disroot.org> wrote:
>
>> Maxim Cournoyer <maxim.cournoyer@gmail.com> writes:
>> >> Strange, I use keepassxc regularly for a long time now and I've
>> >> never seen it crash. Though I don't do complex stuff such as
>> >> merging databases, just retrieval of users and passwords and
>> >> creation of new entries.
>> >
>> > I also use it everyday, but I simply open an existing (dated)
>> > database and edit entries to it/use it. It seems to crash often
>> > when creating new databases for me.
>> >
>> > Maxim
>>
>> I just tested Guix's Keepassxc v2.7.1 at Guix revision
>> 01596f40a994a2bb39dde5867ca66e9f7e9e67e0 for merging newly created
>> databases (KDBX4) with and without conflicts in entries.
>>
>> I experienced no crashes. Unless keepassxc or its dependencies changed
>> by the time I tested it, I think that something else might be
>> interacting.
>>
>> - Aurora
>
> Might very well be an upstream bug, I'll try to build it with debug
> symbols and see if I can reproduce it with the latest Guix commit.

Any update? Do newer versions work better for you?

--
Thanks,
Maxim
M
M
Maxim Cournoyer wrote on 4 Oct 2023 05:14
control message for bug #55136
(address . control@debbugs.gnu.org)
87a5sz3wpo.fsf@gmail.com
tags 55136 + moreinfo
quit
C
C
Csepp wrote on 8 Oct 2023 16:27
Re: bug#55136: keepassxc segfaults when merging databases
(name . Maxim Cournoyer)(address . maxim.cournoyer@gmail.com)
cuc5y3hur1n.fsf@riseup.net
Maxim Cournoyer <maxim.cournoyer@gmail.com> writes:

Toggle quote (35 lines)
> Hello,
>
> raingloom <raingloom@riseup.net> writes:
>
>> On Thu, 09 Jun 2022 23:42:35 -0400
>> Aurora <rind38@disroot.org> wrote:
>>
>>> Maxim Cournoyer <maxim.cournoyer@gmail.com> writes:
>>> >> Strange, I use keepassxc regularly for a long time now and I've
>>> >> never seen it crash. Though I don't do complex stuff such as
>>> >> merging databases, just retrieval of users and passwords and
>>> >> creation of new entries.
>>> >
>>> > I also use it everyday, but I simply open an existing (dated)
>>> > database and edit entries to it/use it. It seems to crash often
>>> > when creating new databases for me.
>>> >
>>> > Maxim
>>>
>>> I just tested Guix's Keepassxc v2.7.1 at Guix revision
>>> 01596f40a994a2bb39dde5867ca66e9f7e9e67e0 for merging newly created
>>> databases (KDBX4) with and without conflicts in entries.
>>>
>>> I experienced no crashes. Unless keepassxc or its dependencies
>>> changed
>>> by the time I tested it, I think that something else might be
>>> interacting.
>>>
>>> - Aurora
>>
>> Might very well be an upstream bug, I'll try to build it with debug
>> symbols and see if I can reproduce it with the latest Guix commit.
>
> Any update? Do newer versions work better for you?

Seems to work right now, I guess we can close it for now.
?