[PATCH] gnu: Add r-affixcan.

  • Done
  • quality assurance status badge
Details
2 participants
  • Mădălin Ionel Patrașcu
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Mădălin Ionel Patrașcu
Severity
normal

Debbugs page

Mădălin Ionel Patrașcu wrote 3 years ago
(address . guix-patches@gnu.org)
20220426152455.17387-1-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/bioconductor.scm (r-affixcan): New variable.
---
gnu/packages/bioconductor.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (40 lines)
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index fa862d736f..925ebcdbdc 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -1616,6 +1616,31 @@ (define-public r-adam
functionally associated genes} (GFAG).")
(license license:gpl2+)))
+(define-public r-affixcan
+ (package
+ (name "r-affixcan")
+ (version "1.12.0")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "AffiXcan" version))
+ (sha256
+ (base32
+ "06yn87briv2141jqad934gg5rcd90w5nghrgmbhqnmwafn72gj9d"))))
+ (properties `((upstream-name . "AffiXcan")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-biocparallel r-crayon r-multiassayexperiment
+ r-summarizedexperiment))
+ (native-inputs (list r-knitr))
+ (home-page "https://bioconductor.org/packages/AffiXcan")
+ (synopsis "Functional approach to impute genetically regulated expression")
+ (description
+ "The @code{AffiXcan} package imputes a @dfn{Genetically regulated
+expression} (GReX) for a set of genes in a sample of individuals, using a method
+based on the @dfn{total binding affinity} (TBA). Statistical models to impute
+GReX can be trained with a training dataset where the real total expression
+values are known.")
+ (license license:gpl3)))
+
(define-public r-aneufinder
(package
(name "r-aneufinder")

base-commit: 30ff557bd7255dddec16f4a032e58f5a88d5e448
--
2.34.0
Ricardo Wurmus wrote 3 years ago
(name . Mădălin Ionel Patrașcu)(address . madalinionel.patrascu@mdc-berlin.de)(address . 55128-done@debbugs.gnu.org)
87k0ba4nxa.fsf@elephly.net
Mădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de> writes:

Toggle quote (2 lines)
> * gnu/packages/bioconductor.scm (r-affixcan): New variable.

Applied with stylistic changes, thank you!

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 55128@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 55128
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help