[PATCH] gnu: Add r-adimpute and r-saver

  • Done
  • quality assurance status badge
Details
3 participants
  • MadalinIonel.Patrascu@mdc-berlin.de
  • M?d?lin Ionel Patra?cu
  • Ricardo Wurmus
Owner
unassigned
Submitted by
MadalinIonel.Patrascu@mdc-berlin.de
Severity
normal
M
M
MadalinIonel.Patrascu@mdc-berlin.de wrote on 26 Apr 2022 13:33
(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
7d2f41e893ea40a98618c962d4f02ca5@mdc-berlin.de

Attachment: file
M
M
M?d?lin Ionel Patra?cu wrote on 26 Apr 2022 13:36
[PATCH 2/2] gnu: Add r-adimpute.
(address . 55124@debbugs.gnu.org)
20220426113623.15268-2-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/bioconductor.scm (r-adimpute): New variable.
---
gnu/packages/bioconductor.scm | 48 +++++++++++++++++++++++++++++++++++
1 file changed, 48 insertions(+)

Toggle diff (61 lines)
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index fa862d736f..a861c2e576 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -1616,6 +1616,54 @@ (define-public r-adam
functionally associated genes} (GFAG).")
(license license:gpl2+)))
+(define-public r-adimpute
+ (package
+ (name "r-adimpute")
+ (version "1.4.0")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "ADImpute" version))
+ (sha256
+ (base32
+ "1bkq1hd8sqg9r28r70a9vd3gb2nsmg6dybf002d621p88cdfjib2"))))
+ (properties `((upstream-name . "ADImpute")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-biocparallel
+ r-checkmate
+ r-data-table
+ r-drimpute
+ r-kernlab
+ r-mass
+ r-matrix
+ r-rsvd
+ r-s4vectors
+ r-saver
+ r-singlecellexperiment
+ r-summarizedexperiment))
+ (native-inputs (list r-knitr))
+ (home-page "https://bioconductor.org/packages/ADImpute")
+ (synopsis "Adaptive computational prediction for dropout imputations")
+ (description
+ "@dfn{Single-cell RNA sequencing} (scRNA-seq) methods are typically unable
+to quantify the expression levels of all genes in a cell, creating a need for
+the computational prediction of missing values (dropout imputation). Most
+existing dropout imputation methods are limited in the sense that they
+exclusively use the scRNA-seq dataset at hand and do not exploit external
+gene-gene relationship information. The @code{ADImpute} package proposes two
+novel methods to address this issue:
+
+@enumerate
+@item a gene regulatory network-based approach using gene-gene relationships
+learnt from external data;
+@item a baseline approach corresponding to a sample-wide average.
+@end enumerate
+
+@code{ADImpute} implements these novel methods and also combines them with
+existing imputation methods like @code{DrImpute} and @code{SAVER}.
+@code{ADImpute} can learn the best performing method per gene and combine the
+results from different methods into an ensemble.")
+ (license license:gpl3+)))
+
(define-public r-aneufinder
(package
(name "r-aneufinder")
--
2.34.0
M
M
M?d?lin Ionel Patra?cu wrote on 26 Apr 2022 13:36
[PATCH 1/2] gnu: Add r-saver.
(address . 55124@debbugs.gnu.org)
20220426113623.15268-1-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/cran.scm (r-saver): New variable.
---
gnu/packages/cran.scm | 31 +++++++++++++++++++++++++++++++
1 file changed, 31 insertions(+)

Toggle diff (46 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 21cfca3102..ab93a94158 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -2333,6 +2333,37 @@ (define-public r-sass
language, which is stable, powerful, and CSS compatible.")
(license license:expat)))
+(define-public r-saver
+ (package
+ (name "r-saver")
+ (version "1.1.2")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "SAVER" version))
+ (sha256
+ (base32
+ "1s1kw8idkaj7j90fw4qn9k0wd4vz0sblsk06ry6lm4afcar0p158"))))
+ (properties `((upstream-name . "SAVER")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-doparallel r-foreach r-glmnet r-iterators
+ r-matrix))
+ (native-inputs (list r-knitr))
+ (home-page "https://github.com/mohuangx/SAVER")
+ (synopsis
+ "Recovery of the gene expression profile in noisy and sparse scRNA-seq data")
+ (description
+ "This package is an implementation of a regularized regression prediction
+and empirical Bayes method to recover the true gene expression profile in noisy
+and sparse single-cell RNA-seq data. In @dfn{single-cell RNA sequencing}
+(scRNA-seq) studies, only a small fraction of the transcripts present in each
+cell are sequenced. This leads to unreliable quantification of genes with low
+or moderate expression, which hinders downstream analysis. This package
+@dfn{single-cell analysis via expression recovery} (SAVER) implements an
+expression recovery method for unique molecule index (UMI)-based scRNA-seq data
+that borrows information across genes and cells to provide accurate expression
+estimates for all genes.")
+ (license license:gpl2)))
+
;; This package includes minified JavaScript files. When upgrading please
;; check that there are no new minified JavaScript files.
(define-public r-bslib

base-commit: 30ff557bd7255dddec16f4a032e58f5a88d5e448
--
2.34.0
R
R
Ricardo Wurmus wrote on 27 Apr 2022 15:51
[PATCH] gnu: Add r-adimpute and r-saver
(address . 55124-done@debbugs.gnu.org)
87sfpy4os6.fsf@elephly.net
Thanks for the patches. I applied them with minor stylistic changes.

--
Ricardo
Closed
?