[PATCH] gnu: Add cl-formgrep.

  • Done
  • quality assurance status badge
Details
2 participants
  • Guillaume Le Vaillant
  • Paul A. Patience
Owner
unassigned
Submitted by
Paul A. Patience
Severity
normal
P
P
Paul A. Patience wrote on 25 Apr 2022 00:36
(address . guix-patches@gnu.org)(name . Paul A. Patience)(address . paul@apatience.com)
20220424223639.23909-1-paul@apatience.com
* gnu/packages/lisp-xyz.scm (sbcl-formgrep, cl-formgrep,
ecl-formgrep): New variables.
---
gnu/packages/lisp-xyz.scm | 37 +++++++++++++++++++++++++++++++++++++
1 file changed, 37 insertions(+)

Toggle diff (45 lines)
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 9b89625202..4e8e0a4bfc 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -21198,3 +21198,40 @@ (define-public ecl-just-getopt-parser

(define-public cl-just-getopt-parser
(sbcl-package->cl-source-package sbcl-just-getopt-parser))
+
+(define-public sbcl-formgrep
+ (let ((commit "91238cdbdd0ad815ff5d574d032b4a502febd190")
+ (revision "0"))
+ (package
+ (name "sbcl-formgrep")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/death/formgrep")
+ (commit commit)))
+ (file-name (git-file-name "cl-formgrep" version))
+ (sha256
+ (base32 "1rqzkmz6nddg5ywvs3v0k8cvxdwas38mfwgbr3rs4fdsbps90k9r"))))
+ (build-system asdf-build-system/sbcl)
+ (inputs
+ (list sbcl-alexandria
+ sbcl-babel
+ sbcl-cl-fad
+ sbcl-cl-ppcre
+ sbcl-eclector))
+ (home-page "https://github.com/death/formgrep")
+ (synopsis "Find top-level Lisp forms matching an operator pattern")
+ (description
+ "This library provides the @code{FORMGREP} function and related
+utilities which find top-level Lisp forms matching the regular expression
+corresponding to an operator name, returning the matched forms and the names
+of the files and the line numbers where they were found.")
+ (license license:expat))))
+
+(define-public cl-formgrep
+ (sbcl-package->cl-source-package sbcl-formgrep))
+
+(define-public ecl-formgrep
+ (sbcl-package->ecl-package sbcl-formgrep))
--
2.35.1
G
G
Guillaume Le Vaillant wrote on 25 Apr 2022 10:13
(name . Paul A. Patience)(address . paul@apatience.com)(address . 55100-done@debbugs.gnu.org)
87wnfda8cj.fsf@kitej
Patch pushed as 5183ff2b9125ffa47c761f15cbda6a91080b6812.
Thanks.
-----BEGIN PGP SIGNATURE-----

iIUEAREKAC0WIQTLxZxm7Ce5cXlAaz5r6CCK3yH+PwUCYmZYPA8cZ2x2QHBvc3Rl
by5uZXQACgkQa+ggit8h/j8u4gD/UR211CCxSPx80gvf+VuogfR/CsKlEmrK87C/
7a+/sW8A/itGom9D+5b5TcK/zsZvEZ0uQP+jxG0ITSsK9Ck6CJr8
=lieP
-----END PGP SIGNATURE-----

Closed
?