[PATCH] gnu: Add grsync.

  • Done
  • quality assurance status badge
Details
2 participants
  • Mathieu Othacehe
  • tumashu
Owner
unassigned
Submitted by
tumashu
Severity
normal
T
T
tumashu wrote on 24 Apr 2022 03:54
(address . guix-patches@gnu.org)(name . Feng Shu)(address . tumashu@163.com)
20220424015405.6006-1-tumashu@163.com
From: Feng Shu <tumashu@163.com>

* gnu/packages/backup.scm (grsync): New variable.
---
gnu/packages/backup.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (41 lines)
diff --git a/gnu/packages/backup.scm b/gnu/packages/backup.scm
index 36bb2ae8e2..51d6de6b43 100644
--- a/gnu/packages/backup.scm
+++ b/gnu/packages/backup.scm
@@ -71,6 +71,7 @@ (define-module (gnu packages backup)
#:use-module (gnu packages gnupg)
#:use-module (gnu packages golang)
#:use-module (gnu packages gperf)
+ #:use-module (gnu packages gtk)
#:use-module (gnu packages guile)
#:use-module (gnu packages guile-xyz)
#:use-module (gnu packages linux)
@@ -1340,3 +1341,26 @@ (define-public vorta
scheduled backups, and has a graphical tool for browsing and extracting the Borg
archives.")
(license license:gpl3+)))
+
+(define-public grsync
+ (package
+ (name "grsync")
+ (version "1.3.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://www.opbyte.it/release/"
+ "grsync-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1z1m782b50x348kgynzf753apy8yszkl31y32y1jsc055skcdixp"))))
+ (build-system gnu-build-system)
+ (native-inputs (list intltool pkg-config))
+ (inputs (list gtk+))
+ (propagated-inputs (list rsync))
+ (home-page "http://www.opbyte.it/grsync/")
+ (synopsis "GTK frontend for rsync")
+ (description
+ "Grsync is a simple graphical interface using GTK for the rsync command line
+program. It currently supports only a limited set of the most important rsync
+features, but can be used effectively for local directory synchronization.")
+ (license license:gpl2)))
--
2.35.1
M
M
Mathieu Othacehe wrote on 26 Apr 2022 09:29
(address . tumashu@163.com)(address . 55087-done@debbugs.gnu.org)
87tuagwbep.fsf@gnu.org
Toggle quote (2 lines)
> * gnu/packages/backup.scm (grsync): New variable.

I added your copyright, wrapped the description and pushed,

Thanks,

Mathieu
Closed
?