[PATCH] gnu: Add python-flake8-bandit and upgrade python-bandit

  • Done
  • quality assurance status badge
Details
2 participants
  • Allan Adair
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Allan Adair
Severity
normal

Debbugs page

Allan Adair wrote 3 years ago
(address . guix-patches@gnu.org)
ab2d6404b6a74677a92af80968cd8342658ffd53.camel@adair.no
* gnu/packages/python-xyz.scm (python-flake8-bandit): New variable.
* gnu/packages/openstack.scm (python-bandit): Upgrade to 1.7.4.
Toggle diff (69 lines)
diff --git a/gnu/packages/openstack.scm b/gnu/packages/openstack.scm
index 4c28bb9283..67c8b2b5b7 100644
--- a/gnu/packages/openstack.scm
+++ b/gnu/packages/openstack.scm
@@ -7,6 +7,7 @@
;;; Copyright © 2020, 2021 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2020 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2022 Tanguy Le Carrour <tanguy@bioneland.org>
+;;; Copyright © 2022 Allan Adair <allan@adair.no>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -49,14 +50,14 @@ (define-module (gnu packages openstack)
(define-public python-bandit
(package
(name "python-bandit")
- (version "1.6.2")
+ (version "1.7.4")
(source
(origin
(method url-fetch)
(uri (pypi-uri "bandit" version))
(sha256
(base32
- "0rb034c99pyhb4a60z7f2kz40cjydhm8m9v2blaal1rmhlam7rs1"))))
+ "1lkvf5ffdqa9504mm5fd9vvq0q5wdyqbkm32i4rswys1fg2shqrd"))))
(build-system python-build-system)
(arguments
;; The tests are disabled to avoid a circular dependency with
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 9a5d311680..b45e8bc959 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -119,6 +119,7 @@
;;; Copyright © 2022 Evgeny Pisemsky <evgeny@pisemsky.com>
;;; Copyright © 2022 drozdov <drozdov@portalenergy.tech>
;;; Copyright © 2022 Peter Polidoro <peter@polidoro.io>
+;;; Copyright © 2022 Allan Adair <allan@adair.no>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -10604,6 +10605,27 @@ (define-public python-flake8-3.8
(list python-pycodestyle-2.6 python-entrypoints python-pyflakes-2.2
python-mccabe))))
+(define-public python-flake8-bandit
+ (package
+ (name "python-flake8-bandit")
+ (version "3.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "flake8_bandit" version))
+ (sha256
+ (base32 "18fnw8c0w3ij0fc4bwvmd62jvhm7q10ihbmhlwi07md8wqkr9lal"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ (list python-bandit
+ python-flake8
+ python-flake8-polyfill
+ python-pycodestyle))
+ (home-page "https://github.com/tylerwince/flake8-bandit")
+ (synopsis "Automated security testing with bandit and flake8.")
+ (description "Automated security testing with bandit and flake8.")
+ (license license:expat)))
+
(define-public python-flake8-bugbear
(package
(name "python-flake8-bugbear")
Sharlatan Hellseher wrote 5 days ago
(address . 55063-done@debbugs.gnu.org)
87tt7wps2j.fsf@gmail.com
Hi,

python-bandit is on 1.7.4.

Toggle snippet (8 lines)
guix describe
Generation 84 Mar 12 2025 18:53:26 (current)
guix ac19daa
repository URL: https://git.savannah.gnu.org/git/guix.git
branch: master
commit: ac19daa9d44766694cea33bcd28d4e20cf192835

Closing as not applied.

--
Oleg
-----BEGIN PGP SIGNATURE-----

iQJKBAEBCgA0FiEEmEeB3micIcJkGAhndtcnv/Ys0rUFAmfTRqQWHHNoYXJsYXRh
bnVzQGdtYWlsLmNvbQAKCRB21ye/9izStam4D/91+Q2UItS/UVBq9m4xQUTuzZjU
dGDlwbZ8qpLwH9Jp1s00FCtOC6zmusxmdm4hBBFqpvS+9vz48uarI7VtI2GdLwYD
isSgtOqN8/P7bkCTun0EYEu6gPXiuq0LBNYMtne0wiS+AGEL2ma8AfjXWW8jkDNa
kk1aG+tEcPNHOinI7JLxBXZToeRpoOy/zxfOJSCom8/QEEc12Ivh3nLn35eObGMf
ihRMJw0wu93dYmrbWbNVEfSSI9Co5DLhk6eE1SK5r/QA1ndiL1j9lwdCTd3x4RTk
MC9mQJNciwV25cURTQktvrcv5If9WqLqmGa3C5iqYwpVCF1RkfcEk9Qap42GOGJr
gmZkRvGp7wfN9Gb9myrsBOffI3ey5YWrHrorpRrXW+OSmcUBmrkbnPHnub/zUisV
YRTjg7GYHIEa+GmpORogcijlHh5I6aL5navjTr/jmNNE15rlEUH+NM0hFCpfrlvs
yk+VzwoAYe/qv+GdYkXEGR5et65xYkyqOwfcTxNjSu0/FqeXF3ZKrFDxmPaJnsOl
nLADaDX0mOzflLR/haRicchrHDBzcY3V3GEnoLlgYQQEJIr2/xKF6N2YByTm4goI
cXKH3qXO5buE4sd5KtBzf8CmCC/4vkqF30q5LCJpnOHiXP8lSSwbtW9NZkkO4utG
7T4vcHKrrEXfGjB1/w==
=Hw80
-----END PGP SIGNATURE-----

Closed
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 55063@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 55063
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help