[PATCH] gnu: Add wtime.

  • Done
  • quality assurance status badge
Details
2 participants
  • Foo Chuan Wei
  • Mathieu Othacehe
Owner
unassigned
Submitted by
Foo Chuan Wei
Severity
normal
F
F
Foo Chuan Wei wrote on 19 Apr 2022 09:26
(address . guix-patches@gnu.org)
PU1PR01MB215577BF8244F7995FB2878E8DF29@PU1PR01MB2155.apcprd01.prod.exchangelabs.com
* gnu/packages/task-management.scm (wtime): New variable.
---
gnu/packages/task-management.scm | 36 ++++++++++++++++++++++++++++++++
1 file changed, 36 insertions(+)

Toggle diff (58 lines)
diff --git a/gnu/packages/task-management.scm b/gnu/packages/task-management.scm
index c349081f01..17fb8c335e 100644
--- a/gnu/packages/task-management.scm
+++ b/gnu/packages/task-management.scm
@@ -4,6 +4,7 @@
;;; Copyright © 2021 Eric Bavier <bavier@posteo.net>
;;; Copyright © 2021 Stefan Reichör <stefan@xsteve.at>
;;; Copyright © 2021 LibreMiami <packaging-guix@libremiami.org>
+;;; Copyright © 2022 Foo Chuan Wei <chuanwei.foo@hotmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -242,6 +243,41 @@ to with the goal of improving your focus and enhancing your productivity.
You can also use it to fall asleep in a noisy environment.")
(license license:gpl3+)))
+(define-public wtime
+ (package
+ (name "wtime")
+ (version "0.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/wtime/wtime/"
+ version "/wtime_"
+ (string-replace-substring version "." "_")
+ ".tar.gz"))
+ (sha256
+ (base32 "1rp1sxas9wjc84fvr6x94ryl3r9w7jd0x5j1hbi9q7yrgfclp830"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:make-flags
+ (list (string-append "CC=" ,(cc-for-target))
+ (string-append "PREFIX=" %output))
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (add-after 'unpack 'fix-man-path
+ (lambda _
+ (substitute* "Makefile"
+ (("/man1") "/share/man/man1")))))
+ #:tests? #f)) ; No "check" target.
+ (home-page "http://wtime.sourceforge.net")
+ (synopsis
+ "Command-line utility for tracking time spent working on arbitrary tasks")
+ (description
+ "@code{wtime} is a command-line utility for tracking time spent working on
+arbitrary tasks. All the time data is saved in files residing in the
+@code{.wtimed} directory in the user's home directory.")
+ (license license:x11)))
+
(define-public todoman
(package
(name "todoman")

base-commit: 6b677f4299f38ea70e1852388086ee95c2c48622
--
2.25.1
M
M
Mathieu Othacehe wrote on 27 Apr 2022 11:19
(address . 55018-done@debbugs.gnu.org)(address . chuanwei.foo@hotmail.com)
878rrqlw7d.fsf@gnu.org
Hello,

Toggle quote (2 lines)
> * gnu/packages/task-management.scm (wtime): New variable.

Pushed with the following modifications:

Toggle snippet (46 lines)
diff --git a/gnu/packages/task-management.scm b/gnu/packages/task-management.scm
index 17fb8c335e..65b3dc8699 100644
--- a/gnu/packages/task-management.scm
+++ b/gnu/packages/task-management.scm
@@ -23,6 +23,7 @@
(define-module (gnu packages task-management)
#:use-module ((guix licenses) #:prefix license:)
+ #:use-module (guix gexp)
#:use-module (guix packages)
#:use-module (gnu packages check)
#:use-module (gnu packages freedesktop)
@@ -43,6 +44,7 @@ (define-module (gnu packages task-management)
#:use-module (guix hg-download)
#:use-module (guix utils)
#:use-module (guix build-system cmake)
+ #:use-module (guix build-system gnu)
#:use-module (guix build-system go)
#:use-module (guix build-system meson)
#:use-module (guix build-system python))
@@ -259,8 +261,8 @@ (define-public wtime
(build-system gnu-build-system)
(arguments
`(#:make-flags
- (list (string-append "CC=" ,(cc-for-target))
- (string-append "PREFIX=" %output))
+ ,#~(list (string-append "CC=" #$(cc-for-target))
+ (string-append "PREFIX=" #$output))
#:phases
(modify-phases %standard-phases
(delete 'configure)
@@ -271,10 +273,10 @@ (define-public wtime
#:tests? #f)) ; No "check" target.
(home-page "http://wtime.sourceforge.net")
(synopsis
- "Command-line utility for tracking time spent working on arbitrary tasks")
+ "Command-line utility for tracking time spent on arbitrary tasks")
(description
- "@code{wtime} is a command-line utility for tracking time spent working on
-arbitrary tasks. All the time data is saved in files residing in the
+ "@code{wtime} is a command-line utility for tracking time spent working
+on arbitrary tasks. All the time data is saved in files residing in the
@code{.wtimed} directory in the user's home directory.")
(license license:x11)))

Thanks,

Mathieu
Closed
?