[PATCH] gnu: Add cl-just-getopt-parser

  • Done
  • quality assurance status badge
Details
2 participants
  • Guillaume Le Vaillant
  • Thomas Albers
Owner
unassigned
Submitted by
Thomas Albers
Severity
normal
T
T
Thomas Albers wrote on 18 Apr 2022 22:28
(address . guix-patches@gnu.org)(name . Thomas Albers)(address . thomas@thomaslabs.org)
20220418202818.26514-1-thomas@thomaslabs.org
* gnu/packages/lisp-xyz.scm (sbcl-just-getopt-parser,
ecl-just-getopt-parser, cl-just-getopt-parser): New variables
---
gnu/packages/lisp-xyz.scm | 30 ++++++++++++++++++++++++++++++
1 file changed, 30 insertions(+)

Toggle diff (45 lines)
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 9317108f4c..b8f3cdb307 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -33,6 +33,7 @@
;;; Copyright © 2021 Jacob MacDonald <jaccarmac@gmail.com>
;;; Copyright © 2022 Jai Vetrivelan <jaivetrivelan@gmail.com>
;;; Copyright © 2022 Paul A. Patience <paul@apatience.com>
+;;; Copyright © 2022 Thomas Albers Raviola <thomas@thomaslabs.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -21009,3 +21010,32 @@ (define-public ecl-purgatory

(define-public cl-purgatory
(sbcl-package->cl-source-package sbcl-purgatory))
+
+(define-public sbcl-just-getopt-parser
+ (package
+ (name "sbcl-just-getopt-parser")
+ (version "2021.11")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/tlikonen/cl-just-getopt-parser")
+ (commit version)))
+ (sha256
+ (base32 "0ngh8b51ngh3bqacl40j6wwiinhwxswsy02d9k7qlzv9sbjxay4s"))
+ (file-name (git-file-name name version))))
+ (build-system asdf-build-system/sbcl)
+ (synopsis "Getopt-like command-line parser for Common Lisp")
+ (description
+ "This package provides the @code{getopt} function to parse command-line
+options. The options are organized in valid options, other arguments and
+unknown arguments. Optional Lisp conditions for error situations are also
+defined.")
+ (home-page "https://github.com/tlikonen/cl-just-getopt-parser")
+ (license license:cc0)))
+
+(define-public ecl-just-getopt-parser
+ (sbcl-package->ecl-package sbcl-just-getopt-parser))
+
+(define-public cl-just-getopt-parser
+ (sbcl-package->cl-source-package sbcl-just-getopt-parser))
--
2.35.1
G
G
Guillaume Le Vaillant wrote on 20 Apr 2022 13:34
(name . Thomas Albers)(address . thomas@thomaslabs.org)(address . 55008-done@debbugs.gnu.org)
87zgkgc7j0.fsf@kitej
Patch pushed as 101edbe63a887678722bc26cd85a7b7f5637428f.
Thanks.
-----BEGIN PGP SIGNATURE-----

iIUEAREKAC0WIQTLxZxm7Ce5cXlAaz5r6CCK3yH+PwUCYl/v4w8cZ2x2QHBvc3Rl
by5uZXQACgkQa+ggit8h/j+NyQD+PmMSGO7HMiTfT0hxtY83+0AgElRen7y6L4lL
WUwY2xoA/Rz0je+Sq8ynXOAUEvrQ/3gorWrgqnb5w4pZNCQb7tNr
=BBPw
-----END PGP SIGNATURE-----

Closed
?