[PATCH] gnu: Fix incorrect path in home-fish-service

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Maya
Owner
unassigned
Submitted by
Maya
Severity
normal

Debbugs page

Maya wrote 3 years ago
(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
uL5oOeLOQqmJ7TQKaXv-010rwqPGjhP8RBA46FojbsocqLBezWis3XGe5_hmxg6RcTUN2kW9q7SwahPL1fH6d6rOYsgsetkUwpg96nuwymE=@protonmail.com
I haven't found any info on this and I wasn't sure if I should open a bug report. I believe this is a bug in the home-fish-service, as guix home copies the configuration file to "~/config/fish/config.fish" but the path where fish looks for is "~/.config/fish/config.fish"

Other than that it functions correctly, it must've been a mistake as one rarely changes this file and once in the right place, it works perfectly. Without it though, the guix home is non-functional.

Regards,
Maya
---
gnu/home/services/shells.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (13 lines)
diff --git a/gnu/home/services/shells.scm b/gnu/home/services/shells.scm
index d96c951cd8..fd0a8397f6 100644
--- a/gnu/home/services/shells.scm
+++ b/gnu/home/services/shells.scm
@@ -586,7 +586,7 @@ (define-configuration home-fish-configuration
serialize-fish-abbreviations))

(define (fish-files-service config)
- `(("config/fish/config.fish"
+ `((".config/fish/config.fish"
,(mixed-text-file
"fish-config.fish"
#~(string-append "\
--
2.35.1
Ludovic Courtès wrote 3 years ago
(name . Maya)(address . maya.omase@protonmail.com)(address . 55000-done@debbugs.gnu.org)
874k2cc1j7.fsf@gnu.org
Hi,

Maya <maya.omase@protonmail.com> skribis:

Toggle quote (4 lines)
> I haven't found any info on this and I wasn't sure if I should open a bug report. I believe this is a bug in the home-fish-service, as guix home copies the configuration file to "~/config/fish/config.fish" but the path where fish looks for is "~/.config/fish/config.fish"
>
> Other than that it functions correctly, it must've been a mistake as one rarely changes this file and once in the right place, it works perfectly. Without it though, the guix home is non-functional.

Indeed. This is because ‘home-files-service-type’ no longer prepends
“.” to file names.

Applied now, thanks!

Ludo’.

PS: And congrats on getting bug #55000. :-)
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 55000@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 55000
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help