[PATCH] gnu: Add servefile.

  • Open
  • quality assurance status badge
Details
4 participants
  • Ludovic Courtès
  • Maxime Devos
  • Stefan Reichör
  • Steve George
Owner
unassigned
Submitted by
Stefan Reichör
Severity
normal
S
S
Stefan Reichör wrote on 17 Apr 2022 23:29
(address . guix-patches@gnu.org)(name . Stefan Reichör)(address . stefan@xsteve.at)
20220417212954.93893-1-stefan@xsteve.at
* gnu/packages/web.scm (servefile): New variable.
---
gnu/packages/web.scm | 23 ++++++++++++++++++++++-
1 file changed, 22 insertions(+), 1 deletion(-)

Toggle diff (43 lines)
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index ee74a4385d..9df55d21cc 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -47,7 +47,7 @@
;;; Copyright © 2020, 2021 Ryan Prior <rprior@protonmail.com>
;;; Copyright © 2020 Alexandru-Sergiu Marton <brown121407@posteo.ro>
;;; Copyright © 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
-;;; Copyright © 2021 Stefan Reichör <stefan@xsteve.at>
+;;; Copyright © 2021, 2022 Stefan Reichör <stefan@xsteve.at>
;;; Copyright © 2021 la snesne <lasnesne@lagunposprasihopre.org>
;;; Copyright © 2021 Matthew James Kraai <kraai@ftbfs.org>
;;; Copyright © 2021 Sarah Morgensen <iskarian@mgsn.dev>
@@ -5000,6 +5000,27 @@ can easily be invoked on a single file. Your partner can access the file with
tools they trust (e.g. wget).")
(license license:gpl2+)))
+(define-public servefile
+ (package
+ (name "servefile")
+ (version "0.5.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "servefile" version))
+ (sha256
+ (base32
+ "1ywi9yzc2l24nxfb2mvmkha7qfaapjvqchd6rhjbc54ijwrdq9m1"))))
+ (build-system python-build-system)
+ (inputs (list python-pyopenssl))
+ (arguments
+ '(#:tests? #f)) ; tests fail
+ (home-page "https://github.com/sebageek/servefile")
+ (synopsis "Serve or receive files from shell via a small HTTP server")
+ (description "Serve files from shell via a small HTTP server. It
+also supports uploads, SSL, HTTP basic auth and directory listings.")
+ (license license:gpl3+)))
+
(define netsurf-buildsystem
(package
(name "netsurf-buildsystem")
--
2.25.1
M
M
Maxime Devos wrote on 18 Apr 2022 13:48
210ce6a91bed39233e59a6977ef1165dceced81e.camel@telenet.be
Stefan Reichör schreef op zo 17-04-2022 om 23:29 [+0200]:
Toggle quote (3 lines)
> +    (arguments
> +     '(#:tests? #f)) ; tests fail

Which tests?

Greetings,
Maxime.
-----BEGIN PGP SIGNATURE-----

iI0EABYKADUWIQTB8z7iDFKP233XAR9J4+4iGRcl7gUCYl1QDhccbWF4aW1lZGV2
b3NAdGVsZW5ldC5iZQAKCRBJ4+4iGRcl7ollAP4uUyisJrgIqPAQXdKuVqXaAkQY
UP1c8Et844H1ZWaCTwD8Da3Nuym3n9KIK77pa0gfM0xu/AizPhy4HPvK7KvZMwY=
=Vvoc
-----END PGP SIGNATURE-----


M
M
Maxime Devos wrote on 18 Apr 2022 13:54
5d764a46e4fd720b40f0a2ed27e39436f7e4a08c.camel@telenet.be
Stefan Reichör schreef op zo 17-04-2022 om 23:29 [+0200]:
Toggle quote (2 lines)
> +    (inputs (list python-pyopenssl))

-----BEGIN PGP SIGNATURE-----

iI0EABYKADUWIQTB8z7iDFKP233XAR9J4+4iGRcl7gUCYl1RYxccbWF4aW1lZGV2
b3NAdGVsZW5ldC5iZQAKCRBJ4+4iGRcl7uzHAP43BlUdFx5VAdjBK/XSN7fWhk56
xf4PIaraKfOzkQqpmwEAhWnDThEmbemf5Jtv3qnckMajT/+5XAiZ5MjndA9mSAE=
=58Ot
-----END PGP SIGNATURE-----


M
M
Maxime Devos wrote on 18 Apr 2022 13:55
77a6ee6b93dfa6f7df5ea226d7e490fd725f2aae.camel@telenet.be
Stefan Reichör schreef op zo 17-04-2022 om 23:29 [+0200]:
Toggle quote (3 lines)
> +    (description "Serve files from shell via a small HTTP server. It
> +also supports uploads, SSL, HTTP basic auth and directory listings.")

Nowadays it's called TLS; not SSL (SSL is the old version)
-----BEGIN PGP SIGNATURE-----

iI0EABYKADUWIQTB8z7iDFKP233XAR9J4+4iGRcl7gUCYl1RtRccbWF4aW1lZGV2
b3NAdGVsZW5ldC5iZQAKCRBJ4+4iGRcl7veTAPoC8akfRooNkO4W/QYGsyoaCfqf
2xpJ3e/QuQFl3bEwUgD/S/6Qdg1piDyj52mpwv/CLh93KqCS22LTkZlE+OtLxA8=
=bXEj
-----END PGP SIGNATURE-----


M
M
Maxime Devos wrote on 18 Apr 2022 13:57
654d5e1972e09c1cd362635d4f9acc8b559ddd3e.camel@telenet.be
Stefan Reichör schreef op zo 17-04-2022 om 23:29 [+0200]:
Toggle quote (8 lines)
> +    (source
> +     (origin
> +       (method url-fetch)
> +       (uri (pypi-uri "servefile" version))
> +       (sha256
> +        (base32
> +         "1ywi9yzc2l24nxfb2mvmkha7qfaapjvqchd6rhjbc54ijwrdq9m1"))))

It uses TLSv1_2_METHOD which apparently is deprecated
for TLS 1.3 support something else needs to be done here.

Given the potential security impact, I think it's important here to do
the non-deprecated thing.

Greetings,
Maxime
-----BEGIN PGP SIGNATURE-----

iI0EABYKADUWIQTB8z7iDFKP233XAR9J4+4iGRcl7gUCYl1SGhccbWF4aW1lZGV2
b3NAdGVsZW5ldC5iZQAKCRBJ4+4iGRcl7m8lAP93M8Os3kZvII/b3Va5/0h+pyYH
6DOx2+5L9SwiPuqVQQD+OypUq37YkkcC1VHTvzNmvjmEORvdRBaYJdxKeBAbjAI=
=h5R8
-----END PGP SIGNATURE-----


M
M
Maxime Devos wrote on 18 Apr 2022 13:58
fdf1f6d05d1125c8064c708aa86d227d9324eb0f.camel@telenet.be
Stefan Reichör schreef op zo 17-04-2022 om 23:29 [+0200]:
Toggle quote (7 lines)
> +     (origin
> +       (method url-fetch)
> +       (uri (pypi-uri "servefile" version))
> +       (sha256
> +        (base32
> +        

At
and following lines, things like 'ip', 'sed', 'grep' and 'ifconfig' are
run and may need to be absolutised with an appropriate 'substitute*'.

G
-----BEGIN PGP SIGNATURE-----

iI0EABYKADUWIQTB8z7iDFKP233XAR9J4+4iGRcl7gUCYl1SdRccbWF4aW1lZGV2
b3NAdGVsZW5ldC5iZQAKCRBJ4+4iGRcl7glfAQC4HR8npucJQNph/XuRE1KGTQTI
qLCRNz8DS+GfzmO7VgD9E3P84mNhL1ciEiS8vDAQcP+/wvKx5pi0Zs0iqcRz/Qg=
=hKa1
-----END PGP SIGNATURE-----


L
L
Ludovic Courtès wrote on 8 May 2022 23:53
control message for bug #54998
(address . control@debbugs.gnu.org)
87h75zvggj.fsf@gnu.org
tags 54998 + moreinfo
quit
S
S
Steve George wrote on 1 Apr 11:03 +0200
RE: Adding servefile to Guix
(address . 54998@debbugs.gnu.org)
Zgp4csaHzEc-woIZ@t25sg
Hi Stefan,

Are you still interested in adding Servefile to Guix?

Looks like the upstream has released a new version, and you can add bugs to the upstream tracker for the issues that Maxime advised. If you could update and reroll your patch hopefully we can get it reviewed!

Thanks,

Futurile / Steve
?