[PATCH] gnu: Add cl-ipfs-api2.

  • Done
  • quality assurance status badge
Details
3 participants
  • Guillaume Le Vaillant
  • jgart
  • Maxime Devos
Owner
unassigned
Submitted by
jgart
Severity
normal
J
(address . guix-patches@gnu.org)(name . jgart)(address . jgart@dismail.de)
20220417184748.14902-1-jgart@dismail.de
* gnu/packages/lisp-xyz.scm (cl-ipfs-api2): New variable.
---
gnu/packages/lisp-xyz.scm | 38 ++++++++++++++++++++++++++++++++++++++
1 file changed, 38 insertions(+)

Toggle diff (51 lines)
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 82270b3e32..5a6a344d4c 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -20940,6 +20940,44 @@ (define-public cl-simple-routes
(define-public ecl-simple-routes
(sbcl-package->ecl-package sbcl-simple-routes))
+(define-public sbcl-cl-ipfs-api2
+ (let ((commit "3ee52c80023bcc662f7d01276ea0a5814bd0011b")
+ (revision "0"))
+ (package
+ (name "sbcl-cl-ipfs-api2")
+ (version (git-version "0.51" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/JadedCtrl/cl-ipfs-api2")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1h0csxk4db1hid793mk5kz3nbjyl7z4ic1zk2wy46k1vz5lnnsph"))))
+ (build-system asdf-build-system/sbcl)
+ (arguments
+ '(#:tests? #f ; There are no tests.
+ #:asd-files '("cl-ipfs-api2.asd")
+ #:asd-systems '("cl-ipfs-api2")))
+ (inputs
+ (list sbcl-drakma
+ sbcl-yason
+ sbcl-arnesi))
+ (home-page "https://github.com/JadedCtrl/cl-ipfs-api2/")
+ (synopsis "Bindings for the IPFS HTTP API")
+ (description
+"@code{cl-sbcl-cl-ipfs-api2} is a pretty simple set of IPFS bindings for
+Common Lisp, using the HTTP API for (almost) everything, except for pubsub
+(which uses the locally installed go-ipfs program).")
+ (license license:lgpl3+))))
+
+(define-public cl-ipfs-api2
+ (sbcl-package->cl-source-package sbcl-cl-ipfs-api2))
+
+(define-public ecl-cl-ipfs-api2
+ (sbcl-package->ecl-package sbcl-cl-ipfs-api2))
+
(define-public sbcl-purgatory
(let ((commit "ade0d60a14a1067b9cc8cf06d1f1a1ca8cecdb03")
(revision "1"))
--
2.35.1
G
G
Guillaume Le Vaillant wrote on 18 Apr 2022 09:27
(name . jgart)(address . jgart@dismail.de)(address . 54995-done@debbugs.gnu.org)
8735ia3l47.fsf@kitej
Patch pushed as b629b302696605201b270439bf8e4f958547a88f with a few
modifications (the 'asd-files' and 'asd-systems' parameters were not
necessary in this case).
Thanks.
-----BEGIN PGP SIGNATURE-----

iIUEAREKAC0WIQTLxZxm7Ce5cXlAaz5r6CCK3yH+PwUCYl0TWQ8cZ2x2QHBvc3Rl
by5uZXQACgkQa+ggit8h/j8NXQD8D9VXa9dJiKH8fF3UUc219Ftu6pN73XI7D5rx
8MNfMLMA/0tKN4ES4N3pPiGSRcKIo0+qoPXvWvLTtbVRhEszIa0w
=AjoK
-----END PGP SIGNATURE-----

Closed
M
M
Maxime Devos wrote on 18 Apr 2022 11:23
4f6d8eee044342498fc385800eabdd686965ae7a.camel@telenet.be
jgart via Guix-patches via schreef op zo 17-04-2022 om 14:47 [-0400]:
Toggle quote (2 lines)
> +(which uses the locally installed go-ipfs program).")

go-ipfs is missing from the inputs and would need to be patched into
(not sure where exactly) such that 'cl-ipfs-api2' works without 'ipfs'
being in $PATH.

Greetings,
Maxime.
-----BEGIN PGP SIGNATURE-----

iI0EABYKADUWIQTB8z7iDFKP233XAR9J4+4iGRcl7gUCYl0uGBccbWF4aW1lZGV2
b3NAdGVsZW5ldC5iZQAKCRBJ4+4iGRcl7gASAQD795aO93hoZcP7y8m6clzMlwbr
yQ+K6j4MeKkPvVCA4QEAu2CXzJ0EdjDz137u7BLUN1qrH1kYhpMSmA7DnqL7KAg=
=tq3B
-----END PGP SIGNATURE-----


J
(name . Maxime Devos)(address . maximedevos@telenet.be)(address . 54995@debbugs.gnu.org)
20220418131213.GD9547@gac.attlocal.net
On Mon, 18 Apr 2022 11:23:36 +0200 Maxime Devos <maximedevos@telenet.be> wrote:
Toggle quote (9 lines)
> jgart via Guix-patches via schreef op zo 17-04-2022 om 14:47 [-0400]:
> > +(which uses the locally installed go-ipfs program).")
>
> go-ipfs is missing from the inputs and would need to be patched into
> <https://github.com/JadedCtrl/cl-ipfs-api2/blob/master/main.lisp#L14>
> or <https://github.com/JadedCtrl/cl-ipfs-api2/blob/master/main.lisp#L837>
> (not sure where exactly) such that 'cl-ipfs-api2' works without 'ipfs'
> being in $PATH.

Thanks for catching that. I didn't realize it was a dependency.

I'll send an updated patch soon.

all best,

jgart
?