[PATCH] gnu: Add r-adam.

  • Done
  • quality assurance status badge
Details
2 participants
  • Mădălin Ionel Patrașcu
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Mădălin Ionel Patrașcu
Severity
normal

Debbugs page

Mădălin Ionel Patrașcu wrote 3 years ago
(address . guix-patches@gnu.org)
20220417081343.29275-1-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/bioconductor.scm (r-adam): New variable.
---
gnu/packages/bioconductor.scm | 35 +++++++++++++++++++++++++++++++++++
1 file changed, 35 insertions(+)

Toggle diff (50 lines)
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index bec3496057..cd28d3eb20 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -1581,6 +1581,41 @@ (define-public r-absseq
ranking by fold-change and visualization.")
(license license:gpl3+)))
+(define-public r-adam
+ (package
+ (name "r-adam")
+ (version "1.10.0")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "ADAM" version))
+ (sha256
+ (base32
+ "18zwci0ab54q7rdwj0n63w0i14lfrb4cccp09bcrq10gl1ki07f5"))))
+ (properties `((upstream-name . "ADAM")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-dplyr
+ r-dt
+ r-go-db
+ r-keggrest
+ r-knitr
+ r-pbapply
+ r-rcpp
+ r-stringr
+ r-summarizedexperiment))
+ (native-inputs (list r-knitr))
+ (home-page "https://bioconductor.org/packages/ADAM")
+ (synopsis "Gene activity and diversity analysis module")
+ (description
+ "This software @code{ADAM} is a @dfn{Gene set enrichment analysis} (GSEA)
+package created to group a set of genes from comparative samples (control
+versus experiment) belonging to different species according to their respective
+functions. The corresponding roles are extracted from the default collections
+like Gene ontology and @dfn{Kyoto encyclopedia of genes and genomes} (KEGG).
+@code{ADAM} show their significance by calculating the p-values referring to
+gene diversity and activity. Each group of genes is called @dfn{Group of
+functionally associated genes} (GFAG).")
+ (license license:gpl2+)))
+
(define-public r-aneufinder
(package
(name "r-aneufinder")

base-commit: 0c89fe9e17dc9e628c73959289464ac5f146c7cd
--
2.34.0
Ricardo Wurmus wrote 3 years ago
(address . 54985-done@debbugs.gnu.org)
874k2g6zrc.fsf@elephly.net
Applied, thanks!

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 54985@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 54985
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help