(address . guix-patches@gnu.org)(name . Imran Iqbal)(address . imran@imraniqbal.org)
* gnu/packages/lua.scm (lua-luv): Update to 1.43.0-0.
---
gnu/packages/lua.scm | 10 +++++-----
1 file changed, 5 insertions(+), 5 deletions(-)
Toggle diff (47 lines)
diff --git a/gnu/packages/lua.scm b/gnu/packages/lua.scm
index ee4b7727e0..e91d04cbd0 100644
--- a/gnu/packages/lua.scm
+++ b/gnu/packages/lua.scm
@@ -785,7 +785,7 @@ (define-public lua5.2-lpeg
(define (make-lua-luv name lua)
(package
(name name)
- (version "1.32.0-0")
+ (version "1.43.0-0")
(source (origin
;; The release tarball includes the sources of libuv but does
;; not include the pkg-config files.
@@ -796,7 +796,7 @@ (define (make-lua-luv name lua)
(file-name (git-file-name name version))
(sha256
(base32
- "0c65c1lhbl0axnyks3910gjs0z0hw7w6jvl07g8kbpnbvfl4qajh"))))
+ "1yzi4bm845vl84wyv2qw4z1n1v285lgwm681swmp84brfy2s7czp"))))
(build-system cmake-build-system)
(arguments
`(#:tests? #f ; there are none
@@ -813,7 +813,7 @@ (define (make-lua-luv name lua)
(copy-recursively (assoc-ref inputs "lua-compat")
"lua-compat")
(setenv "CPATH"
- (string-append (getcwd) "/lua-compat:"
+ (string-append (getcwd) "/lua-compat/c-api:"
(or (getenv "CPATH") "")))
#t)))))
(inputs
@@ -824,11 +824,11 @@ (define (make-lua-luv name lua)
(method git-fetch)
(uri (git-reference
(url "https://github.com/keplerproject/lua-compat-5.3")
- (commit "daebe77a2f498817713df37f0bb316db1d82222f")))
+ (commit "e245d3a18957e43ef902a59a72c8902e2e4435b9")))
(file-name "lua-compat-5.3-checkout")
(sha256
(base32
- "02a14nvn7aggg1yikj9h3dcf8aqjbxlws1bfvqbpfxv9d5phnrpz"))))))
+ "1caxn228gx48g6kymp9w7kczgxcg0v0cd5ixsx8viybzkd60dcn4"))))))
(home-page "https://github.com/luvit/luv/")
(synopsis "Libuv bindings for Lua")
(description
--
2.35.3