(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
---
This is my first git patch ever. I really hope I did everything correctly. This is imported emacs package from ELPA, but I shortened the ELPA description a bit.
I apologize for any mistakes I made. I never used this method before.
Maya
gnu/packages/emacs-xyz.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)
Toggle diff (39 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 2d95421472..e88c2898b8 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -1076,6 +1076,34 @@ (define-public emacs-nano-modeline
displayed at the bottom or at the top.")
(license license:gpl3+))))
+(define-public emacs-nano-theme
+ (package
+ (name "emacs-nano-theme")
+ (version "0.3.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://elpa.gnu.org/packages/nano-theme-"
+ version
+ ".tar"))
+ (sha256
+ (base32 "1nq5x46467vnsfg3fzb0qyg97xpnwsvbqg8frdjil5zq5fhsgmrz"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/rougier/nano-theme")
+ (synopsis "N Λ N O theme")
+ (description
+ "N Λ N O theme is a consistent theme that comes in two flavors: - a light theme
+that is based on Material (https://material.io/) - a dark theme that is based
+on Nord (https://www.nordtheme.com/).
+
+A theme is fully defined by a set of (1+6) faces as explained in this paper
+https://arxiv.org/abs/2008.06030
+
+Recommended font is \"Roboto Mono\" or \"Roboto Mono Nerd\" if you want to benefit
+from all the fancy glyphs.")
+ (license license:gpl3+)))
+
(define-public emacs-moody
(package
(name "emacs-moody")
--
2.35.1