[PATCH] gnu: emacs-chess: Fix path to pieces.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Michael Rohleder
Owner
unassigned
Submitted by
Michael Rohleder
Severity
normal

Debbugs page

Michael Rohleder wrote 3 years ago
(address . guix-patches@gnu.org)(name . Michael Rohleder)(address . mike@rohleder.de)
20220415074040.10300-1-mike@rohleder.de
* gnu/packages/emacs-xyz.scm (emacs-chess)[arguments]: Fix path to pieces in
phase install-pieces.
---
emacs-chess doesn't find the piece graphics, because it searches them in
"/share/emacs/site-lisp/chess-2.0.5/pieces" not "/share/emacs/site-lisp/pieces".

gnu/packages/emacs-xyz.scm | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)

Toggle diff (16 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 2d95421472..e4607be09f 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -8454,7 +8454,8 @@ (define-public emacs-chess
(add-after 'install 'install-pieces
(lambda _
(let ((pieces
- (string-append #$output "/share/emacs/site-lisp/pieces")))
+ (string-append #$output "/share/emacs/site-lisp/chess-"
+ #$version "/pieces")))
(mkdir-p pieces)
(copy-recursively "pieces" pieces)))))))
(home-page "https://elpa.gnu.org/packages/chess.html")
--
2.35.1
Ludovic Courtès wrote 3 years ago
(name . Michael Rohleder)(address . mike@rohleder.de)(address . 54948-done@debbugs.gnu.org)
87lew2t76o.fsf@gnu.org
Michael Rohleder <mike@rohleder.de> skribis:

Toggle quote (3 lines)
> * gnu/packages/emacs-xyz.scm (emacs-chess)[arguments]: Fix path to pieces in
> phase install-pieces.

Applied, thanks!
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 54948@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 54948
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help