more than one target service of type 'account'

  • Open
  • quality assurance status badge
Details
2 participants
  • Maxim Cournoyer
  • raingloom
Owner
unassigned
Submitted by
raingloom
Severity
normal
R
R
raingloom wrote on 14 Apr 2022 06:49
(name . Guix Bugs)(address . bug-guix@gnu.org)
20220414064918.366daeb3@riseup.net
Toggle quote (2 lines)
> more than one target service of type 'account'

I did not add any new service, I just modified openssh-service-type.

```
(operating-system
(inherit os)
(services
(modify-services
(operating-system-services os)
(openssh-service-type
config =>
(openssh-configuration
(inherit config)
(permit-root-login 'without-password))))))
```

Full system description in attachment.
;; TODO convert to R6RS module syntax? (use-modules (gnu packages android) (gnu packages bootloaders) (gnu packages certs) (gnu packages cups) (gnu packages ghostscript) (gnu packages gnome) (gnu packages linux) (gnu packages networking) (gnu packages package-management) (gnu packages shells) (gnu packages suckless) (gnu packages wm) (gnu packages xdisorg) (gnu packages xorg) (gnu services cups) (gnu services desktop) (gnu services linux) (gnu services networking) (gnu services ssh) (gnu services virtualization) (gnu services xorg) (gnu services) (gnu system install) (gnu system nss) (gnu system shadow)) ;; this is for devices with no screen, or UART, or anything of the sort ;; the name is apt though, because this completely ruins security! ;; DO NOT USE THIS FOR THE FINAL SYSTEM ;; use it only for the inital setup, then reconfigure with a proper config (define-public (backdoor-os os) (operating-system (inherit os) (services (modify-services (operating-system-services os) (openssh-service-type config => (openssh-configuration (inherit config) (permit-root-login 'without-password))))))) (define-public backdoored-installation-os (backdoor-os installation-os)) ;; guix system: error: more than one target service of type 'account' backdoored-installation-os
M
M
Maxim Cournoyer wrote on 8 Jun 2022 22:19
(name . raingloom)(address . raingloom@riseup.net)(address . 54923@debbugs.gnu.org)
87ilpakiwq.fsf@gmail.com
Hello!

raingloom <raingloom@riseup.net> writes:

Toggle quote (17 lines)
>> more than one target service of type 'account'
>
> I did not add any new service, I just modified openssh-service-type.
>
> ```
> (operating-system
> (inherit os)
> (services
> (modify-services
> (operating-system-services os)
> (openssh-service-type
> config =>
> (openssh-configuration
> (inherit config)
> (permit-root-login 'without-password))))))
> ```

I think it's becaused you used operating-system-services instead of
operating-system-user-services; could you try again with the later?

Thanks,

Maxim
M
M
Maxim Cournoyer wrote on 8 Jun 2022 22:22
control message for bug #54923
(address . control@debbugs.gnu.org)
87fskekir0.fsf@gmail.com
tags 54923 + moreinfo
quit
?