[PATCH] gnu: Add r-acme.

  • Done
  • quality assurance status badge
Details
2 participants
  • Mădălin Ionel Patrașcu
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Mădălin Ionel Patrașcu
Severity
normal

Debbugs page

Mădălin Ionel Patrașcu wrote 3 years ago
(address . guix-patches@gnu.org)
20220413141258.30929-1-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/bioconductor.scm (r-acme): New variable.
---
gnu/packages/bioconductor.scm | 30 ++++++++++++++++++++++++++++++
1 file changed, 30 insertions(+)

Toggle diff (43 lines)
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 803437a033..69e9e14dd3 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -11642,6 +11642,36 @@ (define-public r-universalmotif
motifs, and others.")
(license license:gpl3)))
+;; The homepage (http://watson.nci.nih.gov/~sdavis) seems to be inaccessible
+;; anymore so I changed it to the Bioconductor page of the package.
+(define-public r-acme
+ (package
+ (name "r-acme")
+ (version "2.50.0")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "ACME" version))
+ (sha256
+ (base32
+ "0h4bqbbqcwc938q7lysk5l35f64xz9d1bsniv2wshmlr4rr0zpcg"))))
+ (properties `((upstream-name . "ACME")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-biobase r-biocgenerics))
+ (home-page "https://bioconductor.org/packages/aCGH/")
+ (synopsis "Calculating microarray enrichment")
+ (description
+ "This package implements
+@dfn{algorithms for calculating microarray enrichment} (ACME), and it is a set
+of tools for analysing tiling array of
+@dfn{combined chromatin immunoprecipitation with DNA microarray} (ChIP/chip),
+DNAse hypersensitivity, or other experiments that result in regions of the
+genome showing enrichment. It does not rely on a specific array technology
+(although the array should be a tiling array), is very general (can be applied
+in experiments resulting in regions of enrichment), and is very insensitive to
+array noise or normalization methods. It is also very fast and can be applied
+on whole-genome tiling array experiments quite easily with enough memory.")
+ (license license:gpl2+)))
+
;; This is a CRAN package, but it depends on Bioconductor packages, so we put
;; it here.
(define-public r-activedriverwgs
--
2.34.0
Ricardo Wurmus wrote 3 years ago
(address . 54912-done@debbugs.gnu.org)
87ilrcvt9d.fsf@elephly.net
Applied, thanks!

I removed the comment at the top, because the bioc home page is fine to
use. The importer just extracts the home page as it is declared in the
package’s DESCRIPTION file. It’s not unusual that the home page there
has been abandoned as developers often forget about updating the
DESCRIPTION file.

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 54912@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 54912
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help