[PATCH] gnu: Add r-absseq.

  • Done
  • quality assurance status badge
Details
2 participants
  • Mădălin Ionel Patrașcu
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Mădălin Ionel Patrașcu
Severity
normal

Debbugs page

Mădălin Ionel Patrașcu wrote 3 years ago
(address . guix-patches@gnu.org)
20220412215755.8819-1-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/bioconductor.scm (r-absseq): New variable.
---
gnu/packages/bioconductor.scm | 29 +++++++++++++++++++++++++++++
1 file changed, 29 insertions(+)

Toggle diff (42 lines)
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 803437a033..25e02bebad 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -1139,6 +1139,35 @@ (define-public r-abadata
All datasets are restricted to protein coding genes.")
(license license:gpl2+)))
+(define-public r-absseq
+ (package
+ (name "r-absseq")
+ (version "1.48.0")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "ABSSeq" version))
+ (sha256
+ (base32
+ "0l2hh6qv4lhw1g1kciw2f3ssj3lw83hqxnkmxzmv7snik3k6i650"))))
+ (properties `((upstream-name . "ABSSeq")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-limma r-locfit))
+ (home-page "https://bioconductor.org/packages/ABSSeq")
+ (synopsis
+ "RNA-Seq analysis based on modelling absolute expression differences")
+ (description
+ "This package @code{ABSSeq} implements a new RNA-Seq analysis method and
+integrates two modules: a basic model for pairwise comparison and a linear
+model for complex design. RNA-Seq quantifies gene expression with reads count,
+which usually consists of conditions (or treatments) and several replicates for
+each condition. This software infers differential expression directly by the
+counts difference between conditions. It assumes that the sum counts
+difference between conditions follow a negative binomial distribution. In
+addition, @code{ABSSeq} moderates the fold-changes by two steps: the expression
+level and gene-specific dispersion, that might facilitate the gene ranking by
+fold-change and visualization.")
+ (license license:gpl3+)))
+
(define-public r-aneufinderdata
(package
(name "r-aneufinderdata")
--
2.34.0
Ricardo Wurmus wrote 3 years ago
(address . 54896-done@debbugs.gnu.org)
871qxzx5pr.fsf@elephly.net
Applied, thanks!

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 54896@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 54896
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help