(address . guix-patches@gnu.org)
Hello Guix,
I have a need to use ncurses-with-tinfo@5.
The ncurses package embeds the version string in various places, and even
hard-codes the version-major 6 in a couple places, making it impractical to
just create a transformation.
Is this patch reasonable?
From 8ed5fceb8b0bcbfc39505b4a74bb7eed93dfdaf9 Mon Sep 17 00:00:00 2001
From: "B. Wilson" <elaexuotee@wilsonb.com>
Date: Tue, 12 Apr 2022 12:09:26 +0900
Subject: [PATCH] gnu: Add ncurses-5, ncurses/tinfo-5
To: guix-patches@gnu.org
* gnu/packages/ncurses.scm (ncurses-5, ncurses/tinfo-5): New varaibles.
---
gnu/packages/ncurses.scm | 49 ++++++++++++++++++++++++++++++----------
1 file changed, 37 insertions(+), 12 deletions(-)
Toggle diff (105 lines)
diff --git a/gnu/packages/ncurses.scm b/gnu/packages/ncurses.scm
index 5b00da25bb..afca7b0208 100644
--- a/gnu/packages/ncurses.scm
+++ b/gnu/packages/ncurses.scm
@@ -39,18 +39,19 @@ (define-module (gnu packages ncurses)
#:use-module (guix utils)
#:use-module (ice-9 match))
-(define-public ncurses
+(define* (make-ncurses-package #:key
+ version
+ source-hash
+ rollup-patch-hash)
(package
(name "ncurses")
- (version "6.2.20210619")
+ (version version)
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/ncurses/ncurses-"
(version-major+minor version)
".tar.gz"))
- (sha256
- (base32
- "17bcm2z1rdx5gmzj5fb8cp7f28aw5b4g2z4qvvqg3yg0fq66wc1h"))))
+ (sha256 (base32 source-hash))))
(build-system gnu-build-system)
(outputs '("out"
"doc")) ;1 MiB of man pages
@@ -130,10 +131,12 @@ (define lib.a
(string-append "lib" lib ".a"))
,@(if (not (target-mingw?))
- '((define libw.so.x
- (string-append "lib" lib "w.so.6"))
+ `((define libw.so.x
+ (string-append "lib" lib "w.so."
+ ,(version-major version)))
(define lib.so.x
- (string-append "lib" lib ".so.6"))
+ (string-append "lib" lib ".so."
+ ,(version-major version)))
(define lib.so
(string-append "lib" lib ".so"))
(define packagew.pc
@@ -192,7 +195,9 @@ (define package.pc
"cf_cv_ld_searchpath=/no-ld-searchpath"
;; MinGW: Use term-driver created for the MinGW port.
- ,@(if (target-mingw?) '("--enable-term-driver") '()))))
+ ,@(if (target-mingw?) '("--enable-term-driver") '())
+
+ ,@extra-configure-flags)))
#:tests? #f ; no "check" target
#:phases (modify-phases %standard-phases
(add-after 'unpack 'apply-rollup-patch
@@ -216,9 +221,7 @@ (define package.pc
(string-append "https://invisible-mirror.net/archives"
"/ncurses/" major "." minor "/ncurses-"
major "." minor "-" point "-patch.sh.bz2"))))
- (sha256
- (base32
- "1b6522cvi4066bgh9lp93q8lk93zcjjssvnw1512z447xvazy2y6"))))
+ (sha256 (base32 rollup-patch-hash))))
("pkg-config" ,pkg-config)))
(native-search-paths
(list (search-path-specification
@@ -234,6 +237,18 @@ (define package.pc
(license x11)
(home-page "https://www.gnu.org/software/ncurses/")))
+(define-public ncurses
+ (make-ncurses-package
+ #:version "6.2.20210619"
+ #:source-hash "17bcm2z1rdx5gmzj5fb8cp7f28aw5b4g2z4qvvqg3yg0fq66wc1h"
+ #:rollup-patch-hash "1b6522cvi4066bgh9lp93q8lk93zcjjssvnw1512z447xvazy2y6"))
+
+(define-public ncurses-5
+ (make-ncurses-package
+ #:version "5.9.20141206"
+ #:source-hash "0fsn7xis81za62afan0vvm38bvgzg5wfmv1m86flqcj0nj7jjilh"
+ #:rollup-patch-hash "16ny892yhimy6r4mmsgw3rcl0i15570ifn9c54g1ndyrk7kpmlgs"))
+
(define-public ncurses/gpm
(package/inherit ncurses
(name "ncurses-with-gpm")
@@ -258,6 +273,16 @@ (define-public ncurses/tinfo
`(cons "--with-termlib=tinfo"
,cf))))))
+;; Consider merging into ncurses for next core-updates cycle.
+(define-public ncurses/tinfo-5
+ (package/inherit ncurses-5
+ (name "ncurses-with-tinfo")
+ (arguments
+ (substitute-keyword-arguments (package-arguments ncurses-5)
+ ((#:configure-flags cf)
+ `(cons "--with-termlib=tinfo"
+ ,cf))))))
+
(define-public dialog
(package
(name "dialog")
--
2.35.1