LLVM 3.* build failure

  • Open
  • quality assurance status badge
Details
2 participants
  • Guillaume Le Vaillant
  • Maxime Devos
Owner
unassigned
Submitted by
Guillaume Le Vaillant
Severity
normal
G
G
Guillaume Le Vaillant wrote on 10 Apr 2022 16:23
(address . bug-guix@gnu.org)
87ilrhdmyo.fsf@kitej
The clamav package can't be built right know because it depends on
llvm-3.6 which fails to build. In fact, all the llvm-3.* packages fail
to build with the same error:

Toggle snippet (12 lines)
The following derivation will be built:
/gnu/store/7rh78xkkglsx289s9j6fdxwfwakqdhv8-llvm-3.6.2.drv
building /gnu/store/7rh78xkkglsx289s9j6fdxwfwakqdhv8-llvm-3.6.2.drv...
ice-9/read.scm:126:4: In procedure read-expr*:
/gnu/store/kj78hgwyb11z2sxz4xfd3v9sd93xk7yc-llvm-3.6.2-builder:1:3078: Unknown # object: "#<"
builder for `/gnu/store/7rh78xkkglsx289s9j6fdxwfwakqdhv8-llvm-3.6.2.drv' failed with exit code 1
build of /gnu/store/7rh78xkkglsx289s9j6fdxwfwakqdhv8-llvm-3.6.2.drv failed
View build log at '/var/log/guix/drvs/7r/h78xkkglsx289s9j6fdxwfwakqdhv8-llvm-3.6.2.drv.gz'.
guix build: error: build of `/gnu/store/7rh78xkkglsx289s9j6fdxwfwakqdhv8-llvm-3.6.2.drv' failed


It looks like the problem comes from a gexp in the builder. There's
a gexp inside another gexp, but I don't know if that's the problem:

Toggle snippet (3 lines)
#:phases (modify-phases #<gexp (modify-phases #<gexp-input #<gexp ...

The full builder file is in attachment.
M
M
Maxime Devos wrote on 10 Apr 2022 17:50
a8fcb64c1067f3c8da9e8cc1bdefea5748fe0764.camel@telenet.be
Guillaume Le Vaillant schreef op zo 10-04-2022 om 14:23 [+0000]:
Toggle quote (6 lines)
> It looks like the problem comes from a gexp in the builder. There's
> a gexp inside another gexp, but I don't know if that's the problem:
>
> --8<---------------cut here---------------start------------->8---
> #:phases (modify-phases #<gexp (modify-phases #<gexp-input #<gexp ...

Suggestion:

Replace

(substitute-keyword-arguments (package-arguments llvm)
((#:phases phases)
`(modify-phases ,phases
(delete 'install-opt-viewer)))))))

by

(substitute-keyword-arguments (package-arguments llvm)
((#:phases phases)
#~(modify-phases #$phases
(delete 'install-opt-viewer)))))))

in llvm-3.9.1.

Greetings,
Maxime.
-----BEGIN PGP SIGNATURE-----

iI0EABYKADUWIQTB8z7iDFKP233XAR9J4+4iGRcl7gUCYlL8zxccbWF4aW1lZGV2
b3NAdGVsZW5ldC5iZQAKCRBJ4+4iGRcl7hKAAP95Lyf7siYZsWBSu5Gz9+siKUks
xwe8A4fXQyVPnC89OAD/YsfiHDMTW7ebXo6yeitdfR2p8MtKrlhkuO1kZBLauQ0=
=2FGL
-----END PGP SIGNATURE-----


G
G
Guillaume Le Vaillant wrote on 10 Apr 2022 18:42
(name . Maxime Devos)(address . maximedevos@telenet.be)(address . 54837@debbugs.gnu.org)
87ee24evb2.fsf@kitej
Maxime Devos <maximedevos@telenet.be> skribis:

Toggle quote (25 lines)
> Guillaume Le Vaillant schreef op zo 10-04-2022 om 14:23 [+0000]:
>> It looks like the problem comes from a gexp in the builder. There's
>> a gexp inside another gexp, but I don't know if that's the problem:
>>
>> --8<---------------cut here---------------start------------->8---
>> #:phases (modify-phases #<gexp (modify-phases #<gexp-input #<gexp ...
>
> Suggestion:
>
> Replace
>
> (substitute-keyword-arguments (package-arguments llvm)
> ((#:phases phases)
> `(modify-phases ,phases
> (delete 'install-opt-viewer)))))))
>
> by
>
> (substitute-keyword-arguments (package-arguments llvm)
> ((#:phases phases)
> #~(modify-phases #$phases
> (delete 'install-opt-viewer)))))))
>
> in llvm-3.9.1.

Thanks, that solves the builder issue.

However there are other issues during the build phase:

Toggle snippet (18 lines)
../../bin/llvm-tblgen: error while loading shared libraries: libLLVMTableGen.so: cannot open shared object file: No such file or directory
make[2]: *** [lib/IR/CMakeFiles/AttributeCompatFuncTableGen.dir/build.make:105: lib/IR/AttributesCompatFunc.inc.tmp] Error 127
make[2]: Leaving directory '/tmp/guix-build-llvm-3.9.1.drv-0/build'
make[1]: *** [CMakeFiles/Makefile2:5233: lib/IR/CMakeFiles/AttributeCompatFuncTableGen.dir/all] Error 2
make[1]: *** Waiting for unfinished jobs....
../../bin/llvm-tblgen: error while loading shared libraries: libLLVMTableGen.so: cannot open shared object file: No such file or directory
make[2]: *** [lib/LibDriver/CMakeFiles/LibOptionsTableGen.dir/build.make:105: lib/LibDriver/Options.inc.tmp] Error 127
make[2]: Leaving directory '/tmp/guix-build-llvm-3.9.1.drv-0/build'
make[1]: *** [CMakeFiles/Makefile2:12101: lib/LibDriver/CMakeFiles/LibOptionsTableGen.dir/all] Error 2
../../../bin/llvm-tblgen: error while loading shared libraries: libLLVMTableGen.so: cannot open shared object file: No such file or directory
make[2]: *** [include/llvm/IR/CMakeFiles/intrinsics_gen.dir/build.make:123: include/llvm/IR/Attributes.inc.tmp] Error 127
make[2]: *** Waiting for unfinished jobs....
../../../bin/llvm-tblgen: error while loading shared libraries: libLLVMTableGen.so: cannot open shared object file: No such file or directory
make[2]: *** [include/llvm/IR/CMakeFiles/intrinsics_gen.dir/build.make:165: include/llvm/IR/Intrinsics.gen.tmp] Error 127
make[2]: Leaving directory '/tmp/guix-build-llvm-3.9.1.drv-0/build'
make[1]: *** [CMakeFiles/Makefile2:5153: include/llvm/IR/CMakeFiles/intrinsics_gen.dir/all] Error 2
make[2]: Leaving directory '/tmp/guix-build-llvm-3.9.1.drv-0/build'
-----BEGIN PGP SIGNATURE-----

iIUEAREKAC0WIQTLxZxm7Ce5cXlAaz5r6CCK3yH+PwUCYlMLAQ8cZ2x2QHBvc3Rl
by5uZXQACgkQa+ggit8h/j916AEAnTnp6sFUE32T+9ZRUiIvDHLKPFdP6kCbc90X
rGIpuEMA/RGiHTJak/O5n/c3wnigKcJHx4dDYvRqQ15v5BqAMM0h
=7thQ
-----END PGP SIGNATURE-----

G
G
Guillaume Le Vaillant wrote on 10 Apr 2022 19:07
(name . Guillaume Le Vaillant)(address . glv@posteo.net)(address . 54837@debbugs.gnu.org)
87a6cseuhm.fsf@kitej
Guillaume Le Vaillant <glv@posteo.net> skribis:

Toggle quote (20 lines)
> However there are other issues during the build phase:
>
> ../../bin/llvm-tblgen: error while loading shared libraries: libLLVMTableGen.so: cannot open shared object file: No such file or directory
> make[2]: *** [lib/IR/CMakeFiles/AttributeCompatFuncTableGen.dir/build.make:105: lib/IR/AttributesCompatFunc.inc.tmp] Error 127
> make[2]: Leaving directory '/tmp/guix-build-llvm-3.9.1.drv-0/build'
> make[1]: *** [CMakeFiles/Makefile2:5233: lib/IR/CMakeFiles/AttributeCompatFuncTableGen.dir/all] Error 2
> make[1]: *** Waiting for unfinished jobs....
> ../../bin/llvm-tblgen: error while loading shared libraries: libLLVMTableGen.so: cannot open shared object file: No such file or directory
> make[2]: *** [lib/LibDriver/CMakeFiles/LibOptionsTableGen.dir/build.make:105: lib/LibDriver/Options.inc.tmp] Error 127
> make[2]: Leaving directory '/tmp/guix-build-llvm-3.9.1.drv-0/build'
> make[1]: *** [CMakeFiles/Makefile2:12101: lib/LibDriver/CMakeFiles/LibOptionsTableGen.dir/all] Error 2
> ../../../bin/llvm-tblgen: error while loading shared libraries: libLLVMTableGen.so: cannot open shared object file: No such file or directory
> make[2]: *** [include/llvm/IR/CMakeFiles/intrinsics_gen.dir/build.make:123: include/llvm/IR/Attributes.inc.tmp] Error 127
> make[2]: *** Waiting for unfinished jobs....
> ../../../bin/llvm-tblgen: error while loading shared libraries: libLLVMTableGen.so: cannot open shared object file: No such file or directory
> make[2]: *** [include/llvm/IR/CMakeFiles/intrinsics_gen.dir/build.make:165: include/llvm/IR/Intrinsics.gen.tmp] Error 127
> make[2]: Leaving directory '/tmp/guix-build-llvm-3.9.1.drv-0/build'
> make[1]: *** [CMakeFiles/Makefile2:5153: include/llvm/IR/CMakeFiles/intrinsics_gen.dir/all] Error 2
> make[2]: Leaving directory '/tmp/guix-build-llvm-3.9.1.drv-0/build'

It looks like llvm-12 has a workaround for this issue. I'll copy it to
llvm-3.9 and test that...
-----BEGIN PGP SIGNATURE-----

iIUEAREKAC0WIQTLxZxm7Ce5cXlAaz5r6CCK3yH+PwUCYlMPJQ8cZ2x2QHBvc3Rl
by5uZXQACgkQa+ggit8h/j+4pgD/Yo+L6uyakomMgxOiHR+QYDZbSfiuhbCtSBr2
z1dWV/UA/3lUjzzB7kPGTAA/fCv9xFPQqbe3r/lpi+AQQzrsMvjY
=h/di
-----END PGP SIGNATURE-----

G
G
Guillaume Le Vaillant wrote on 10 Apr 2022 19:23
(name . Guillaume Le Vaillant)(address . glv@posteo.net)(address . 54837@debbugs.gnu.org)
875yngeto3.fsf@kitej
Guillaume Le Vaillant <glv@posteo.net> skribis:

Toggle quote (25 lines)
> Guillaume Le Vaillant <glv@posteo.net> skribis:
>
>> However there are other issues during the build phase:
>>
>> ../../bin/llvm-tblgen: error while loading shared libraries: libLLVMTableGen.so: cannot open shared object file: No such file or directory
>> make[2]: *** [lib/IR/CMakeFiles/AttributeCompatFuncTableGen.dir/build.make:105: lib/IR/AttributesCompatFunc.inc.tmp] Error 127
>> make[2]: Leaving directory '/tmp/guix-build-llvm-3.9.1.drv-0/build'
>> make[1]: *** [CMakeFiles/Makefile2:5233: lib/IR/CMakeFiles/AttributeCompatFuncTableGen.dir/all] Error 2
>> make[1]: *** Waiting for unfinished jobs....
>> ../../bin/llvm-tblgen: error while loading shared libraries: libLLVMTableGen.so: cannot open shared object file: No such file or directory
>> make[2]: *** [lib/LibDriver/CMakeFiles/LibOptionsTableGen.dir/build.make:105: lib/LibDriver/Options.inc.tmp] Error 127
>> make[2]: Leaving directory '/tmp/guix-build-llvm-3.9.1.drv-0/build'
>> make[1]: *** [CMakeFiles/Makefile2:12101: lib/LibDriver/CMakeFiles/LibOptionsTableGen.dir/all] Error 2
>> ../../../bin/llvm-tblgen: error while loading shared libraries: libLLVMTableGen.so: cannot open shared object file: No such file or directory
>> make[2]: *** [include/llvm/IR/CMakeFiles/intrinsics_gen.dir/build.make:123: include/llvm/IR/Attributes.inc.tmp] Error 127
>> make[2]: *** Waiting for unfinished jobs....
>> ../../../bin/llvm-tblgen: error while loading shared libraries: libLLVMTableGen.so: cannot open shared object file: No such file or directory
>> make[2]: *** [include/llvm/IR/CMakeFiles/intrinsics_gen.dir/build.make:165: include/llvm/IR/Intrinsics.gen.tmp] Error 127
>> make[2]: Leaving directory '/tmp/guix-build-llvm-3.9.1.drv-0/build'
>> make[1]: *** [CMakeFiles/Makefile2:5153: include/llvm/IR/CMakeFiles/intrinsics_gen.dir/all] Error 2
>> make[2]: Leaving directory '/tmp/guix-build-llvm-3.9.1.drv-0/build'
>
> It looks like llvm-12 has a workaround for this issue. I'll copy it to
> llvm-3.9 and test that...

Partial fix pushed in 81567f751bd31d972cf05013a177311b73425d7d; the
builds for llvm-3.7 and llvm-3.8 are still failing.
-----BEGIN PGP SIGNATURE-----

iIUEAREKAC0WIQTLxZxm7Ce5cXlAaz5r6CCK3yH+PwUCYlMTTA8cZ2x2QHBvc3Rl
by5uZXQACgkQa+ggit8h/j9SbgEAos6sKMAa/mpO/DQT5++4C70ddHf5Id9kAiZO
nwUvDVwA/i6p28GvHi1ZxvYl1f1EdS7/hbF60y6mrV1OCcd6rUBm
=ykn3
-----END PGP SIGNATURE-----

?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 54837@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 54837
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch